[nsp] eBGP establishment

From: chris (chris@chrisland.net)
Date: Thu Jun 20 2002 - 10:41:37 EDT


Dear all,

I have this network setup:

 Router A <-eth0-------eth0-> Router B

and simplified config:

--------------------
! Router A
interface loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface ethernet0
 ip address 10.0.0.1 255.255.255.0
!
router bgp 65501
 neighbor 192.168.0.2 remote-as 65502
 neighbor 192.168.0.2 update-source loopback0
 neighbor 192.168.0.2 ebgp-multihop 2
!
ip route 0.0.0.0 0.0.0.0 10.0.0.2
--------------------
! Router B
interface loopback0
 ip address 192.168.0.2 255.255.255.255
!
interface ethernet0
 ip address 10.0.0.2 255.255.255.0
!
router bgp 65502
 neighbor 192.168.0.1 remote-as 65501
 neighbor 192.168.0.1 update-source loopback0
 neighbor 192.168.0.1 ebgp-multihop 2
!
ip route 0.0.0.0 0.0.0.0 10.0.0.1
--------------------

BGP between 2 routers cannot be established. However, when I add a
route of another router's loopback in either one router, it will be up.
E.g.

! Router A
ip route 192.168.0.2 255.255.255.255 10.0.0.2

Is it normal? (in the sense that I only need to add this route in 1
router, not both.)

Thanks.

Regards,
Chris



This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:12:00 EDT