RE: [nsp] Unusual load balancing with policing...

From: Stephane Perez (perezs@nortelnetworks.com)
Date: Thu Apr 11 2002 - 09:35:57 EDT


Hi,

hmmm..., my feeling is the following:

 When a packet comes into the box (NetX) it first use the routing table and
then beeing forwarded to the outoing interface. This interface has got the
policy map applied to and then gets the traffic policying, all traffic under
1Mb will be forwarded to the Next-Hop X with IP-Precedence of 5 and all
traffic exceeding 1 Mb will be forwarded to X as well but only marked as 6.

 The route-map never uses the routing table and if a packet with an already
marked IP-Precedence of 6 is coming into the router, only at that point the
packet will be forwarded to the outgoing interface Y.

 One solution could be the use of a layer 3 routing protocol such as EIGRP.
I know this could be possible but need tests however this is not really a
beautiful solution as by modifying the EIGRP metric parameters I think about
K1, K2, ... K5 you will be able to influence that routing.
 The bad thing by modifying theses metrics are, the routing table will no
longer became stable and the metrics are changed (EIGRP updates) per EIGRP
timer basis depending on the traffic flow on the Main interface (serial 6).
Usually we do not want to do this.

I hope this can help

regards

----------------------------------------------------------------------------
----------------------------------------------------------------------------
----------------
PEREZ Stephane
Carrier IP Specialist, Shasta GTS
Nortel Networks
ATS IP Core Infrastructure
25, allee Pierre Ziller
06560 Valbonne, FRANCE
Phone: +33 4 92 96 18 05 Mail : mailto:perezs@nortelnetworks.com
Fax : +33 4 92 96 16 68 www : http://www.nortelnetworks.com
Esn : 296-1805 Intranet :
http://hector.europe.nortel.com
ICQ : 120356046

-----Original Message-----
From: ivac+cisco-nsp@iskon.hr [mailto:ivac+cisco-nsp@iskon.hr]
Sent: Thursday, April 11, 2002 2:34 PM
To: cisco-nsp@puck.nether.net
Subject: [nsp] Unusual load balancing with policing...

Hello,
I'd like to here your thoughts about this problem. Idea is to make
special kind of load balancing over two (or more) links but with
predefined bandwidth limits. Below is example

                ------ ------
               | | a s1| |
10.0.0.0/24 - | RA |----------| RB | - NetX
               | |X | |
                ------ ------
                   \ /
                    \ /
                     \ ------ /
                    c \ | | / b
                       \| RC |/
                        | |Y
                         ------

Packets from NetX to 10.0.0.0/24 should go through link "a" when
bandwidth is below 1Mb/s, and everything above 1Mb/s should go through
link "b" (and than through "c").

What I came up is combination of policy-map and route-map:
(I am aware that this puts significant burden on cpu)

Router RB:

class-map match-all Limit
  match access-group 100
!
policy-map Limit
  class Limit
     police 1000000 50000 50000 conform-action set-prec-transmit 5
exceed-action set-prec-transmit 6
!
interface Serial 6/0
 ip policy route-map Limit
 service-policy input Limit
!
access-list 100 permit ip any 10.0.0.0 0.0.0.255
access-list 100 deny ip any any
!
access-list 101 permit ip any 10.0.0.0 0.0.0.255 precedence 5
access-list 101 deny ip any any
!
access-list 102 permit ip any 10.0.0.0 0.0.0.255 precedence 6
access-list 102 deny ip any any
!
route-map Limit permit 10
 match ip address 101
 set ip next-hop X
!
route-map Limit permit 15
 match ip address 102
 set ip next-hop Y

Unfortunately this doesn't work, because route-map doesn't match
precedences set by policy-map (probably order of operation is first
route-map then policy-map; can someone confirm this??).

One solution is to mark packets in NetX, before they enter RB and then
route them according to precedence flag.

Can you advise better (less cpu intensive) solution?



This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:13:40 EDT