RE: [nsp] REG: MPLS VPN route exchange

From: Scott Morris (smorris@mentortech.com)
Date: Tue Oct 10 2000 - 09:16:07 EDT


No problems. :)

You're correct on the BGP route maps. Whether it's import or export is
really a design call, but in my opinion, filtering at the point where you
FIRST put them into a particular VRF/RD would seem to be the best option (so
"import" to a particular VRF on a PE).

Example.... Hmmm.... Ok.

-------
ip cef distributed

ip vrf vrf1
 rd 100:1
 route-target both 100:1

ip vrf vrf2
 rd 100:2
 route-target both 100:2
 route-target import 100:1
 import map vrf2_import

ip vrf vrf_blue
 rd 100:3

ip vrf vrf_red
 rd 173.13.0.12:200

interface ethernet 5/0/1
 ip vrf forwarding vrf1
 ip address 10.20.0.13 255.255.255.0

interface hssi 10/1/0.16 point-to-point
 ip vrf forwarding vrf2
 ip address 10.20.1.13 255.255.255.0
 frame-relay interface-dlci 16

ip route vrf vrf1 10.0.0.0 255.0.0.0 ethernet 5/0/1 10.20.0.60

route-map vrf2_import permit 10
 match ip address 2

access-list 2 permit 10.20.4.0 0.0.0.255

router bgp 1
 no synchronization
 no bgp default ipv4-activate
 neighbor 10.15.0.15 remote-as 1
 neighbor 10.15.0.15 update-source loopback 0

address-family vpnv4 unicast
 neighbor 10.15.0.15 activate
 exit-address-family

address-family ipv4 unicast vrf vrf1
 redistribute static
 redistribute connected
 neighbor 10.20.0.60 remote-as 65535
 neighbor 10.20.0.60 activate
 no auto-summary
 exit-address-family

address-family ipv4 unicast vrf vrf2
 redistribute static
 redistribute connected
 neighbor 10.20.1.11 remote-as 65535
 neighbor 10.20.1.11 update-source hssi 10/1/0.16
 neighbor 10.20.1.11 activate
 no auto-summary
 exit-address-family
-------------

That gives an example of different types of VRFs (obviously name them
however makes sense to you). In the VRF setup, you can import or export,
and call a particular route map (generic, all-purpose route-maps, that work
as they always do!). in the BGP address-families, the nice thing about it
is that you can call all of the BGP tweaks that you may need to do (or none
if you don't need to). But, as you can see, the setup can get complicated.
In small VPNs, it'll be easy. (great place to learn!) The larger ones will
get more complicated...

Now, along those lines for learning, I'd suggest watching what's going on to
see how routes are moved and added....

Show & debug:

show ip vrf [ brief | detail | interfaces ]
show ip bgp vpnv4 all

debug ip bgp vpnv4

Those will help lots!
BGP populates the VRFs as you tell it to...

For traffic engineering, there are different ways to do it. In an MPLS
core, you need a routing protocol capable of MPLS traffic engineering.
Right now, ISIS is the primary one (wide-metrics), and OSPF is coming along
as well (LSA 10 - Opaque LSA). Or, you can let RSVP work its magic... Or,
you can statically engineer it, but that's a lot more manual labor!

Hope this helps....

Scott Morris, MCSE, CNE(3.x), CCDP (R&S), CCIE (R&S) #4713, Security
Specialization, CCNA - WAN Switching
CCSI #21903
smorris@mentortech.com
----------------------------------------------------------------------------
------------------------------
Mentor Technologies Group, Inc. http://www.mentortech.com
Formerly Chesapeake Network Solutions http://www.ccci.com

  -----Original Message-----
  From: Vinod Anthony Joseph Cherunni [mailto:vac@dsqworld.com]
  Sent: Tuesday, October 10, 2000 6:32 AM
  To: smorris@mentortech.com
  Cc: cisco-nsp@puck.nether.net
  Subject: RE: [nsp] REG: MPLS VPN route exchange

  Hi,

  Thanks a ton once again for all the advice & suggestions. Just going back
to our previous discussion, Could I take the privilege of taking up some of
your time pls.

  Going back to the scenario of one customer site being part of two VPN's
(First connection being part of an Intranet VPN, & the next connection to an
Extranet, using a second VPN), Wherein the Extranet partner needs to only be
aware of only a particular address space of this customer. The solution is
using BGP route maps, But where are the filters applied? Is it generally
applied while routes are exported or while they are imported. Could I also
have a small configuration example illustrating the same with route maps
applied to the route-targets pls.

  I would like to understand the process of the VRF getting populated with
the necessary routes. My understanding is that MBGP is used to exchange VPN
routes between PE routers. Now once the PE router has an entire list of
routers pertaining to various RD's. How is the VRF populated? Does BGP
populate the VRF based on the route-target criteria specified in each &
every VRF.

  Could I have a small MBGP configuration example between two PE routers,
illustrating the exchange of VPN routes, assuming I run static routing with
my customers.

  While I am trying to offer guarantees on bandwidth on an IP MPLS core, I
understand traffic engineering will do the job, But there seem to be various
options on provisioning Traffic engineering (Through RSVP etc). Which is the
best way of doing so, & how is it achieved.

  I hope I am not asking for too much.

  Kindly advice..

  Thanks & warm regards,
  Vinod.



This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:12:18 EDT