RE: [nsp] BGP default-originate

From: Bruce R. Babcock (bbabcock@cisco.com)
Date: Thu Jan 04 2001 - 16:43:47 EST


The route-map isn't needed to select 0/0 in this case. That route will be provided to the peer even if the 0/0 route does not currently exist in the IP Routing table. BGP differs in this regard from IGP's that you might be more familiar with.

I do use route-map with default-originate in BGP if I want to conditionally propagate a default that I have learned (typically via BGP) from another router. The route-map tests for the presence of 0/0 in the IP routing table and only originates the default if one exists locally.

For matching prefix/length, 'ip prefix-list' is the recommended way to do this in route-maps or redistribution. Prefix-list won't filter data packets on interfaces but it is ideal for route filtering.
You could also use an extended ACL to match for 0/0 in the route-map but prefix-list is easier to cfg and maintain.

I would suggest that you avoid clearing the BGP session after making a policy change in BGP. Clearing the BGP session disrupts routing, introduces lots of route flap, and depending on the frequency that you do this, could result in your announcements getting dampened elsewhere in the Internet.
Soft reconfig or route-refresh is much better with route-refresh being more scaleable.

-Bruce

At 11:24 AM 1/4/2001 -0800, F. David Sinn wrote:
>Actually there is a problem. The problem is with the ACL that is being used
>to select the route to send. The ACL shown selects a host route to 0.0.0.0
>(0.0.0.0/32).
>
>You would probably be better off with a prefix list like:
>
>ip prefix-list default seq 5 permit 0.0.0.0/0
>
>route-map default-map permit 10
> match ip address prefix-list default
>
>David
>
>-----Original Message-----
>From: George Robbins [mailto:grr@shandakor.tharsis.com]
>Sent: Thursday, January 04, 2001 9:52 AM
>To: cisco-nsp@puck.nether.net; Insik_Park@infonet.com
>Subject: Re: [nsp] BGP default-originate
>
>
>You won't be able to see the default internally, it's part of the
>output editing done when routes are actually sent to the neighbor.
>
>Look at the received routes on the neighbor. It might be helpful
>to set some community on the default route so that you can identify
>it as the one you're originating. Also, note that changing the
>route-map will only take effect if you clear the session...
>
> George
>
> > From cisco-nsp-request@puck.nether.net Thu Jan 4 12:34:12 2001
> > Date: Thu, 4 Jan 2001 12:26:25 -0500
> > X-From_: Insik_Park@infonet.com Thu Jan 4 12:26:25 2001
> > Received-Date: Thu, 4 Jan 2001 12:26:24 -0500
> > From: Insik_Park@infonet.com
> > To: cisco-nsp@puck.nether.net
> > Old-Date: Thu, 4 Jan 2001 09:26:20 -0800
> > X-MIMETrack: Serialize by Router on LAXAPP/SVR/ISC(Release 5.0.5
>|September 22, 2000) at
> > 01/04/2001 09:27:09 AM
> > Old-X-Envelope-To: cisco-nsp
> > Resent-From: jared@puck.nether.net
> > Resent-Date: Thu, 4 Jan 2001 12:31:45 -0500
> > Resent-To: cisco-nsp@puck.nether.net
> > Subject: [nsp] BGP default-originate
> > X-Mailing-List: <cisco-nsp@puck.nether.net> archive/latest/4733
> > X-Loop: cisco-nsp@puck.nether.net
> > Precedence: list
> > Resent-Sender: cisco-nsp-request@puck.nether.net
> >
> > Hello all,
> >
> > I am trying to inject default route 0.0.0.0 to eBGP neighbor using
> > default-originate and route map, but it doesn't seem to work. Below is
>the
> > configuration. Am I missing something? If I use default-originate
>without
> > route-map, then it successfully injects default network to eBGP neighbor.
> >
> > !
> > router bgp 200
> > neighbor 200.100.1.2 remote-as 400
> > neighbor 200.100.1.2 default-originate route-map default-map
> > !
> > route-map default-map permit 10
> > match ip address 1
> > !
> > access-list 1 permit 0.0.0.0
> > !
> > ip route 0.0.0.0 0.0.0.0 195.190.1.1
> >
> > ------------------
> > !
> > router bgp 400
> > neighbor 200.100.1.1 remote-as 200
> >
> >
> >
> >
> >
>



This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:12:24 EDT