Re: [nsp] Trying to decide on IGP

From: Jon Lewis (jlewis@inorganic5.fdt.net)
Date: Thu Jul 30 1998 - 19:17:48 EDT


On Wed, 29 Jul 1998, Niels Bakker wrote:

> I assume you want OSPF to be able to use redundant links and to allow
> customers with static IP addresses to dial into different POPs at
> different times while still keeping their IP address.

Mostly for the static IP customer case, and to automate as much routing as
possible and cut down on the number of static routes needed.

> Why not? It's an IGP, IGPs aren't limited to one location, only to one
> administration. You use BGP to announce yourself to the world

                      Multiple T1's to Internet
                                ||
                           -----||---area 0-
                           | RTA |
                           -------\---------
                                  -\---area 1-----------
                                  | \--------RTB |
                                  ----------------------

Ok...I'm playing around with OSPF on the WAN links now. I've cut away most
of the picture to "zoom in" on what I'm having trouble with. RTA is in area
0 with an ethernet segment full of routers in area 0. RTA connects to RTB
via a PTP T1 link. RTB has an ethernet interface talking to a few routers in
area 1.

#RTA
interface FastEthernet0/0
 ip address 209.212.128.1 255.255.255.0
 no ip directed-broadcast
!
interface Serial2/3
 ip address 209.212.144.33 255.255.255.252
 encapsulation ppp
 no fair-queue

router ospf 1
 redistribute static subnets
 [passive-interface Serial1/0-3, Serial2/0-2]
 network 209.212.128.0 0.0.0.255 area 0
 network 209.212.144.33 0.0.0.0 area 1

#RTB
interface Ethernet0
 ip address 209.212.145.1 255.255.255.192
 no ip directed-broadcast
 ip ospf priority 10
!
interface Serial0
 description T1 to FDT backbone
 ip address 209.212.144.34 255.255.255.252
 encapsulation ppp
 no fair-queue
!
router ospf 100
 redistribute static subnets
 passive-interface Serial1
 network 209.212.145.0 0.0.0.63 area 1
!
ip route 0.0.0.0 0.0.0.0 Serial0
ip route 209.212.145.0 255.255.255.0 Null0 250

I kind of expected RTB to tell RTA about 209.212.145/24 via OSPF, but it
doesn't. RTB does tell other OSPF speakers in area 1 about 209.212.145/24.

What have I missed?

------------------------------------------------------------------
 Jon Lewis <jlewis@fdt.net> | Spammers will be winnuked or
 Network Administrator | drawn and quartered...whichever
 Florida Digital Turnpike | is more convenient.
______http://inorganic5.fdt.net/~jlewis/pgp for PGP public key____






This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:13:13 EDT