[cisco-bba] PPPoE with Routed Subnet

Patrick Wu pwu828 at gmail.com
Sun Jan 11 22:07:10 EST 2009


Hi Everyone,

I have a DSL connection running PPPoE with a routed subnet, the service
provider indicated that it will use the 1st IP address of the routed subnet
for the router (WAN?), and the rest of the IPs of the subnet can be assigned
to the hosts behind the router.

What I want to know is whether I need a bridged interface between the WAN
and LAN side of the router (Cisco877), and what configuration will help me
achieve this?

Thanks to all!

What I have so far (was doing NAT before, but probably will remove it
later):

interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
 service-policy output SIP-priority
!
interface ATM0.1 point-to-point
 description $FW_OUTSIDE$$ES_WAN$
 pvc 8/35
  pppoe-client dial-pool-number 1
 !
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
 description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
 ip tcp adjust-mss 1412
!
interface Dialer0
 description $FW_OUTSIDE$
 ip address negotiated
 ip mtu 1452
 ip nat outside
 ip virtual-reassembly
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp pap sent-username xxxx at xxxx password 7 xxxx
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip nat translation udp-timeout never
ip nat inside source list 1 interface Dialer0 overload
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://puck.nether.net/pipermail/cisco-bba/attachments/20090112/0f35a6e0/attachment.html>


More information about the cisco-bba mailing list