[c-nsp] Basic DHCP config assistance

Marcello Pedersen mpedersen at touchbase.us
Tue May 24 13:15:57 EDT 2005


Hi,
 
I am trying to get DHCP to work on multiple VLANs. My lab is pretty simple:
 
Lucent Firewall --> 2651XM router and DHCP  --> 3560 PoE Switch
 
I am trying to have phones on VLAN 3 get IP from 265x1XM as well as PCs on VLAN 1.
 
PCs get an IP address however the phones don't. I think it is because my VLAN 3 has no IP address but does it need to have an IP?
 
Thanks!
Marcello
 
My running config on the router:
 
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname ussf2521RT1
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 
 
!
username cisco privilege 15 secre
ip subnet-zero
!
!
ip cef
!
ip dhcp pool ITS
   network 172.25.2.128 255.255.255.128
   option 150 ip 172.25.1.15
   default-router 172.25.2.130
   dns-server 172.25.1.10
!
!
ip domain list 172.25.1.10
ip domain name xyz
ip name-server 172.25.1.10
no ftp-server write-enable
!
interface GigabitEthernet0/0
 description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-GE 0/0$
 ip address 172.25.2.2 255.255.255.128
 ip nbar protocol-discovery
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 ip address 172.25.2.129 255.255.255.128
 duplex auto
 speed auto
!
interface Serial0/2/1:23
 no ip address
 isdn switch-type primary-qsig
 isdn incoming-voice voice
 no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 172.25.2.1
!
ip http server
ip http authentication local
ip http secure-server
ip http server
ip http authentication local
ip http secure-server
!
ip access-list extended DHCP
 permit ip host 0.0.0.0 host 255.255.255.255
!
!
end
 
 
version 12.1
no service pad
service timestamps debug uptime
service timestamps log datetime
no service password-encryption
service sequence-numbers
!
hostname ussf3560sw1
 
ip subnet-zero
ip routing
ip dhcp smart-relay
!
ip name-server 172.25.1.10
ip dhcp-server 172.25.2.129
cluster enable ussfinternalnet 0
!
spanning-tree mode pvst
interface FastEthernet0/1
 no ip address
 srr-queue bandwidth share 10 20 40 80
 srr-queue bandwidth shape  0  0  0  0
 no mdix auto
!
interface FastEthernet0/2
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport voice vlan 3
 no ip address
 srr-queue bandwidth share 10 20 40 80
 srr-queue bandwidth shape  0  0  0  0
 no mdix auto
 spanning-tree portfast
 

ALL PORTS CONFIGURED THE SAME 
 

!
interface FastEthernet0/24
 switchport trunk encapsulation dot1q
 switchport mode trunk
 switchport voice vlan 3
 no ip address
 srr-queue bandwidth share 10 20 40 80
 spanning-tree portfast
!
interface GigabitEthernet0/1
 no ip address
 srr-queue bandwidth share 10 20 40 80
 srr-queue bandwidth shape  0  0  0  0
!
interface GigabitEthernet0/2
 no ip address
 srr-queue bandwidth share 10 20 40 80
 srr-queue bandwidth shape  0  0  0  0
!
interface Vlan1
 ip address 172.25.2.130 255.255.255.128
 ip helper-address 172.25.2.129
!
interface Vlan3
 no ip address
 ip helper-address 172.25.2.129
!
ip default-gateway 172.25.2.130
ip classless
ip route 0.0.0.0 0.0.0.0 172.25.2.129
ip http server
!
!
line con 0
line vty 0 4
 password 5upport2021
 login
line vty 5 15
 password 5upport2021
 login
!
end

______________________________________________________________________
This email has been scanned by the MessageLabs Email Security System.
For more information please visit http://www.messagelabs.com/email 
______________________________________________________________________


More information about the cisco-nsp mailing list