[c-nsp] BGP with yourself...

Peter Rathlev peter at rathlev.dk
Thu Apr 24 06:47:34 EDT 2008


I experienced a funny thing, trying to setup some templates for PE
routers. I'd like to do as much as possible in the template, and then
just the unit specifics afterwards. What I did was basically this:

! ;; Template
interface Loopback0
 ! ip address lies in specific configuration
 no ip unreachables
 no shutdown
 exit
!
router bgp 65432
 neighbor iBGP peer-group
 neighbor iBGP remote-as 65432
 neighbor iBGP update-source Loopback0
 ! All peers specified, including ourselves
 neighbor 10.0.0.1 peer-group iBGP
 neighbor 10.0.0.2 peer-group iBGP
 neighbor 10.0.0.3 peer-group iBGP
 ! ... and so on
 exit
!

! ;; Specifics
interface Loopback0
 ip address 10.0.0.1 255.255.255.255
 exit
!

Now it trying to have an iBGP-session with itself, a thing I normally
can't configure. :-)

lab-core-1#sh ip bgp sum
BGP router identifier 10.0.0.1, local AS number 65432
BGP table version is 1, main routing table version 1

Neighbor   V   AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.0.0.1   4  123       0       3      0   0    0 never   OpenSent
lab-core-1#

It never gets any where from there, it's just stuck at "OpenSent".

And yes, I know this is just a novelty, I'm not complaining, just
thought it was a little funny...

Regards,
Peter




More information about the cisco-nsp mailing list