[c-nsp] 3550 routing performance

Tony td_miles at yahoo.com
Fri Dec 19 00:32:09 EST 2008


Hi all,

Apologies in advance for the long post, I'm hoping to cover off some of the obvious questions and show that I have at least tried to answer this myself.

I've been doing some testing with a 3550 and I am getting some strange performance results. I start with a totally blank config and then add the following:

interface FastEthernet0/13
 no switchport
 ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet0/14
 no switchport
 ip address 192.168.40.254 255.255.255.0
!

I have PC1 with IP 192.168.1.200 connected directly to fa0/13 running an FTP server.
I have PC2 with IP 192.168.40.100 connected directly to fa0/14.

If I FTP a file from PC2 to PC1 I get speeds of 97Mbps (near enough to wire speed of 100Mbps). Nice.

I then change the config so that the interfaces are in a VRF, like this:

ip vrf test1
 description test1 vrf
 rd 100:1
!
interface FastEthernet0/13
 no switchport
 ip vrf forwarding test1
 ip address 192.168.1.254 255.255.255.0
!
interface FastEthernet0/14
 no switchport
 ip vrf forwarding test1
 ip address 192.168.40.254 255.255.255.0
!

Testing using the FTP transfer again I get an average transfer speed of around 14Mbps (not so nice).

Ok I think to myself, the VRF stuff is causing issues. So I remove all of the VRF (delete the VRF, delete it from the interfaces, add IP addresses again to interfaces). Once I've done this, I test the FTP again, still 14Mbps. The only way I can get it to go back up to 100Mbps is to reboot the switch..

I tried this on a number of different IOS versions and they all showed the same issue:
c3550-ipservicesk9-mz.122-37.SE.bin 
c3550-ipbasek9-mz.122-25.SED.bin 
c3550-ipservices-mz.122-25.SEE4.bin 
c3550-ipservices-mz.122-44.SE3.bin
c3550-i5q3l2-mz.121-22.EA10b.bin

I then thought that maybe it's doing something strange with VRF's so I will test it with VLAN routing. Reboot the switch, and then put this config on it:

interface vlan13
 ip address 192.168.1.254 255.255.255.0
 no shut
!
interface vlan14
 ip address 192.168.40.254 255.255.255.0
 no shut
!
interface FastEthernet0/13
 switchport
 switchport mode access
 switchport access vlan 13
!
interface FastEthernet0/14
 switchport
 switchport mode access
 switchport access vlan 14
!

I get the same results, transfer speed of around 14Mbps (that's an average too, it bounces around between 8-26Mbps). If I remove the VLAN config and go back to IP addresses directly on the interfaces I have the same issue, the speed doesn't go back up at all, but stays at 14Mbps until reboot.

I have also tried this on another 3550, just to make sure it wasn't something broken in one switch.

What I am trying to achieve is routing between two subnets that are connected to two interfaces in a VRF. I need it to be in a VRF as I have two lots of connections coming into the 3550 (ie. four interfaces). One is for WAN traffic (one set of two interfaces & subnets in one VRF), one for Internet traffic (2nd set of two interfaces & subnets in 2nd VRF). Hopefully that makes sense ?

>From this Cisco doc:
http://www.cisco.com/en/US/docs/switches/lan/catalyst3550/software/release/12.2_25_seb/configuration/guide/swiprout.html#wp1206101

"Multi-VRF CE does not affect the packet switching rate."


Am I missing something simple ? I'm open to any suggestions and am happy to test things and report back with the results (may not be till after weekend though).


Thanks,
Tony.



      



More information about the cisco-nsp mailing list