[c-nsp] How to match local IP address?

Marko Milivojevic markom at markom.info
Tue Oct 21 18:36:04 EDT 2008


Here, I had a few minutes to play in the lab:

interface Loopback0
 ip address 10.0.0.1 255.255.255.0
!
interface Loopback1
 ip address 10.1.0.1 255.255.255.0
!
interface Loopback2
 ip address 10.2.0.1 255.255.255.0
!
interface Loopback3
 ip address 10.3.0.1 255.255.255.0
!
router bgp 100
 bgp log-neighbor-changes
 !
 address-family ipv4
  redistribute connected route-map rc
  no auto-summary
  no synchronization
 exit-address-family
!
ip prefix-list AAA seq 5 permit 10.0.0.0/8 ge 24 le 24
!
route-map rc permit 10
 match ip address prefix-list AAA
 set community no-export
!

R1#sh ip bgp
BGP table version is 9, local router ID is 10.3.0.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.0.0.0/24      0.0.0.0                  0         32768 ?
*> 10.1.0.0/24      0.0.0.0                  0         32768 ?
*> 10.2.0.0/24      0.0.0.0                  0         32768 ?
*> 10.3.0.0/24      0.0.0.0                  0         32768 ?

R1#sh ip bgp 10.0.0.0
BGP routing table entry for 10.0.0.0/24, version 8
Paths: (1 available, best #1, table Default-IP-Routing-Table, not
advertised to EBGP peer)
Flag: 0x8A0
  Not advertised to any peer
  Local
    0.0.0.0 from 0.0.0.0 (10.3.0.1)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid,
sourced, best
      Community: no-export

--
Marko
CCIE #18427 (SP)
My network blog: http://cisco.markom.info/


More information about the cisco-nsp mailing list