[c-nsp] untagged to QinQ switch ports

Laurent Geyer lgeyer at gmail.com
Fri Feb 13 14:17:25 EST 2009


On Fri, Feb 13, 2009 at 2:05 PM, Ross McConner <rmcconner at gmail.com> wrote:
> Maybe I'm just hitting my head against a wall and therefore can't see the
> answer..
>
> I'm looking for a way to take a non-trunked ethernet port and encapsulate
> any of the L2 packets into a double-tagged dot1q vlan.
>
> Basically my provider gives me a single circuit with 802.1q and then tunnels
> vlans to different destinations (most likely via xconnects).  At this
> (small) location I don't need to have all the vlans in use, just specific
> ones - so I'm looking for a way to do it without installing a 2nd switch in
> front of the cisco just to create the inner vlan tags, which is what all of
> cisco's documentation assumes.

Sorry for the previous mail, hit some weird gmail keyboard shortcut.

Here is what I've seen work before.

interface fa0/1
  switchport
  switchport access vlan <provider vlan>
  switchport mode dot1q-tunnel
end

interface fa0/2
  switchport
  switchport trunk encapsulation dot1q
  switchport trunk allowed vlan 50, 60
  switchport mode trunk
end

interface fa0/3
  switchport
  switchport access vlan <provider vlan>
  switchport mode access
end


Connect a crossover cable between fa0/1 and fa0/2 and put the access
ports you want double tagged over the provider link the respective
access vlan.

Of course your layer2 path will have to have the necessary MTU size to
carry the double tagged frames.

- Laurent


More information about the cisco-nsp mailing list