[c-nsp] IPv6 iBGP Route Reflector

Aleksandr Gurbo kron at linkey.ru
Thu Jul 9 14:17:39 EDT 2009


> > rtr4#show ip bgp ipv6 unicast 2001:1020:100::3/128
> > BGP routing table entry for 2001:1020:100::3/128, version 0
> > Paths: (1 available, no best path)
> >   Not advertised to any peer
> >   Local, (received & used)
> >     2001:1020:100::3 (inaccessible) from 2001:1020:100::2 (10.10.1.14)
>                        ^^^^^^^^^^^^^^
> 
> I don't know for sure, but this seems like a reachability problem, not
> necessarily a BGP problem.

Yes, you are partially right, but rtr3 can reach rtr4.

rtr3#sh ipv6 route
IPv6 Routing Table - 10 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
O   2001:1020:100::2/128 [110/1]
     via FE80::21F:CAFF:FEB3:640, FastEthernet6/1/0
LC  2001:1020:100::3/128 [0/0]
     via ::, Loopback0
O   2001:1020:100::4/128 [110/2]
     via FE80::21F:CAFF:FEB3:640, FastEthernet6/1/0
C   2001:1020:700::/64 [0/0]
     via ::, FastEthernet6/0/0
L   2001:1020:700::1/128 [0/0]
     via ::, FastEthernet6/0/0
C   2001:1020:7000::/64 [0/0]
     via ::, FastEthernet6/1/0
L   2001:1020:7000::1/128 [0/0]
     via ::, FastEthernet6/1/0
O   2001:1020:8000::/64 [110/2]
     via FE80::21F:CAFF:FEB3:640, FastEthernet6/1/0
L   FE80::/10 [0/0]
     via ::, Null0
L   FF00::/8 [0/0]
     via ::, Null0

rtr3#ping 2001:1020:100::4

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1020:100::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/1/4 ms


> The next-hop should appear valid and usable, and link-local is a valid
> next-hop in your case. eg:
> 
> O>* 2607:f118:1::e3/128 [110/2] via fe80::21a:70ff:fe14:568a, em5, 05w2d23h
> 
> Can r2 reach r3? Can you provide some relevant BGP and OSPF config snips
> from r2 and r4?
> I have a network segment that is configured nearly identical to yours,
> so I can compare config pieces with you if you'd like.


Yes, rtr2_RR can reach rtr3 and rtr4.
rtr2_RR#ping 2001:1020:100::3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1020:100::3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms

rtr2_RR#sh ipv6 route
IPv6 Routing Table - default - 10 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, R - RIP, I1 - ISIS L1, I2 - ISIS L2
       IA - ISIS interarea, IS - ISIS summary, D - EIGRP, EX - EIGRP external
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
LC  2001:1020:100::2/128 [0/0]
     via Loopback12, receive
O   2001:1020:100::3/128 [110/1]
     via FE80::260:2FFF:FE4E:41C8, GigabitEthernet3/24
O   2001:1020:100::4/128 [110/1]
     via FE80::230:96FF:FEC0:A880, GigabitEthernet3/23
B   2001:1020:700::/64 [200/0]
     via 2A00:1020:100::3, indirectly connected
B   2001:1020:800::/64 [200/0]
     via 2A00:1020:100::4, indirectly connected
C   2001:1020:7000::/64 [0/0]
     via GigabitEthernet3/24, directly connected
L   2001:1020:7000::2/128 [0/0]
     via GigabitEthernet3/24, receive
C   2001:1020:8000::/64 [0/0]
     via GigabitEthernet3/23, directly connected
L   2001:1020:8000::2/128 [0/0]
     via GigabitEthernet3/23, receive
L   FF00::/8 [0/0]
     via Null0, receive



configuration rtr2_RR:

interface Loopback12
 no ip address
 ipv6 address 2001:1020:100::2/128
 ipv6 ospf 333 area 0
end

interface GigabitEthernet3/23
 description rtr4
 no ip address
 ipv6 address 2001:1020:8000::2/64
 ipv6 enable
 ipv6 ospf 333 area 0
 mpls ip
end

interface GigabitEthernet3/24
 description rtr3
 no ip address
 ipv6 address 2001:1020:7000::2/64
 ipv6 enable
 ipv6 ospf 333 area 0
 mpls ip
end

router bgp 65000
 template peer-policy rr-clients-v6
  route-reflector-client
  soft-reconfiguration inbound
  send-community both
  send-label
 exit-peer-policy
 !
 bgp router-id 10.10.1.14
 bgp log-neighbor-changes
 neighbor 2001:1020:100::3 remote-as 65000
 neighbor 2001:1020:100::3 ebgp-multihop 10
 neighbor 2001:1020:100::3 update-source Loopback12
 neighbor 2001:1020:100::4 remote-as 65000
 neighbor 2001:1020:100::4 ebgp-multihop 10
 neighbor 2001:1020:100::4 update-source Loopback12
 !
 address-family ipv4
  no synchronization
  neighbor 2001:1020:100::3 activate
  neighbor 2001:1020:100::4 activate
  no auto-summary
 exit-address-family
 !
 address-family ipv6
  redistribute connected
  no synchronization
  neighbor 2001:1020:100::3 activate
  neighbor 2001:1020:100::3 inherit peer-policy rr-clients-v6
  neighbor 2001:1020:100::4 activate
  neighbor 2001:1020:100::4 inherit peer-policy rr-clients-v6
 exit-address-family

ipv6 router ospf 333
 router-id 192.168.201.14
 log-adjacency-changes
 passive-interface default
 no passive-interface GigabitEthernet3/23
 no passive-interface GigabitEthernet3/24
!


configuration rtr4:

interface Loopback0
 no ip address
 ipv6 address 2001:1020:100::4/128
 ipv6 enable
 ipv6 ospf 333 area 0

interface FastEthernet4/0/0
 description rtr2_RR
 no ip address
 full-duplex
 ipv6 address 2001:1020:8000::1/64
 ipv6 enable
 no ipv6 redirects
 ipv6 ospf 333 area 0
 mpls ip

interface FastEthernet5/0/0
 description IPv6net2
 no ip address
 full-duplex
 ipv6 address 2001:1020:800::1/64

router bgp 65000
 bgp log-neighbor-changes
 neighbor 2001:1020:100::2 remote-as 65000
 neighbor 2001:1020:100::2 update-source Loopback0
 !
 address-family ipv4
  neighbor 2001:1020:100::2 activate
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family ipv6
  neighbor 2001:1020:100::2 activate
  neighbor 2001:1020:100::2 send-community both
  neighbor 2001:1020:100::2 soft-reconfiguration inbound
  neighbor 2001:1020:100::2 send-label
  redistribute connected
  no synchronization
 exit-address-family

ipv6 router ospf 333
 router-id 192.168.153.2
 log-adjacency-changes
 passive-interface default
 no passive-interface FastEthernet4/0/0

Configuration on rtr3 like rtr4.

-- 
Alexandr Gurbo


More information about the cisco-nsp mailing list