[c-nsp] BGP Signalled VPLS

Nick Ryce nick at fluency.net.uk
Tue Apr 16 08:37:06 EDT 2013


Hi,

I have 2 x ME3600x running me360x-universalk9-mz.153-2.S and am looking to use the new VPLS BGP signalling functionality.

I am using RSVP with the topology attached but I cannot get traffic to pass.  Any ideas?


Configs as below.

Any help with debug commands would also be greatly appreciated.

hostname PE1
!
!
!
no aaa new-model
ip routing
!
!
!
!
ip name-server 8.8.8.8
!
!
mpls traffic-eng tunnels
l2vpn vfi context lab
 vpn id 512
 autodiscovery bgp signaling bgp
  ve id 1
  ve range 11
  rd 172.16.1.1:512
  route-target export 56595:512
  route-target import 56595:512
!
vlan 512
 name lab
!
l2 router-id 172.16.1.1
!
!
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.255
 ip ospf 1 area 0.0.0.0
!
interface Tunnel0
 description PE1-to-PE2
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 172.16.2.2
 tunnel mpls traffic-eng priority 1 1
 tunnel mpls traffic-eng path-option 1 dynamic
!
interface Tunnel1
 description PE1-toPE3
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 172.16.3.3
 tunnel mpls traffic-eng priority 1 1
 tunnel mpls traffic-eng path-option 1 dynamic
!
interface GigabitEthernet0/1
 no switchport
 ip address 10.0.0.1 255.255.255.252
 mpls traffic-eng tunnels
 ip rsvp bandwidth percent 100
!
interface GigabitEthernet0/2
 switchport access vlan 512
!
router ospf 1
 router-id 172.16.1.1
 network 10.0.0.0 0.0.0.3 area 0.0.0.0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0.0.0.0
!
router bgp 56595
 bgp log-neighbor-changes
 bgp graceful-restart restart-time 120
 bgp graceful-restart stalepath-time 360
 bgp graceful-restart
 no bgp default ipv4-unicast
 neighbor 172.16.2.2 remote-as 56595
 neighbor 172.16.2.2 update-source Loopback0
 neighbor 172.16.3.3 remote-as 56595
 neighbor 172.16.3.3 update-source Loopback0
 !
 address-family ipv4
  neighbor 172.16.2.2 activate
  neighbor 172.16.2.2 send-community extended
  neighbor 172.16.3.3 activate
  neighbor 172.16.3.3 send-community extended
 exit-address-family
 !
 address-family vpnv4
  neighbor 172.16.2.2 activate
  neighbor 172.16.2.2 send-community extended
  neighbor 172.16.3.3 activate
  neighbor 172.16.3.3 send-community extended
 exit-address-family
 !
 address-family l2vpn vpls
  neighbor 172.16.2.2 activate
  neighbor 172.16.2.2 send-community extended
  neighbor 172.16.2.2 prefix-length-size 2
  neighbor 172.16.2.2 suppress-signaling-protocol ldp
  neighbor 172.16.3.3 activate
  neighbor 172.16.3.3 send-community extended
  neighbor 172.16.3.3 suppress-signaling-protocol ldp
 exit-address-family


hostname PE3
!
!
!
no aaa new-model
ip routing
!
!
!
!
ip name-server 8.8.8.8
ipv6 multicast rpf use-bgp
!
!
mpls traffic-eng tunnels
l2vpn vfi context lab
 vpn id 512
 autodiscovery bgp signaling bgp
  ve id 3
  ve range 11
  rd 172.16.3.3:512
  route-target export 56595:512
  route-target import 56595:512
vlan 512
 name test
!
!
!
!
interface Loopback0
 ip address 172.16.3.3 255.255.255.255
 ip ospf 1 area 0.0.0.0
!
interface Tunnel0
 description PE3-to-PE2
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 172.16.2.2
 tunnel mpls traffic-eng priority 1 1
 tunnel mpls traffic-eng path-option 1 dynamic
!
interface Tunnel1
 description PE3-to-PE1
 ip unnumbered Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 172.16.1.1
 tunnel mpls traffic-eng priority 1 1
 tunnel mpls traffic-eng path-option 1 dynamic
!
interface GigabitEthernet0
 ip address 46.226.1.178 255.255.255.248
 speed auto
 duplex auto
 negotiation auto
!
interface GigabitEthernet0/1
 no switchport
 ip address 10.0.0.6 255.255.255.252
 mpls traffic-eng tunnels
 ip rsvp bandwidth percent 100
!
interface GigabitEthernet0/2
 switchport access vlan 512
!
interface Vlan512
 no ip address
 member vfi lab
!
router ospf 1
 router-id 172.16.3.3
 network 10.0.0.4 0.0.0.3 area 0.0.0.0
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng area 0.0.0.0
!
router bgp 56595
 bgp log-neighbor-changes
 bgp graceful-restart restart-time 120
 bgp graceful-restart stalepath-time 360
 bgp graceful-restart
 no bgp default ipv4-unicast
 neighbor 172.16.1.1 remote-as 56595
 neighbor 172.16.1.1 update-source Loopback0
 neighbor 172.16.2.2 remote-as 56595
 neighbor 172.16.2.2 update-source Loopback0
 !
 address-family ipv4
  neighbor 172.16.1.1 activate
  neighbor 172.16.1.1 send-community extended
  neighbor 172.16.2.2 activate
  neighbor 172.16.2.2 send-community extended
 exit-address-family
 !
 address-family vpnv4
  neighbor 172.16.1.1 activate
  neighbor 172.16.1.1 send-community extended
  neighbor 172.16.2.2 activate
  neighbor 172.16.2.2 send-community extended
 exit-address-family
 !
 address-family l2vpn vpls
  neighbor 172.16.1.1 activate
  neighbor 172.16.1.1 send-community extended
  neighbor 172.16.1.1 suppress-signaling-protocol ldp
  neighbor 172.16.2.2 activate
  neighbor 172.16.2.2 send-community extended
  neighbor 172.16.2.2 prefix-length-size 2
  neighbor 172.16.2.2 suppress-signaling-protocol ldp
 exit-address-family


Tunnels are up in both directions.

Output of some commands as below

PE3#show l2vpn vfi name lab
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No

VFI name: lab, state: up, type: multipoint, signaling: BGP
  VPN ID: 512, VE-ID: 3, VE-SIZE: 11
  RD: 172.16.3.3:512, RT: 56595:512, 56595:512
  Bridge-Domain 512 attachment circuits:
    Vlan512
  Pseudo-port interface: pseudowire100001
  Interface          Peer Address    VE-ID  Local Label  Remote Label    S

PE1#show l2vpn vfi name lab
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No

VFI name: lab, state: down, type: multipoint, signaling: BGP
  VPN ID: 512, VE-ID: 1, VE-SIZE: 11
  RD: 172.16.1.1:512, RT: 56595:512, 56595:512
  Bridge-Domain 512 attachment circuits:
    Vlan512
  Pseudo-port interface: pseudowire100003
  Interface          Peer Address    VE-ID  Local Label  Remote Label    S

PE3#show bgp l2vpn vpls all
BGP table version is 28, local router ID is 172.16.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 172.16.1.1:512
 *>i 172.16.1.1:512:VEID-1:Blk-1/136
                       172.16.1.1               0    100      0 ?
Route Distinguisher: 172.16.2.2:512
 *>i 172.16.2.2:512:VEID-2:Blk-1/136
                       172.16.2.2                    100      0 i
 *>i 172.16.2.2:512:VEID-2:Blk-1/136
                       172.16.2.2                    100      0 i
Route Distinguisher: 172.16.3.3:512
 *>  172.16.3.3:512:VEID-3:Blk-1/136
                       0.0.0.0                            32768 ?


PE1# show bgp l2vpn vpls all
BGP table version is 39, local router ID is 172.16.1.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
Route Distinguisher: 172.16.1.1:512
 *>  172.16.1.1:512:VEID-1:Blk-1/136
                       0.0.0.0                            32768 ?
Route Distinguisher: 172.16.2.2:512
 *>i 172.16.2.2:512:VEID-2:Blk-1/136
                       172.16.2.2                    100      0 i
 *>i 172.16.2.2:512:VEID-2:Blk-1/136
                       172.16.2.2                    100      0 i
Route Distinguisher: 172.16.3.3:512
 *>i 172.16.3.3:512:VEID-3:Blk-1/136
                       172.16.3.3               0    100      0 ?


Nick

--
Nick Ryce

Fluency Communications Ltd.
e. nick at fluency.net.uk<mailto:nick at fluency.net.uk>
w. http://fluency.net.uk/
t. 0845 874 7000


More information about the cisco-nsp mailing list