[c-nsp] MPLS L3VPN - EIGRP routes not being advertised to CE router

Tim Huffman tim at bobbroadband.com
Tue Jun 11 16:23:59 EDT 2013


Although we've done several MPLS VPNs in the past, we've always used BGP as the PE-CE routing protocol. Now, I have a new customer that wants to use EIGRP instead. The configuration doesn't seem too hard, but something isn't working correctly:


-          We are learning routes from the customer at each location (2 currently, with more to follow)

-          PE1 and PE2 both learn routes from their respective CE1 and CE2

-          Those routes get passed onto our Route Reflector

-          PE2 knows routes in the VRF from PE1, and vice versa

-          Neither CE1 nor CE2 are learning any routes, other than connected ones

The customer is getting antsy, and from the documentation I can find, we should be set up correctly. Any help you guys can provide would be GREATLY appreciated! Now the details:

PE1=====RR======PE2
|                                             |
|                                             |
CE1                                         CE2

Our Route Reflector is a Catalyst 6503 w/SUP720-3BXL running 12.2(33)SXH5. The two PEs are ME-C6524GT-8S running 12.2(18)ZU2. Below is the config from the PE routers (IPs and ASNs changed to protect the innocent):

ip vrf CustomerA
description L3VPN for CustomerA
rd 65002:10
route-target export 65002:10
route-target import 65002:10

router eigrp 65002
auto-summary
!
address-family ipv4 vrf CustomerA
redistribute bgp 1234
network 10.3.63.0 0.0.0.3
default-metric 10000 1 255 1 1500
no auto-summary
autonomous-system 65002
eigrp stub connected summary
exit-address-family
eigrp stub connected summary

router bgp 1234
no synchronization
bgp log-neighbor-changes
bgp deterministic-med
bgp maxas-limit 50
redistribute connected
redistribute static
neighbor 10.10.10.1 remote-as 1234
neighbor 10.10.10.1 description Route Reflector
neighbor 10.10.10.1 update-source Loopback0
neighbor 10.10.10.1 next-hop-self
maximum-paths ibgp  2
distance bgp 200 200 200
no auto-summary
!
address-family vpnv4
neighbor 10.10.10.1 activate
neighbor 10.10.10.1 send-community extended
exit-address-family
!
address-family ipv4 vrf CustomerA
redistribute eigrp 65002
no auto-summary
no synchronization
exit-address-family

Here is the output showing the EIGRP neighbor up:

#sh ip eigrp vrf CustomerA 65002 neighbors
IP-EIGRP neighbors for process 65002
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.3.63.2               Gi1/11.898        14 22:31:38    8   450  0  36

And the EIGRP topology:
#sh ip eigrp vrf CustomerA 65002 topology
IP-EIGRP Topology Table for AS(65002)/ID(10.3.63.1) Routing Table: CustomerA

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 10.3.19.0/30, 1 successors, FD is 2816
        via VPNv4 Sourced
P 10.3.18.0/30, 1 successors, FD is 28160
        via VPNv4 Sourced
P 10.3.63.0/30, 1 successors, FD is 25856
        via Connected, GigabitEthernet1/11.898
P 10.3.49.4/30, 1 successors, FD is 2816
        via VPNv4 Sourced
P 172.17.58.4/32, 1 successors, FD is 156160
        via VPNv4 Sourced
P 172.17.58.8/32, 1 successors, FD is 153856
        via 10.3.63.2, GigabitEthernet1/11.898

Here's the routing table, showing routes learned from the customer (via EIGRP), as well as routes learned from PE2:

#sh ip route vrf CustomerA

Routing Table: CustomerA
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.17.0.0/32 is subnetted, 2 subnets
B       172.17.58.4 [200/156160] via 10.10.10.3, 22:05:23 <==This is the loopback from CE2
D       172.17.58.8 <==This is the loopback from CE1
           [90/153856] via 10.3.63.2, 22:06:01, GigabitEthernet1/11.898
     10.0.0.0/30 is subnetted, 4 subnets
B       10.3.18.0 [200/0] via 10.10.10.3, 4d22h <==This is the VRF interface from PE2
C       10.3.63.0 is directly connected, GigabitEthernet1/11.898 <==This is the VRF interface on PE1

And this is what the customer side looks like:

Interface GigabitEthernet2/0/6
ip address 10.3.63.2 255.255.255.252

interface Loopback10
ip address 172.17.58.8 255.255.255.255

router eigrp 65002
default-metric 10000 1 255 1 1500
no auto-summary
network 10.3.63.0 0.0.0.3
network 172.17.58.0 0.0.0.255
!
!
!
!
CE1#sh ip eigrp 65002 neigh
EIGRP-IPv4:(65002) neighbors for process 65002
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq
                                            (sec)         (ms)       Cnt Num
0   10.3.63.1               Gi2/0/6           10 00:05:59 1023  5000  0  14
!
!
!
!
CE1#sh ip eigrp 65002 topology
EIGRP-IPv4 Topology Table for AS(65002)/ID(172.17.58.4)

Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status

P 172.17.58.0/24, 1 successors, FD is 128256
        via Connected, Loopback10
P 10.3.63.0/30, 1 successors, FD is 28160
        via Connected, GigabitEthernet2/0/6

--
Thanks,
Tim Huffman


More information about the cisco-nsp mailing list