[c-nsp] Extranet MVPN and PIM Auto-RP

Ross Halliday ross.halliday at wtccommunications.ca
Mon Jun 24 10:41:08 EDT 2013


Hi Adam,

> In the past I played with both options (src-pe & rec-pe) for mvpn
> extranets
> on 7200s and never got it working unfortunately.
> If I recall correctly I haven't even got the joins across.
> What hardware do you use for leaking between the VRFs please?

I'm using SUP720-3B in a 6506 with IOS 15.1(1)SY. The rest of the network where this is in production runs 12.3(33)SXI4a on the same gear. The rest of the lab, at the moment, is ASR 1002 and even a 2821. I'm waiting on getting a fuse panel installed so I can turn up a couple 7301s and another 6500.

Below are my lab configs. One may note that a receiver PE is also an RR and has all VRFs in it, I've verified that the video actually comes over a data MDT for the recipient VRFs, also, the 2821 only has this VRF configured.

Thanks!
Ross



6500, video source:

ip vrf SOURCES
 rd 9000:240
 mdt default 239.67.83.1
 mdt data 239.67.83.8 0.0.0.7
 mdt data threshold 1000
 route-target export 9000:1
 route-target import 9000:1
 route-target import 9900:1
!
ip vrf RECEIVERS
 rd 9900:240
 mdt default 239.56.72.1
 mdt data 239.56.72.8 0.0.0.7
 mdt data threshold 1000
 route-target export 9900:1
 route-target import 9900:1
 route-target import 9000:1
!
ip multicast-routing
ip multicast-routing vrf SOURCES
ip multicast-routing vrf RECEIVERS
!
mls ip multicast replication-mode ingress
mls ip multicast bidir gm-scan-interval 10
mls cef error action freeze
mls mpls tunnel-recir
mpls label protocol ldp
mpls traffic-eng tunnels
no mpls ip propagate-ttl
!
interface Loopback0
 description test-lab-c6506
 ip address 172.18.96.240 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9000
 ip vrf forwarding SOURCES
 ip address 10.9.9.240 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9001
 description PIM RP
 ip vrf forwarding SOURCES
 ip address 10.9.9.251 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9900
 ip vrf forwarding RECEIVERS
 ip address 10.10.10.240 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9901
 description PIM RP
 ip vrf forwarding RECEIVERS
 ip address 10.10.10.251 255.255.255.255
 ip pim sparse-mode
!
interface GigabitEthernet2/8
 description 2821 Gi0/0
 dampening
 mtu 9216
 ip address 10.42.9.241 255.255.255.252
 ip pim sparse-mode
 ip router isis TEST-LAB
 load-interval 30
 mpls traffic-eng tunnels
 mpls ip
 bfd interval 100 min_rx 100 multiplier 5
!
interface GigabitEthernet2/13
 description lab-pc E1
 ip vrf forwarding SOURCES
 ip address 10.9.9.1 255.255.255.252
 ip pim sparse-dense-mode
!
interface GigabitEthernet5/1
 description ASR 1 Gi0/0/0
 dampening
 mtu 9216
 ip address 10.42.9.245 255.255.255.252
 ip pim sparse-mode
 ip router isis TEST-LAB
 logging event link-status
 load-interval 30
 mpls traffic-eng tunnels
 mpls ip
 bfd interval 100 min_rx 100 multiplier 5
!
router bgp 64723
 bgp router-id 172.18.96.240
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 172.18.96.241 remote-as 64723
 neighbor 172.18.96.241 update-source Loopback0
 neighbor 172.18.96.242 remote-as 64723
 neighbor 172.18.96.242 update-source Loopback0
 !
 address-family ipv4
  maximum-paths 2
 exit-address-family
 !
 address-family vpnv4
  neighbor 172.18.96.241 activate
  neighbor 172.18.96.241 send-community both
  neighbor 172.18.96.242 activate
  neighbor 172.18.96.242 send-community both
 exit-address-family
 !
 address-family ipv4 mdt
  neighbor 172.18.96.241 activate
  neighbor 172.18.96.241 send-community both
  neighbor 172.18.96.242 activate
  neighbor 172.18.96.242 send-community both
 exit-address-family
 !
 address-family ipv4 vrf SOURCES
  redistribute connected
 exit-address-family
 !
 address-family ipv4 vrf RECEIVERS
  redistribute connected
  redistribute static
 exit-address-family
!
ip pim bidir-enable
ip pim rp-address 172.18.0.240
ip pim autorp listener
ip pim register-source Loopback0
ip pim sparse sg-expiry-timer 600
ip pim vrf SOURCES autorp listener
ip pim vrf SOURCES send-rp-announce Loopback9001 scope 32 group-list RUMDIARY
ip pim vrf SOURCES register-source Loopback9000
ip pim vrf SOURCES sparse sg-expiry-timer 600
ip pim vrf RECEIVERS  rp-address 10.9.9.251 SOURCES override
ip pim vrf RECEIVERS  rp-address 10.10.10.251 RUMDIARY override
ip pim vrf RECEIVERS  autorp listener
ip pim vrf RECEIVERS  accept-rp 10.10.10.251 SOURCES
ip pim vrf RECEIVERS  send-rp-announce Loopback9901 scope 32 group-list RUMDIARY
ip pim vrf RECEIVERS  register-source Loopback9900
ip pim vrf RECEIVERS  sparse sg-expiry-timer 600
!
ip access-list standard RUMDIARY
 permit 239.9.9.9
!


ASR #1:


ip vrf SOURCES
 rd 9000:241
 mdt default 239.67.83.1
 mdt data 239.67.83.8 0.0.0.7
 mdt data threshold 1000
 route-target export 9000:1
 route-target import 9000:1
 route-target import 9900:1
!
ip vrf RECEIVERS
 rd 9900:241
 mdt default 239.56.72.1
 mdt data 239.56.72.8 0.0.0.7
 mdt data threshold 1000
 route-target export 9900:1
 route-target import 9900:1
 route-target import 9000:1
!
ip multicast-routing distributed
ip multicast-routing vrf SOURCES distributed
ip multicast-routing vrf RECEIVERS distributed
!
mpls label protocol ldp
no mpls ip propagate-ttl
mpls traffic-eng tunnels
!
interface Loopback0
 description lab-test-asr-1
 ip address 172.18.96.241 255.255.255.255
 ip pim sparse-mode
!
interface Loopback1
 description PIM RP AnyCast
 ip address 172.18.96.250 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9000
 ip vrf forwarding SOURCES
 ip address 10.9.9.241 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9001
 description PIM RP anycast
 ip vrf forwarding SOURCES
 ip address 10.9.9.250 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9900
 ip vrf forwarding RECEIVERS
 ip address 10.10.10.241 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9901
 description PIM RP anycast
 ip vrf forwarding RECEIVERS
 ip address 10.10.10.250 255.255.255.255
 ip pim sparse-mode
!
interface GigabitEthernet0/0/0
 description test-lab-c6506 Gi5/1
 dampening
 mtu 9216
 ip address 10.42.9.246 255.255.255.252
 ip router isis TEST-LAB
 ip pim sparse-mode
 logging event link-status
 load-interval 30
 negotiation auto
 mpls ip
 mpls traffic-eng tunnels
 bfd interval 100 min_rx 100 multiplier 5
 cdp enable
!
interface GigabitEthernet0/1/0
 description noctop
 ip vrf forwarding SOURCES
 ip address 10.9.9.5 255.255.255.252
 ip pim sparse-dense-mode
 ip igmp access-group STB-ACL
 load-interval 30
 negotiation auto
!
interface GigabitEthernet0/1/1
 description ross-laptop
 ip vrf forwarding RECEIVERS
 ip address 10.9.9.9 255.255.255.252
 ip pim sparse-dense-mode
 ip igmp access-group STB-ACL
 load-interval 30
 negotiation auto
!
router bgp 64723
 bgp router-id 172.18.96.241
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 172.18.96.240 remote-as 64723
 neighbor 172.18.96.240 update-source Loopback0
 neighbor 172.18.96.242 remote-as 64723
 neighbor 172.18.96.242 update-source Loopback0
 neighbor 172.18.96.243 remote-as 64723
 neighbor 172.18.96.243 update-source Loopback0
 !
 address-family ipv4
  maximum-paths 2
 exit-address-family
 !
 address-family vpnv4
  neighbor 172.18.96.240 activate
  neighbor 172.18.96.240 send-community both
  neighbor 172.18.96.240 route-reflector-client
  neighbor 172.18.96.242 activate
  neighbor 172.18.96.242 send-community both
  neighbor 172.18.96.243 activate
  neighbor 172.18.96.243 send-community both
  neighbor 172.18.96.243 route-reflector-client
 exit-address-family
 !
 address-family ipv4 mdt
  neighbor 172.18.96.240 activate
  neighbor 172.18.96.240 send-community both
  neighbor 172.18.96.240 route-reflector-client
  neighbor 172.18.96.242 activate
  neighbor 172.18.96.242 send-community both
  neighbor 172.18.96.243 activate
  neighbor 172.18.96.243 send-community both
  neighbor 172.18.96.243 route-reflector-client
 exit-address-family
 !
 address-family ipv4 vrf SOURCES
  redistribute connected
 exit-address-family
 !
 address-family ipv4 vrf RECEIVERS
  redistribute connected
 exit-address-family
!
ip pim bidir-enable
ip pim autorp listener
ip pim send-rp-announce Loopback1 scope 32
ip pim send-rp-discovery Loopback1 scope 32
ip pim register-source Loopback0
ip pim sparse sg-expiry-timer 600
ip pim vrf SOURCES autorp listener
ip pim vrf SOURCES send-rp-announce Loopback9001 scope 32
ip pim vrf SOURCES send-rp-discovery Loopback9001 scope 32
ip pim vrf SOURCES register-source Loopback9000
ip pim vrf SOURCES sparse sg-expiry-timer 600
ip pim vrf RECEIVERS autorp listener
ip pim vrf RECEIVERS send-rp-announce Loopback9901 scope 32
ip pim vrf RECEIVERS send-rp-discovery Loopback9901 scope 32
ip pim vrf RECEIVERS register-source Loopback9900
ip pim vrf RECEIVERS sparse sg-expiry-timer 600
ip msdp peer 172.18.96.242 connect-source Loopback0
ip msdp cache-sa-state
ip msdp originator-id Loopback0
ip msdp vrf SOURCES peer 10.9.9.242 connect-source Loopback9000
ip msdp vrf SOURCES cache-sa-state
ip msdp vrf SOURCES originator-id Loopback9000
ip msdp vrf RECEIVERS peer 10.10.10.242 connect-source Loopback9900
ip msdp vrf RECEIVERS cache-sa-state
ip msdp vrf RECEIVERS originator-id Loopback9900
!
ip access-list standard STB-ACL
 permit 239.9.9.9
!




ASR #2:

ip vrf SOURCES
 rd 9000:242
 mdt default 239.67.83.1
 mdt data 239.67.83.8 0.0.0.7
 mdt data threshold 1000
 route-target export 9000:1
 route-target import 9000:1
 route-target import 9900:1
!
ip vrf RECEIVERS
 rd 9900:242
 mdt default 239.56.72.1
 mdt data 239.56.72.8 0.0.0.7
 mdt data threshold 1000
 route-target export 9900:1
 route-target import 9900:1
 route-target import 9000:1
!
ip multicast-routing distributed
ip multicast-routing vrf SOURCES distributed
ip multicast-routing vrf RECEIVERS distributed
!
mpls label protocol ldp
no mpls ip propagate-ttl
mpls traffic-eng tunnels
!
interface Loopback0
 description lab-test-asr-2
 ip address 172.18.96.242 255.255.255.255
 ip pim sparse-mode
!
interface Loopback1
 description PIM RP AnyCast
 ip address 172.18.96.250 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9000
 ip vrf forwarding SOURCES
 ip address 10.9.9.242 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9001
 description PIM RP anycast
 ip vrf forwarding SOURCES
 ip address 10.9.9.250 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9900
 ip vrf forwarding RECEIVERS
 ip address 10.10.10.242 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9901
 description PIM RP anycast
 ip vrf forwarding RECEIVERS
 ip address 10.10.10.250 255.255.255.255
 ip pim sparse-mode
!
interface GigabitEthernet0/0/0
 description test-lab-c2821 Gi0/1
 dampening
 mtu 9216
 ip address 10.42.9.250 255.255.255.252
 ip router isis TEST-LAB
 ip pim sparse-mode
 logging event link-status
 load-interval 30
 negotiation auto
 mpls ip
 mpls traffic-eng tunnels
 bfd interval 100 min_rx 100 multiplier 5
 cdp enable
!
router bgp 64723
 bgp router-id 172.18.96.242
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 172.18.96.240 remote-as 64723
 neighbor 172.18.96.240 update-source Loopback0
 neighbor 172.18.96.241 remote-as 64723
 neighbor 172.18.96.241 update-source Loopback0
 neighbor 172.18.96.243 remote-as 64723
 neighbor 172.18.96.243 update-source Loopback0
 !
 address-family ipv4
  maximum-paths 2
 exit-address-family
 !
 address-family vpnv4
  neighbor 172.18.96.240 activate
  neighbor 172.18.96.240 send-community both
  neighbor 172.18.96.240 route-reflector-client
  neighbor 172.18.96.241 activate
  neighbor 172.18.96.241 send-community both
  neighbor 172.18.96.243 activate
  neighbor 172.18.96.243 send-community both
  neighbor 172.18.96.243 route-reflector-client
 exit-address-family
 !
 address-family ipv4 mdt
  neighbor 172.18.96.240 activate
  neighbor 172.18.96.240 send-community both
  neighbor 172.18.96.240 route-reflector-client
  neighbor 172.18.96.241 activate
  neighbor 172.18.96.241 send-community both
  neighbor 172.18.96.243 activate
  neighbor 172.18.96.243 send-community both
  neighbor 172.18.96.243 route-reflector-client
 exit-address-family
 !
 address-family ipv4 vrf SOURCES
  redistribute connected
 exit-address-family
 !
 address-family ipv4 vrf RECEIVERS
  redistribute connected
 exit-address-family
!
ip pim bidir-enable
ip pim autorp listener
ip pim send-rp-announce Loopback1 scope 32
ip pim send-rp-discovery Loopback1 scope 32
ip pim register-source Loopback0
ip pim sparse sg-expiry-timer 600
ip pim vrf SOURCES autorp listener
ip pim vrf SOURCES send-rp-announce Loopback9001 scope 32
ip pim vrf SOURCES send-rp-discovery Loopback9001 scope 32
ip pim vrf SOURCES register-source Loopback9000
ip pim vrf SOURCES sparse sg-expiry-timer 600
ip pim vrf RECEIVERS autorp listener
ip pim vrf RECEIVERS send-rp-announce Loopback9901 scope 32
ip pim vrf RECEIVERS send-rp-discovery Loopback9901 scope 32
ip pim vrf RECEIVERS register-source Loopback9900
ip pim vrf RECEIVERS sparse sg-expiry-timer 600
ip msdp peer 172.18.96.241 connect-source Loopback0
ip msdp cache-sa-state
ip msdp originator-id Loopback0
ip msdp vrf SOURCES peer 10.9.9.241 connect-source Loopback9000
ip msdp vrf SOURCES cache-sa-state
ip msdp vrf SOURCES originator-id Loopback9000
ip msdp vrf RECEIVERS peer 10.10.10.241 connect-source Loopback9900
ip msdp vrf RECEIVERS cache-sa-state
ip msdp vrf RECEIVERS originator-id Loopback9900



2821:

ip vrf RECEIVERS
 rd 9900:243
 route-target export 9900:1
 route-target import 9000:1
 route-target import 9900:1
 mdt default 239.56.72.1
 mdt data 239.56.72.8 0.0.0.7 threshold 1000
!
ip multicast-routing
ip multicast-routing vrf RECEIVERS
!
mpls traffic-eng tunnels
no mpls ip propagate-ttl
mpls label protocol ldp
!
interface Loopback0
 description test-lab-c2821
 ip address 172.18.96.243 255.255.255.255
 ip pim sparse-mode
!
interface Loopback9900
 description multicast testing
 ip vrf forwarding RECEIVERS
 ip address 10.10.10.243 255.255.255.255
 ip pim sparse-mode
 ip igmp join-group 239.9.9.9
!
interface GigabitEthernet0/0
 description test-lab-c6506 Gi2/8
 dampening
 mtu 9216
 ip address 10.42.9.242 255.255.255.252
 ip router isis TEST-LAB
 ip pim sparse-mode
 load-interval 30
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 mpls ip
 bfd interval 100 min_rx 100 multiplier 5
!
interface GigabitEthernet0/1
 description test-lab-asr-2 Gi0/0/0
 dampening
 mtu 9216
 ip address 10.42.9.249 255.255.255.252
 ip router isis TEST-LAB
 ip pim sparse-mode
 load-interval 30
 duplex auto
 speed auto
 mpls traffic-eng tunnels
 mpls ip
 bfd interval 100 min_rx 100 multiplier 5
!
router bgp 64723
 bgp router-id 172.18.96.243
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 172.18.96.241 remote-as 64723
 neighbor 172.18.96.241 update-source Loopback0
 neighbor 172.18.96.242 remote-as 64723
 neighbor 172.18.96.242 update-source Loopback0
 maximum-paths 2
 !
 address-family ipv4
  maximum-paths 2
  no auto-summary
  no synchronization
 exit-address-family
 !
 address-family ipv4 mdt
  neighbor 172.18.96.241 activate
  neighbor 172.18.96.241 send-community both
  neighbor 172.18.96.242 activate
  neighbor 172.18.96.242 send-community both
 exit-address-family
 !
 address-family vpnv4
  neighbor 172.18.96.241 activate
  neighbor 172.18.96.241 send-community both
  neighbor 172.18.96.242 activate
  neighbor 172.18.96.242 send-community both
 exit-address-family
 !
 address-family ipv4 vrf RECEIVERS
  redistribute connected
  no synchronization
 exit-address-family
!
ip pim bidir-enable
ip pim autorp listener
ip pim register-source Loopback0
ip pim vrf RECEIVERS autorp listener
ip pim vrf RECEIVERS register-source Loopback9900
!
ip access-list standard RUMDIARY
 permit 239.9.9.9
!



More information about the cisco-nsp mailing list