[c-nsp] ASR 920 - H-QoS across 2+ EFP interfaces

Feedly Reader feedlyreader at outlook.com
Tue Jul 21 18:52:23 EDT 2015


Hi Steve,

Not sure if this help directly answer your question. We achieve something
similar on ASR 9000 platform using the following:

class-map match-any CM-EF
 match dscp ef
 end-class-map
!
policy-map PM-Child
 class CM-EF
  priority level 1
  police rate percent 20
  !
 !
 class class-default
  bandwidth percent 80
 !
 end-policy-map
!
policy-map PM-Parent
 class class-default
  service-policy PM-Child
  shape average 50 mbps
 !
 end-policy-map
!

We shape the overall service to 50M and then prioritize DCSP EF traffic over
others. The parent performs the queuing so that the child policy can
prioritize traffic from the packets being held in the queue. We then apply
the parent to the service instance.

Hope that helps.

 Vaibhav

-----Original Message-----
From: cisco-nsp [mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of
Steve Margelos
Sent: Tuesday, 21 July 2015 3:51 AM
To: 'cisco-nsp at puck.nether.net'
Subject: [c-nsp] ASR 920 - H-QoS across 2+ EFP interfaces

Hello,

I have an ASR 920 that I will be using to form an NNI with an upstream
provider.  We typically have customers that purchase not just an internet
circuit, but also P2P/VPLS services all over the same single physical
circuit.  We then separate these services out into logical units on our NNI
so that we can take appropriate action, depending on the inner  C-VLAN that
we see coming from the remote CPE.  The problem I am having is
designing/implementing a QoS solution that will take into account multiple
logical circuits, while still allowing me to prioritize certain types of
traffic.  Normally, we use Juniper to accomplish this, via interface-sets
and applying a multi-level class-of-service configuration. As an example:

set interfaces interface-set Customer-XYZ interface ge-1/0/5 vlan-tags-outer
725

set class-of-service interfaces interface-set Customer-XYZ
output-traffic-control-profile LEVEL_2-svlan_100m

set class-of-service interfaces ge-1/0/5 unit 123
output-traffic-control-profile LEVEL_3-cvlan_data-50m       **CKT #2**
set class-of-service interfaces ge-1/0/5 unit 725
output-traffic-control-profile LEVEL_3-cvlan_data-50m       **CKT #1**

set class-of-service traffic-control-profiles LEVEL_2-svlan_100m
scheduler-map svlan-data-voice set class-of-service traffic-control-profiles
LEVEL_2-svlan_100m shaping-rate 100m set class-of-service
traffic-control-profiles LEVEL_2-svlan_100m guaranteed-rate 100m

set class-of-service traffic-control-profiles LEVEL_3-cvlan_data-50m
scheduler-map cvlan-data set class-of-service traffic-control-profiles
LEVEL_3-cvlan_data-50m shaping-rate 100m set class-of-service
traffic-control-profiles LEVEL_3-cvlan_data-50m guaranteed-rate 50m


Trying to translate this type of configuration over to the Cisco ASR 920 has
been.... Difficult.

I believe the only thing close to the Juniper interface-set is the Cisco
'service-group'.  The problem I am having is that the service-group
service-policy restrictions are  not allowing me to ensure certain traffic
(voice) is given priority queue access.    Per the ASR documentation, I
understand that queuing and marking is not supported at the service-group
policy level, but I am hoping to get this to work by having a service-policy
on the EFP itself and having the ASR "merge" the two together, as described
in the documentation - of course, that is not working as designed either.

Here is what I have so far:

**setting up the service-group and calling a rather simple class-default
policy-map** service-group 1234 description CID-1234 EVC group
service-policy output 50Mbps_Egress_Service_Group end

Router#show policy-map 50Mbps_Egress_Service_Group
  Policy Map 50Mbps_Egress_Service_Group
    Class class-default
     police cir 50000000 bc 1562500
       conform-action transmit
       exceed-action drop

interface GigabitEthernet0/0/0
no ip address
load-interval 30
negotiation auto
storm-control broadcast level 5.00 4.00
storm-control action shutdown
no lldp transmit
no lldp receive
spanning-tree portfast trunk
spanning-tree bpdufilter enable
spanning-tree bpduguard enable

service instance 30 ethernet
  description CID-XYZ-Internet
  encapsulation dot1q 30
  rewrite ingress tag pop 1 symmetric
  group 1234
  service-policy output EFP_Egress_Level3

Router#show policy-map EFP_Egress_Level3
  Policy EFP_Egress_Level3
    Class EGR-EF-CLASS
      priority

Router#show class-map EGR-EF-CLASS
Class Map match-all EGR-EF-CLASS (id 4)
  Description: Matches VoIP EF traffic
   Match ip  dscp ef (46)


Once I apply the service-policy in the EFP instance above, I get a console
log message stating the following:

"Cannot attach queuing-based child policy to a non-queuing based class"

So my question is, can anyone point me in the right direction in getting as
closed to the desired Juniper solution posted above?

Thank you.

Sincerely,
Steve Margelos
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
Atlantech Online, Inc.  | http://www.atlantech.net
phone: 301-755-2260 | 866-755-2260
fax: 301-589-3936
-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
view our Network status | http://noc.atlantech.net

_______________________________________________
cisco-nsp mailing list  cisco-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/


More information about the cisco-nsp mailing list