[cisco-voip] changing caller id

Christopher M. Bomba cbomba at s4nets.com
Wed Aug 15 10:37:32 EDT 2007


To me it looks like you want to strip the "252" going out and prefix a "0".

Test your voice translation rule with the command below

test voice translation-rule 2 252XXXX and see if it gives you 0XXXX.  That is what it should give you when looking at:

voice translation-rule 2
 rule 1 /^25221/ //
 rule 2 /^252/ /0/

if you use |  test voice translation-rule 2 252221XXXX then you should get XXXX.  Now this is outgoing on your POTS dial-peer which will have you sending only 5 digits out to the PSTN or might only send 4 out to the PSTN.  And since you have it as "called" then you are translating your called number not your CLID.

If you want to translate your "calling" number you have to change the follow:

voice translation-rule 2
 rule 1 /^25221/ //
 rule 2 /^252/ /0/

voice translation-profile profile2
 translate called 2       <----------------should be translate calling 2

This would translate your CLID out to the PSTN to 4 digits if your calling number is 252221 or it will replace the 252 at the beginning of the calling number to 0.

Chris

|||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||||

Date: Tue, 14 Aug 2007 06:43:56 -0700 (PDT)
From: Pezhman Lali <pezhman_lali at yahoo.com>
Subject: Re: [cisco-voip] changing caller id
To: zohaib shabir <zohaibshabir at gmail.com>
Cc: cisco-voip at puck.nether.net
Message-ID: <254032.59415.qm at web52305.mail.re2.yahoo.com>
Content-Type: text/plain; charset=iso-8859-1

dear 
thanks for your reply.
the config is:

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname test
!
enable password 111111
!
username admin password 0 111111
voice-card 1
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication login vty local
aaa authentication login h323 group radius
aaa authentication login con none
aaa authorization exec default local 
aaa authorization exec vty local 
aaa authorization exec h323 group radius 
aaa accounting connection h323 start-stop group radius
aaa session-id common
ip subnet-zero
!
!
no ip domain lookup
ip name-server 4.2.2.4
!
isdn switch-type primary-net5
!
!
voice rtp send-recv
!
voice class codec 10
 codec preference 1 g723r53
 codec preference 2 g723r63
 codec preference 3 g723ar53
 codec preference 4 g723ar63
 codec preference 6 g729br8
!
!
!
!
!
!
voice class custom-cptone test
 dualtone busy
  frequency 425 425
  cadence 500 500
 dualtone ringback
  frequency 425 425
  cadence 1000 4000
 dualtone reorder
  frequency 425 425
  cadence 1000 1000
 dualtone out-of-service
  frequency 950
  cadence 330 330
 dualtone number-unobtainable
  frequency 425
  cadence 240 240
 dualtone disconnect
  frequency 425 425
  cadence 250 250
!
!
!
!
voice translation-rule 1
 rule 1 /^2/ /2197121112/
 rule 2 /^1/ /2197121111/
 rule 3 /^3/ /2197121113/
 rule 4 /^4/ /2197121114/
 rule 5 /^5/ /2197121115/
 rule 6 /^6/ /2197121116/
 rule 7 /^7/ /2197121117/
 rule 8 /^8/ /2197121118/
 rule 9 /^9/ /2197121119/
 rule 10 /^0/ /2197121110/
!
voice translation-rule 2
 rule 1 /^25221/ //
 rule 2 /^252/ /0/
!
!
voice translation-profile profile1
 translate called 1
!
voice translation-profile profile2
 translate called 2
!
!
mta receive maximum-recipients 0
!
controller E1 1/0
 framing NO-CRC4 
 clock source line primary
 line-termination 75-ohm
 pri-group timeslots 1-31
!
controller E1 1/1
 shutdown
 framing NO-CRC4 
 line-termination 75-ohm
!
translation-rule 1
!
translation-rule 2
!
!
!
!
interface FastEthernet0/0
 ip address 85.1.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial1/0:15
 no ip address
 no logging event link-status
 isdn switch-type primary-net5
 isdn incoming-voice voice
 no cdp enable
!
ip default-gateway 85.1.1.1
ip classless
ip route 0.0.0.0 0.0.0.0 85.1.1.1
no ip http server
ip pim bidir-enable
!
!
access-list 102 deny   tcp any any eq 4444
access-list 102 deny   tcp any any eq 593
access-list 102 deny   tcp any any eq 445
access-list 102 deny   tcp any any eq 139
access-list 102 deny   tcp any any eq 135
access-list 102 deny   udp any any eq tftp
access-list 102 deny   udp any any eq netbios-dgm
access-list 102 deny   udp any any eq 135
access-list 102 permit tcp any any eq telnet
access-list 102 permit ip any any
access-list 102 permit tcp any any
access-list 102 permit udp any any
!

radius-server host 85.1.1.3 auth-port 1812 acct-port
1813 key test
radius-server authorization permit missing
Service-Type
radius-server vsa send accounting
radius-server vsa send authentication
call rsvp-sync
!
call application voice cidial flash:cidial.tcl
call application voice cidial language 0 en
call application voice cidial set-location fa 0 flash:
!
voice-port 1/0:15
!
!
mgcp profile default
!
!
!
dial-peer cor custom
!
!
!
dial-peer voice 900 voip
 session protocol sipv2
 session target dns:did.test.com
 dtmf-relay rtp-nte
!
dial-peer voice 100 pots
 translation-profile outgoing profile2
 destination-pattern 252T
 clid restrict
 port 1/0:15
!
dial-peer voice 1112 pots
!
dial-peer voice 1111 pots
!
dial-peer voice 110 pots
 incoming called-number T
 direct-inward-dial
!
sip-ua 
 sip-server ipv4:217.10.79.219
!
!
line con 0
line aux 0
line vty 0 4
 password 11111
!
!
end

--- zohaib shabir <zohaibshabir at gmail.com> wrote:

> Yes
> you can always change the callerid of calls if you
> have the PRI line for the
> pstn. I dont know you config, but i am sure you if
> you share the config with
> me, i will be able to help you out.
> 
> On 8/14/07, Pezhman Lali <pezhman_lali at yahoo.com>
> wrote:
> >
> > Hi dears
> > I have a cisco2600+nm-hdv+pri line(E1).
> > is any way to change callerid of outgoing calls to
> the
> > pstn.
> > best
> > Mani

_



More information about the cisco-voip mailing list