On Thu, 06 Jun 2002 10:18:09 GMT Tejal Shah <tejal.shah@surat.iqara.net> wrote:
> I want to start the BGP session with both of my
> upstream provider. each link from upstream terminated on
> diffrent router(7206) VXR.
>
> My requirement is that whenever one of the link goes
> down all traffic should get go through other link.
>
>
> To do this what should i do in my both of router. If
> my AS numner is 100 and AS number of both upstream provider
> 200 and 300 respectively.
Something like this will do the trick, assuming you already have a fully
working IGP and that both routers are already advertising a default route
into your IGP. Obviously, you'll want to change the IP addresses. YMMV, I
haven't had any coffee yet so I may have made some stupid mistakes but at
least this should get you started. :-)
Router 1
--------
interface serial0/0
description Serial link to ISP 1, AS 200
ip address 192.168.1.2 255.255.255.252
interface loopback0
ip address 100.1.1.1 255.255.255.255
router bgp 100
neighbor 100.1.1.2 remote-as 100
neighbor 100.1.1.2 update-source loopback0
neighbor 100.1.1.2 description iBGP peer with Router 2
neighbor 192.168.1.1 remote-as 200
neighbor 192.168.1.1 description eBGP peer with ISP 1.
no sync
Router 2
--------
interface serial0/0
description Serial link to ISP 2, AS 300
ip address 192.168.2.2 255.255.255.252
interface loopback0
ip address 100.1.1.2 255.255.255.255
router bgp 100
neighbor 100.1.1.1 remote-as 100
neighbor 100.1.1.1 update-source loopback0
neighbor 100.1.1.1 description iBGP peer with Router 1
neighbor 192.168.2.1 remote-as 200
neighbor 192.168.2.1 description eBGP peer with ISP 2.
no sync
-- Ryan O'Connell - CCIE #8174 <ryan@complicity.co.uk> - http://www.complicity.co.ukI'm not losing my mind, no I'm not changing my lines, I'm just learning new things with the passage of time
This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:11:59 EDT