I like to use IPSec / GRE Tunnels for this application. The config I
pasted is statically routed, but you could easily run your favorite
routing protocol.
Of course just mirror on the other router with appropriate IP address
changes.
Andre
crypto isakmp policy 10
encr 3des
hash md5
authentication pre-share
crypto isakmp key whatakey address 1.1.1.1
!
!
crypto ipsec transform-set vpn-3des esp-3des esp-md5-hmac
!
crypto map VPN local-address Ethernet0
crypto map VPN 10 ipsec-isakmp
description VPN to Satellite Office
set peer 1.1.1.1
set transform-set vpn-3des
match address 121
!
!
!
!
interface Tunnel0
description GRE Tunnel to Satellite Office
ip address 192.168.254.1 255.255.255.252
tunnel source 2.2.2.2
tunnel destination 1.1.1.1
crypto map VPN
!
interface Ethernet0
ip address 2.2.2.2 255.255.255.252
ip nat outside
half-duplex
crypto map VPN
!
interface FastEthernet0
ip address 192.168.1.254 255.255.255.0
ip nat inside
speed auto
!
ip nat inside source list 2 interface Ethernet0 overload
ip classless
ip route 192.168.0.0 255.255.255.0 192.168.254.2
no ip http server
ip pim bidir-enable
!
!
access-list 2 permit 192.168.1.0 0.0.0.255
access-list 121 permit gre host 1.1.1.1 host 3.3.3.3
On Fri, 2002-07-19 at 18:08, Daniel Cuautle wrote:
> Hi all,
>
> Somebody can help me for configure IPSec & L2TP between 2 LAN with
> private IP address, I have cisco 1600 IOS 12.0.
>
> I like some real example for configure this issue.
>
> Thanks
> DC
>
This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:13:50 EDT