Dear all,
Thanks for the advice. The last time I had just put down the basic
configuration, which was different from what I had mentioned.I have just
listed out the possible config in relevance to what I had mentioned the
last time, wherein a customer has dual links to the provider. I am really
sorry its huge.
Before that I have a doubt in Traffic Engineering which has been haunting
me for quiet some time. Assuming the following scenario -
Customer ABC-Corp has three sites in a provider's MPLS cloud connected in
a way as follows -
(Site A - Site B )
(Site A - Site C )
Customer XYZ-Corp has two sites in a provider's MPLS cloud connected in a
way as follows -
(Site D - Site E )
Can I configure strict source based routing within the MPLS cloud based on
a list destination RD values, or even probably based on destination RD:IP
Prefixes. To be more specifc, I would like certain traffic to a particular
destination RD / IP Prefix to choose an specified traffic engineered path
on the core, & other traffic choose another path. Is this achieveable on a
single PE router. Probably traffic withing ABC-Corp choose backbone link
1, & traffic of XYZ-Corp choose Backbone link 3. I have not mentioned the
configuration for traffic engineering.
CONFIGURATION:
hostname router1 (PE1 - local router@Chicago)
!
ip vrf customer-xyz
rd 1097:100
route-target both 1097:100
!
interface serial 0
description *** Primary link to customer XYZ ***
IP VRF FORWARDING customer-xyz
ip address 10.2.1.5 255.255.255.252
!
router ospf 1095 vrf customer-xyz
network 10.2.1.4 0.0.0.3 area0
!
router ospf 1 (Internal Service provider IGP)
network x area0
network y area0
network z area1
!
router bgp 1095
no bgp default ipv4-unicast
neighbor router2 remote-as 1097
neighbor router2 update-source loopback0
neighbor router2 activate
neighbor router3 remote-as 1097
neighbor router3 update-source loopback0
neighbor router3 activate
!
address-family ipv4 vrf customer-xyz
redistribute ospf
no auto-summary
no synchronization
exit-address-family
hostname router2 (PE2 - local router@chicago)
!
ip vrf customer-xyz
rd 1097:100
route-target both 1097:100
!
interface serial 0
description *** Secondary link to customer XYZ ***
IP VRF FORWARDING customer-xyz
ip address 11.2.1.5 255.255.255.252
!
ip route vrf customer-xyz 11.0.0.0 255.0.0.0 serial0 210 <floating static
route to customer's network>
!
router ospf 1 (Internal Service provider IGP)
network x area0
network y area0
network z area1
!
router bgp 1095
no bgp default ipv4-unicast
neighbor router1 remote-as 1097
neighbor router1 update-source loopback0
neighbor router1 activate
neighbor router3 remote-as 1097
neighbor router3 update-source loopback0
neighbor router3 activate
!
address-family ipv4 vrf customer-xyz
redistribute static
no auto-summary
no synchronization
exit-address-family
hostname router3 (PE3 - remote router@paris)
!
ip vrf customer-xyz
rd 1097:100
route-target both 1097:100
!
interface serial 2
description *** Link to customer XYZ ***
IP VRF FORWARDING customer-xyz
ip address 12.2.1.5 255.255.255.252
!
router ospf 1095 vrf customer-xyz
network 12.2.1.4 0.0.0.3 area0
!
router ospf 1 (Internal Service provider IGP)
network A area0
network B area0
network C area1
!
router bgp 1095
no bgp default ipv4-unicast
neighbor router1 remote-as 1097
neighbor router1 update-source loopback0
neighbor router1 activate
neighbor router2 remote-as 1097
neighbor router2 update-source loopback0
neighbor router2 activate
!
address-family ipv4 vrf customer-xyz
redistribute ospf
no auto-summary
no synchronization
exit-address-family
Kindly advice me.
With warm regards
Vinod.
This archive was generated by hypermail 2b29 : Sun Aug 04 2002 - 04:12:25 EDT