[cisco-bba] PPPoE config config
Ash Garg
ash at telstra.net
Wed Sep 24 19:51:32 EDT 2003
James,
As far as I can see:
interface ATM 1/IMA0.3 point-to-point
no ip directed-broadcast
PVC 1/36
encapsulation aal5snap
protocol pppoe
!
ties the interface to pppoe and
vpdn-group PPPoE1
accept-dialin
protocol pppoe
virtual-template 1
!
Tells all ppp sessions to clone off virtual template 1 which gives the
following:
interface Virtual-Template 1
ip unnumbered Loopback1
no ip directed-broadcast
peer default ip address pool PPPoE1
ppp authentication pap
!
which says that the ip address is send from the pool PPPoE1 and the auth
type is pap. You could do something with domain names ie:
interface ATM 1/IMA0.3 point-to-point
desc try domain test.net
no ip directed-broadcast
PVC 1/36
encapsulation aal5snap
protocol pppoe
!
interface ATM 1/IMA0.3 point-to-point
dest try domain guest.net
no ip directed-broadcast
PVC 1/36
encapsulation aal5snap
protocol pppoe
!
vpdn-group PPPoE1
accept-dialin
protocol pppoe
domain test.net
virtual-template 1
!
vpdn-group PPPoE2
accept-dialin
protocol pppoe
domain guest.net
virtual-template 2
!
interface Virtual-Template 1
ip unnumbered Loopback1
no ip directed-broadcast
peer default ip address pool PPPoE1
ppp authentication pap
interface Virtual-Template 2
ip unnumbered Loopback1
no ip directed-broadcast
ip address pool valor
ppp authentication chap
!
!
ip dhcp pool valor
network 65.19.30.0 255.255.255.0
domain-name cybermesa.com
default-router 65.19.30.1
dns-server 198.59.109.7
lease 0 6
!
I've tried some similar configs in the lab and I expect the above "should"
work...
Regards,
Ash
\\\|||///
\\ ^ ^ //
( 6 6 )
-----------------------------------------oOOo-(_)-oOOo---
Ash Garg 5/490 Northbourne Ave
Network Specialist DICKSON 2602
Internet Network Development
Telstra
Email: <<mailto:Ash.Garg at telstra.net>>
BH: +612 6208 1994
Mob: 0408 687 642
Fax: +612 6248 6165
The best way to publicize a governmental or political
action is to attempt to hide it. -Mark B. Cohen
----------------------------------------------------------
-----Original Message-----
From: cisco-bba-bounces at puck.nether.net
[mailto:cisco-bba-bounces at puck.nether.net]On Behalf Of james
Sent: Thursday, 25 September 2003 8:16 AM
To: cisco-bba at puck.nether.net
Subject: [cisco-bba] PPPoE config config
Would the list mind checking the PPPoE part of this config ?
What I am not clear on is that most of the pvc's get their address
via DHCP, off the router. In this config I am not seeing how PPPoE
gets applied to the interface, since there is no VI applied to the pvc
that does PPPoE. Can I do both DHCP, on some interfaces &
PPPoE on select interfaces ?
Router is 2620, soon to be 7206.
version 12.1
no service single-slot-reload-enable
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service compress-config
!
hostname esp-dsl
!
logging buffered 4096 debugging
logging rate-limit console 10 except errors
no logging console
enable password 7 xxxxxxxxxxxxx
!
username eyecare password 7 xxxxxxxxx
clock timezone MST -7
clock summer-time MDT recurring
ip subnet-zero
no ip source-route
!
!
no ip finger
ip ftp username routerdump
ip ftp password 7 xxxxxxxxxxx
no ip domain-lookup
ip domain-name cybermesa.com
ip name-server 198.59.109.7
ip name-server 206.222.97.82
!
ip dhcp pool valor
network 65.19.30.0 255.255.255.0
domain-name cybermesa.com
default-router 65.19.30.1
dns-server 198.59.109.7
lease 0 6
!
ip multicast-routing
ip cef
vpdn enable
no vpdn logging
!
vpdn-group PPPoE1
accept-dialin
protocol pppoe
virtual-template 1
!
call rsvp-sync
cns event-service server
!
!
!
!
!
bridge irb
!
!
!
interface Loopback1
ip address 65.19.20.129 255.255.255.128
!
interface Null0
no ip unreachables
!
interface FastEthernet0/0
description Espanola DSL ATM router
ip address 65.19.11.8 255.255.255.0
ip access-group 102 out
no ip proxy-arp
ip pim dense-mode
duplex auto
speed auto
ntp multicast client
no cdp enable
!
interface ATM1/0
no ip address
atm vc-per-vp 256
no atm ilmi-keepalive
ima-group 0
no scrambling-payload
!
interface ATM1/1
description Espanola Valor ATM T1 # 2
no ip address
atm vc-per-vp 256
no atm ilmi-keepalive
ima-group 0
no scrambling-payload
!
interface ATM1/2
no ip address
shutdown
atm vc-per-vp 256
atm ilmi-keepalive
no scrambling-payload
!
interface ATM1/3
no ip address
shutdown
atm vc-per-vp 256
atm ilmi-keepalive
no scrambling-payload
!
interface ATM1/IMA0
no ip address
atm vc-per-vp 256
atm ilmi-keepalive
ima differential-delay-maximum 100
!
interface ATM1/IMA0.1 multipoint
description Espanola DSL Bridged IMA group
pvc 0/36
!
pvc 0/37
!
pvc 0/38
!
pvc 0/39
!
pvc 0/40
<ect>
!
interface ATM1/IMA0.2 multipoint
description static DSL customers
no ip redirects
no ip unreachables
no ip mroute-cache
pvc 0/186
protocol ip 65.19.20.3 no broadcast
!
pvc 7/73
!
interface ATM 1/IMA0.3 point-to-point
no ip directed-broadcast
PVC 1/36
encapsulation aal5snap
protocol pppoe
!
interface Virtual-Template 1
ip unnumbered Loopback1
no ip directed-broadcast
peer default ip address pool PPPoE1
ppp authentication pap
!
ip local pool PPPoE1 65.19.20.130
!
interface BVI1
ip address 65.19.30.1 255.255.255.0
no ip unreachables
no ip proxy-arp
arp timeout 3600
clns mtu 1514
hold-queue 150 in
!
interface BVI2
ip address 65.19.20.1 255.255.255.128
no ip unreachables
no ip proxy-arp
arp timeout 3600
clns mtu 1514
hold-queue 150 in
!
bridge 1 protocol ieee
bridge 1 route ip
bridge 1 aging-time 3600
bridge 2 protocol ieee
bridge 2 route ip
bridge 2 aging-time 3600
!
_______________________________________________
cisco-bba mailing list
cisco-bba at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-bba
More information about the cisco-bba
mailing list