[cisco-bba] PPPoE multilink

Sigurbjörn Birkir Lárusson sigurbjornl at ogvodafone.is
Wed Dec 21 09:24:10 EST 2005


I've been using multiple bundled SHDSL connections (using Cisco 1800's and 2800's) with our ATM DSLAMS for quite some time now, this was terminated on the BRAS like so:

interface Multilink72
 description yyy
 ip vrf forwarding zzz
 ip address xxx.xxx.xxx.xxx 255.255.255.252
 ppp multilink
 ppp multilink group 72
 
interface ATM1/0.vvv point-to-point
 description yyy->line 1
 ip vrf forwarding zzz
 pvc 0/vvv 
  encapsulation aal5snap
  protocol ppp Virtual-Template72
 !
!
interface ATM1/0.vvv+1 point-to-point
 description yyy->line 2
 ip vrf forwarding zzz
 pvc 0/vvv+1
  encapsulation aal5snap
  protocol ppp Virtual-Template72
 !
 
interface Virtual-Template72
 ip vrf forwarding zzz
 no ip address
 ppp multilink
 ppp multilink group 72

This worked fine, and with as many links as the customers wanted using a very similar setup on the customer router against it.

Now I want to do the same thing, for a customer connected to an "IP DSLAM" i.e. the BRAS terminates the ATM connection itself, and I want to do it over PPPoE, since that's how the BRAS is setup towards the "IP DSLAM".  

Show ppp multilink says:

Virtual-Access4, bundle name is B0x-TEST
  Endpoint discriminator is B0x-TEST
  Bundle up for 00:03:08, 1/255 load
  Receive buffer limit 24384 bytes, frag timeout 1000 ms
  Dialer interface is Dialer1
    0/0 fragments/bytes in reassembly list
    24 lost fragments, 45 reordered
    14/1244 discarded fragments/bytes, 0 lost received
    0xAA received sequence, 0x95 sent sequence
  Member links: 2 (max not set, min not set)
    Vi2, since 00:03:14
    Vi3, since 00:03:11
No inactive multilink interfaces

Vi2 and Vi3 are straight copies from Dialer1.

Dialer 1 config is:

interface Dialer1
 mtu 1492
 bandwidth 4000
 ip address negotiated
 ip load-sharing per-packet
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer idle-timeout 600
 dialer-group 1
 ppp pap sent-username xxxxxx password 0 xxxxx

The config for the SHDSL interfaces:
interface ATM0/0/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0/0/0.33 point-to-point
 pvc 0/33
  encapsulation aal5snap
  pppoe-client dial-pool-number 1
 !
!
interface ATM0/1/0
 no ip address
 no atm ilmi-keepalive
!
interface ATM0/1/0.33 point-to-point
 pvc 0/33
  encapsulation aal5snap
  pppoe-client dial-pool-number 1

The virtual-template on the BRAS terminating the pppoe client:

interface Virtual-Template1
 ip vrf forwarding ggggg
 ip unnumbered Loopback0
 ip mtu 1492
 ip tcp adjust-mss 1400
 no logging event link-status
 load-interval 30
 no peer default ip address
 ppp authentication pap chap
 ppp multilink
end

IOS on the 1841 test CPE is 12.3(8r)T8

IOS on the 7206 NPE-G1 test BRAS is 12.3(5a)B5

This "works".  I can ping the BRAS just fine, no packet loss even on large packets.  However, if I ping something, outside of the bras, I get heavy packet loss (40-60%) and some packets never seem to get through.  Removing ppp multilink from dialer1 solves the problem, but of course only allows the end user to use one of his SHDSL connections. 

Of course I could split this up into two dialers, assign each ATM interface into a different dial pool, and route 0.0.0.0 0.0.0.0 over both dialer1 and dialer2, doing load sharing, but that doesn't give the customer a single download of n*2Mbits like he is used to, and it's going to be very hard for me to explain to the customer that he does indeed get all the bandwidth he used to, just not all on one connection.

I've experimented with ppp multilink interleave and ppp multilink fragment settings to no avail.

Has anyone successfully done PPP multilink on two PPPoE connections?  And if not, is there another way to implement the same functionality, preferebly one that allows the user to reach his maximum speed (n*2Mbit) on a single download?  I have the option to have the customer connections split into a separate vlan from the normal PPPoE traffic, and I could also split it into two (or more) separate vlans (one for each connection) if that enables a solution.

Best regards,
Sigurbjörn B. Lárusson
Network Specialist

E-mail: sigurbjornl at ogvodafone.is
Tel: (+354) 599 9000
Fax: (+354) 599 9005

Og Vodafone
Sidumuli 28
108 Reykjavik
Iceland
www.ogvodafone.is





More information about the cisco-bba mailing list