[cisco-bba] TCP and PPPoE problems with one type of CPE

Robert Blayzor rblayzor at inoc.net
Sat Jun 23 17:48:41 EDT 2007

Frank Bulk wrote:
> Doesn't sounds like an easy one to solve.
> If I was in that position I would be asking the customer to push back on
> ZyXEL tech support for assistance, assuring the customer of my willingness
> to work with them and ZyXEL tech support. 

I actually found out what was causing this.  It has to do with TCP
header compression.  By default I believe the 7200 (12.2 SB) tcp header
compression is set passive and will only send compressed data to the
connecting PPPoE host if it sends compressed data.

Our packet traces showed this to be the case.  When the session came up
a connection initiated without compression was replied to by the Zywall
with TCP header compression in use.  From that point on all the TCP
headers from the 7200 side were sent compressed.  At that point, the
Zyxel would reply back with something like "VJ compressed TCP (unknown
direction)". (at least that's the flags/indication from Wireshark).  But
the Zyxel is clearly complaining about the TCP header compression from
the 7200 end of the connection.

If we turn off header compression completely on the 7200 side, things
work well again.  Keep in mind that none of our other CPE's are seeing
this problem.  The strange thing is this has worked until we
moved/upgraded things to 12.2SB series routers.  So I'm not sure what
changed in header compression on the Cisco end that caused the Zyxels to
start acting up.  But it appears to be a Zyxel problem, every other
PPPoE client we've tried works fine.

Robert Blayzor
rblayzor at inoc.net

NOTICE: alloc: /dev/null: filesystem full

More information about the cisco-bba mailing list