[cisco-nas] AS5350

Oliver Boehmer (oboehmer) oboehmer at cisco.com
Mon Jun 21 11:35:15 EDT 2004


Hi,

you're missing IP config on your group-async1, so PPP will refuse to
start IPCP on your async connections. so please add

int loopback0
 ip address ...

int group-async1
 ip unnumbered loopback0

There is also a typo at "aaa authentication ppp".. it should say
"default", not "defult", "if-needed" might not be necessary here. I'd
add "aaa authorization network default local" as well, but this is not
strictly needed..

	oli

kh MOh <> wrote on Monday, June 21, 2004 8:56 AM:

> hi, I have a little problem I have an AS5350 for ISP,
> the problem is after I configure every thing and try
> to login through a modem an error message appear
> stating error 770 TCP error here is the Router config
> 
> ********************************************
> 
> 
> 
> 
> Current configuration : 2741 bytes
> !
> version 12.1
> no service single-slot-reload-enable
> service timestamps debug datetime msec
> service timestamps log datetime msec
> service password-encryption
> !
> hostname Router
> !
> no boot startup-test
> logging rate-limit console 10 except errors
> aaa new-model
> aaa authentication login default local
> aaa authentication login defult local
> aaa authentication ppp defult if-needed local
> enable secret 5 *.*.*.*
> !
> username admin password 7 020F105508
> username itnc password 7 09455A071A
> username alfanet password 7 01120A025A05031B
> !
> 
> resource-pool disable
> calltracker enable
> calltracker call-record terse
> !
> !
> !
> !
> voice-fastpath enable
> ip subnet-zero
> no ip finger
> no ip domain-lookup
> ip name-server *.*.*.*
> ip name-server *.*.*.*
> !
> async-bootp dns-server *.*.*.* *.*.*.*
> isdn switch-type primary-net5
> call rsvp-sync
> !
> !
> !
> !
> 
> fax interface-type modem
> mta receive maximum-recipients 0
> !
> !
> !
> controller E1 3/0
>  pri-group timeslots 1-31
> !
> controller E1 3/1
>  pri-group timeslots 1-31
> !
> !
> interface FastEthernet0/0
>  ip address *.*.*.* *.*.*.*
>  duplex auto
>  speed auto
>  no cdp enable
> !
> interface FastEthernet0/1
>  ip address *.*.*.* *.*.*.*
>  duplex full
>  speed 100
>  --More--          no cdp enable
> !
> interface Serial0/0
>  no ip address
>  encapsulation frame-relay
>  shutdown
>  clockrate 2000000
>  frame-relay interface-dlci 16
> !
> interface Serial0/1
>  no ip address
>  encapsulation frame-relay
> !
> interface Serial0/1.1 point-to-point
>  ip address *.*.*.*  *.*.*.*
>  no cdp enable
>  frame-relay interface-dlci 16
> !
> interface Serial3/0:15
>  no ip address
>  encapsulation ppp
>  isdn switch-type primary-net5
>  isdn incoming-voice modem
>   no cdp enable
> !
> interface Serial3/1:15
>  no ip address
>  encapsulation ppp
>  isdn switch-type primary-net5
>  isdn incoming-voice modem
>  no cdp enable
> !
> interface Group-Async0
>  no ip address
>  encapsulation ppp
>  async mode interactive
>  peer default ip address pool addr-pool
>  ppp authentication chap pap
>  no group-range
> !
> interface Group-Async1
>  no ip address
>  encapsulation ppp
>  no logging event link-status
>  async mode interactive
>  no snmp trap link-status
>  peer default ip address pool addr-pool
>  ppp authentication chap pap
>  group-range 1/00 1/59
> !
> ip local pool addr-pool *.*.*.* *.*.*.*
> ip classless
> no ip http server
> !
> no cdp run
> !
> !
> voice-port 3/0:D
> !
> voice-port 3/1:D
> !
> dial-peer voice 1 pots
> !
> !
> line con 0
>  transport input none
> line aux 0
>  autoselect during-login
>  autoselect ppp
>  line vty 0 4
>  autoselect during-login
>  autoselect ppp
> line vty 5 58
>  autoselect during-login
>  autoselect ppp
> line 1/00 1/59
>  no flush-at-activation
>  autoselect during-login
>  autoselect ppp
>  modem InOut
> !
> scheduler allocate 10000 400
> end
> 
> ***************************************
> 
> here is the ppp authentication debug output
> 
> *Jan  1 01:26:44.615: %ISDN-6-CONNECT: Interface
> Serial3/1:7 is now connected to 0183782702
> *Jan  1 01:27:10.363: AAA: parse name=tty1/36 idb
> type=10 tty=252
> *Jan  1 01:27:10.363: AAA: name=tty1/36 flags=0x11
> type=4 shelf=0 slot=0 adapter=0 port=252 channel=0
> *Jan  1 01:27:10.363: AAA: parse name=Serial3/1:7 idb
> type=13 tty=-1
> *Jan  1 01:27:10.363: AAA: name=Serial3/1:7 flags=0x55
> type=1 shelf=0 slot=3 adapter=0 port=1 channel=7
> *Jan  1 01:27:10.363: AAA/MEMORY: create_user
> (0x6357E060) user='NULL' ruser='NULL' ds0=50335751
> port='tty1/36' rem_addr='0183782702/1285'
> authen_type=ASCII service=LOGIN priv=1
> *Jan  1 01:27:10.363: AAA/AUTHEN/START (1559833238):
> port='tty1/36' list='' action=LOGIN service=LOGIN
> *Jan  1 01:27:10.363: AAA/AUTHEN/START (1559833238):
> using "default" list
> *Jan  1 01:27:10.363: AAA/AUTHEN/START (1559833238):
> Method=LOCAL
> *Jan  1 01:27:10.363: AAA/AUTHEN (1559833238): status
> = GETUSER
> *Jan  1 01:27:10.363: AAA/AUTHEN/ABORT: (1559833238)
> because Autoselected.
> *Jan  1 01:27:10.363: AAA/AUTHEN/ABORT: (1559833238)
> because Autoselected.
> *Jan  1 01:27:10.363: AAA/MEMORY: free_user_quiet
> (0x6357E060) user='NULL' ruser='NULL' port='tty1/36'
> rem_addr='0183782702/1285' authen_type=1 service=1
> priv=1
> *Jan  1 01:27:10.367: As1/36 LCP: I CONFREQ [Closed]
> id 0 len 23
> *Jan  1 01:27:10.367: As1/36 LCP:    ACCM 0x00000000
> (0x020600000000)
> *Jan  1 01:27:10.367: As1/36 LCP:    MagicNumber
> 0x6B2D7CAC (0x05066B2D7CAC)
> *Jan  1 01:27:10.367: As1/36 LCP:    PFC (0x0702)
> *Jan  1 01:27:10.367: As1/36 LCP:    ACFC (0x0802)
> *Jan  1 01:27:10.367: As1/36 LCP:    Callback 6
> (0x0D0306)
> *Jan  1 01:27:10.367: As1/36 LCP: Lower layer not up,
> Fast Starting
> *Jan  1 01:27:10.367: As1/36 PPP: Treating connection
> as a dedicated line
> *Jan  1 01:27:10.367: As1/36 PPP: Phase is
> ESTABLISHING, Active Open [0 sess, 1 load]
> *Jan  1 01:27:10.367: As1/36 LCP: O CONFREQ [Closed]
> id 1 len 25
> *Jan  1 01:27:10.367: As1/36 LCP:    ACCM 0x000A0000
> (0x0206000A0000)
> *Jan  1 01:27:10.367: As1/36 LCP:    AuthProto CHAP
> (0x0305C22305)
> *Jan  1 01:27:10.367: As1/36 LCP:    MagicNumber
> 0x09931B2F (0x050609931B2F)
> *Jan  1 01:27:10.367: As1/36 LCP:    PFC (0x0702)
> *Jan  1 01:27:10.367: As1/36 LCP:    ACFC (0x0802)
> *Jan  1 01:27:10.367: As1/36 LCP: O CONFREJ [REQsent]
> id 0 len 7
> *Jan  1 01:27:10.367: As1/36 LCP:    Callback 6
> (0x0D0306)
> *Jan  1 01:27:10.559: As1/36 LCP: I CONFACK [REQsent]
> id 1 len 25
> *Jan  1 01:27:10.559: As1/36 LCP:    ACCM 0x000A0000
> (0x0206000A0000)
> *Jan  1 01:27:10.559: As1/36 LCP:    AuthProto CHAP
> (0x0305C22305)
> *Jan  1 01:27:10.559: As1/36 LCP:    MagicNumber
> 0x09931B2F (0x050609931B2F)
> *Jan  1 01:27:10.559: As1/36 LCP:    PFC (0x0702)
> *Jan  1 01:27:10.559: As1/36 LCP:    ACFC (0x0802)
> *Jan  1 01:27:10.575: As1/36 LCP: I CONFREQ [ACKrcvd]
> id 1 len 20
> *Jan  1 01:27:10.575: As1/36 LCP:    ACCM 0x00000000
> (0x020600000000)
> *Jan  1 01:27:10.575: As1/36 LCP:    MagicNumber
> 0x6B2D7CAC (0x05066B2D7CAC)
> *Jan  1 01:27:10.575: As1/36 LCP:    PFC (0x0702)
> *Jan  1 01:27:10.575: As1/36 LCP:    ACFC (0x0802)
> *Jan  1 01:27:10.575: As1/36 LCP: O CONFACK [ACKrcvd]
> id 1 len 20
> *Jan  1 01:27:10.575: As1/36 LCP:    ACCM 0x00000000
> (0x020600000000)
> *Jan  1 01:27:10.575: As1/36 LCP:    MagicNumber
> 0x6B2D7CAC (0x05066B2D7CAC)
> *Jan  1 01:27:10.575: As1/36 LCP:    PFC (0x0702)
> *Jan  1 01:27:10.575: As1/36 LCP:    ACFC (0x0802)
> *Jan  1 01:27:10.575: As1/36 LCP: State is Open
> *Jan  1 01:27:10.575: As1/36 PPP: Phase is
> AUTHENTICATING, by this end [0 sess, 1 load]
> *Jan  1 01:27:10.575: As1/36 CHAP: O CHALLENGE id 1
> len 27 from "Router"
> *Jan  1 01:27:10.759: As1/36 LCP: I IDENTIFY [Open] id
> 2 len 18 magic 0x6B2D7CAC MSRASV5.10
> *Jan  1 01:27:10.759: As1/36 LCP: I IDENTIFY [Open] id
> 3 len 26 magic 0x6B2D7CAC MSRAS-1-AAUMANAGER
> *Jan  1 01:27:10.767: As1/36 CHAP: I RESPONSE id 1 len
> 28 from "alfanet"
> *Jan  1 01:27:10.771: AAA: parse name=Async1/36 idb
> type=10 tty=252
> *Jan  1 01:27:10.771: AAA: name=Async1/36 flags=0x11
> type=4 shelf=0 slot=0 adapter=0 port=252 channel=0
> *Jan  1 01:27:10.771: AAA: parse name=Serial3/1:7 idb
> type=13 tty=-1
> *Jan  1 01:27:10.771: AAA: name=Serial3/1:7 flags=0x55
> type=1 shelf=0 slot=3 adapter=0 port=1 channel=7
> *Jan  1 01:27:10.771: AAA/MEMORY: create_user
> (0x637019C4) user='alfanet' ruser='NULL' ds0=50335751
> port='Async1/36' rem_addr='0183782702/1285'
> authen_type=CHAP service=PPP priv=1
> *Jan  1 01:27:10.771: AAA/AUTHEN/START (1296610873):
> port='Async1/36' list='' action=LOGIN service=PPP
> *Jan  1 01:27:10.771: AAA/AUTHEN/START (1296610873):
> non console login - defaults to local database
> *Jan  1 01:27:10.771: AAA/AUTHEN/START (1296610873):
> Method=LOCAL
> *Jan  1 01:27:10.771: AAA/AUTHEN (1296610873): status
> = PASS
> *Jan  1 01:27:10.771: As1/36 CHAP: O SUCCESS id 1 len
> 4
> *Jan  1 01:27:10.771: As1/36 PPP: Phase is UP [0 sess,
> 1 load]
> *Jan  1 01:27:10.935: As1/36 CCP: I CONFREQ [Not
> negotiated] id 4 len 10
> *Jan  1 01:27:10.935: As1/36 CCP:    MS-PPC supported
> bits 0x00000001 (0x120600000001)
> *Jan  1 01:27:10.935: As1/36 LCP: O PROTREJ [Open] id
> 2 len 16 protocol CCP (0x80FD0104000A120600000001)
> *Jan  1 01:27:10.943: As1/36 IPCP: I CONFREQ [Not
> negotiated] id 5 len 40
> *Jan  1 01:27:10.943: As1/36 IPCP:    CompressType VJ
> 15 slots CompressSlotID (0x0206002D0F01)
> *Jan  1 01:27:10.943: As1/36 IPCP:    Address 0.0.0.0
> (0x030600000000)
> *Jan  1 01:27:10.943: As1/36 IPCP:    PrimaryDNS
> 0.0.0.0 (0x810600000000)
> *Jan  1 01:27:10.943: As1/36 IPCP:    PrimaryWINS
> 0.0.0.0 (0x820600000000)
> *Jan  1 01:27:10.943: As1/36 IPCP:    SecondaryDNS
> 0.0.0.0 (0x830600000000)
> *Jan  1 01:27:10.943: As1/36 IPCP:    SecondaryWINS
> 0.0.0.0 (0x840600000000)
> *Jan  1 01:27:10.943: As1/36 LCP: O PROTREJ [Open] id
> 3 len 46 protocol IPCP
> *Jan  1 01:27:10.943: As1/36 LCP:
> (0x8021010500280206002D0F0103060000)
> *Jan  1 01:27:10.943: As1/36 LCP:
> (0x00008106000000008206000000008306)
> *Jan  1 01:27:10.943: As1/36 LCP:
> (0x00000000840600000000)
> 
> *Jan  1 01:27:16.363: As1/36 PPP: Phase is TERMINATING
> [0 sess, 1 load]
> *Jan  1 01:27:16.363: As1/36 LCP: State is Closed
> *Jan  1 01:27:16.363: As1/36 PPP: Phase is DOWN [0
> sess, 1 load]
> *Jan  1 01:27:19.363: AAA/MEMORY: free_user
> (0x637019C4) user='alfanet' ruser='NULL'
> port='Async1/36' rem_addr='0183782702/1285'
> authen_type=CHAP service=PPP priv=1
> *Jan  1 01:27:19.363: As1/36 IPCP: Remove route to
> 212.0.136.3
> *Jan  1 01:27:21.363: As1/36 LCP: State is Closed
> 
> 
> 
> 
> 
> 
> 
> __________________________________
> Do you Yahoo!?
> New and Improved Yahoo! Mail - Send 10MB messages!
> http://promotions.yahoo.com/new_mail
> _______________________________________________
> cisco-nas mailing list
> cisco-nas at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nas



More information about the cisco-nas mailing list