[nsp] HSRP stops responding with route-map

Ken.Wortendyke@us.didata.com Ken.Wortendyke@us.didata.com
Mon, 26 Aug 2002 09:30:07 -0400


Never tried this, but...

It appears that your route-map is rewriting the HSRP packets before they get
to the HSRP process on the router.

You should be able to redo ACL 110 starting with a DENY for source IP's
10.166.64.2 and 10.166.64.3.
As a sanity check, you might want to deny 10.166.64.1 as well.
Then your blanket permit statement should follow.

Hope this helps,
Ken W

-----Original Message-----
From: Stephane Gingras [mailto:stephane.gingras@cgi.com]
Sent: Thursday, August 22, 2002 9:38 AM
To: cisco-nsp@puck.nether.net
Subject: [nsp] HSRP stops responding with route-map


Hi, I have two routers that have an HSRP process running. As soon as I
apply a route map to the interfaces, the HSRP process stops working and
they both become active. Here's an example of the configurations.


Router 1:

interface FastEthernet0/0.64
 description Segment Corpo 1
 encapsulation isl 64
 ip address 10.166.64.2 255.255.254.0
 ip policy route-map net-corpo
 standby 1 priority 110
 standby 1 preempt
 standby 1 ip 10.166.64.1
!
access-list 110 permit ip 10.166.64.0 0.0.1.255 any
!
route-map net-corpo permit 10
 match ip address 110
 set ip next-hop 10.199.99.1
!


Router 2:

interface FastEthernet0.64
 description Segment Corpo 1
 encapsulation isl 64
 ip address 10.166.64.3 255.255.254.0
 no ip redirects
 ip policy route-map net-corpo
 standby 1 priority 100
 standby 1 ip 10.166.64.1
!
access-list 110 permit ip 10.166.64.0 0.0.1.255 any
!
route-map net-corpo permit 10
 match ip address 110
 set ip next-hop 10.199.99.1


Thanks,

Stephane


_______________________________________________
cisco-nsp mailing list  real_name)s@puck.nether.net
http://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/