[nsp] VoIP question

Andrew andrew2@one.net
Wed, 25 Sep 2002 14:55:17 -0400


This is a multi-part message in MIME format.

------=_NextPart_000_0038_01C264A3.900D6900
Content-Type: text/plain;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

Being new to the whole voice side of things these may be very basic =
questions, but TFM hasn't seemed to help much here, so I defer to the =
wisdom of nsp...

I have a situation where I have a main office with a Panasonic phone =
switch/voicemail system administrated by an outside company so =
unfortunately I can't provide many details about that piece of the =
equation.  There is a satellite office connected to the main office via =
T1.  Each end of the T1 is serviced by a 2620 with a two-port VIC card.  =
The satellite office has two extensions, one of which is to ring when =
the main line at the main office is called.  Additionally the extensions =
at the satellite office should be able to dial extensions in the main =
office as if they were in the main office, as well as make outgoing =
calls via the switchboard in the main office.

I've been successful in getting most everything working as described =
above, but have run into a problem with one part.  Right now i am able =
to place outgoing calls via the T1, and can dial into the voicemail =
system etc. at the main office from the remote office and vice versa.  =
However incoming calls to the main voice line at the main office are =
*immediately* picked up by what I can only assume is the router and =
dropped to a dialtone. =20

Is there some bit of configuration I'm missing to allow that incoming =
call to be forwarded along over the T1 to an extension in the satellite =
office?  Configurations follow, any suggestions are greatly appreciated:

Main office config:

Using 1236 out of 29688 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname MAW
!
enable secret 5 $1$GdZn$pCkauThYr4TJ1436b989A/
enable password maw
!
!
!
!
!
ip subnet-zero
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
dial-peer voice 1 voip
 destination-pattern +104
 req-qos guaranteed-delay
 session target ipv4:192.168.2.1
!
dial-peer voice 2 pots
 destination-pattern +.
 port 1/0/0
!
dial-peer voice 3 pots
 destination-pattern +.
 port 1/0/1
!
dial-peer voice 4 voip
 destination-pattern +205
 req-qos guaranteed-delay
 session target ipv4:192.168.2.1
!
!
!
interface FastEthernet0/0
 ip address 192.168.1.2 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 bandwidth 1544
 ip address 10.10.10.1 255.255.255.0
 encapsulation ppp
 ip tcp header-compression iphc-format
 no ip mroute-cache
 fair-queue 128 256 36
 service-module t1 clock source internal
 ip rtp header-compression iphc-format
 ip rtp compression-connections 25
 ip rsvp bandwidth 128 128
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
ip route 192.168.2.0 255.255.255.0 10.10.10.2
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password maw
 login
!
end


Satellite office config:

Using 1103 out of 29688 bytes
!
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Scott
!
enable secret 5 $1$Sz.r$ejIBy.gEVliUuo4A4CkPX.
enable password scott
!
!
!
!
!
ip subnet-zero
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
!
dial-peer voice 1 voip
 destination-pattern +...
 session target ipv4:192.168.1.2
!
dial-peer voice 2 pots
 destination-pattern +104
 port 1/0/0
!
dial-peer voice 3 pots
 destination-pattern +205
 port 1/0/1
!
dial-peer voice 4 voip
 destination-pattern +9
 session target ipv4:192.168.1.2
!
!
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 bandwidth 1544
 ip address 10.10.10.2 255.255.255.0
 encapsulation ppp
 ip tcp header-compression iphc-format
 no ip mroute-cache
 fair-queue 128 256 4
 ip rtp header-compression iphc-format
 ip rtp compression-connections 25
 ip rsvp bandwidth 128 128
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.10.10.1
no ip http server
!
!
line con 0
line aux 0
line vty 0 4
 password scott
 login
!
end

------=_NextPart_000_0038_01C264A3.900D6900
Content-Type: text/html;
	charset="iso-8859-1"
Content-Transfer-Encoding: quoted-printable

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<HTML><HEAD>
<META http-equiv=3DContent-Type content=3D"text/html; =
charset=3Diso-8859-1">
<META content=3D"MSHTML 6.00.2719.2200" name=3DGENERATOR>
<STYLE></STYLE>
</HEAD>
<BODY bgColor=3D#ffffff>
<DIV><FONT face=3DArial size=3D2>Being new to the whole voice side of =
things these=20
may be very basic questions, but TFM hasn't seemed to help much here, so =
I defer=20
to the wisdom of nsp...</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>I have a situation where I have a main =
office with=20
a Panasonic phone switch/voicemail system administrated by an outside =
company so=20
unfortunately I can't provide many details about that piece of the=20
equation.&nbsp; There is a satellite office connected to the main office =
via=20
T1.&nbsp; Each end of the T1 is serviced by a 2620 with a two-port VIC=20
card.&nbsp; The satellite office has two extensions, one of which is to =
ring=20
when the main line at the main office is called.&nbsp; Additionally the=20
extensions at the satellite office should be able to dial extensions in =
the main=20
office as if they were in the main office, as well as make outgoing =
calls via=20
the switchboard in the main office.</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>I've been successful in getting most =
everything=20
working as described above, but have run into a problem with one =
part.&nbsp;=20
Right now i am able to place outgoing calls via the T1, and can dial =
into the=20
voicemail system etc. at the main office from the remote office and vice =

versa.&nbsp; However incoming calls to the main voice line at the main =
office=20
are *immediately* picked up by what I can only assume is the router and =
dropped=20
to a dialtone.&nbsp; </FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Is there some bit of configuration I'm =
missing to=20
allow that incoming call to be forwarded along over the T1 to an =
extension in=20
the satellite office?&nbsp; Configurations follow, any suggestions are =
greatly=20
appreciated:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Main office config:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV>Using 1236 out of 29688 bytes<BR>!<BR>version 12.1<BR>no service=20
single-slot-reload-enable<BR>service timestamps debug uptime<BR>service=20
timestamps log uptime<BR>no service password-encryption<BR>!<BR>hostname =

MAW<BR>!<BR>enable secret 5 $1$GdZn$pCkauThYr4TJ1436b989A/<BR>enable =
password=20
maw<BR>!<BR>!<BR>!<BR>!<BR>!<BR>ip =
subnet-zero<BR>!<BR>!<BR>!<BR>voice-port=20
1/0/0<BR>!<BR>voice-port 1/0/1<BR>!<BR>!<BR>dial-peer voice 1=20
voip<BR>&nbsp;destination-pattern +104<BR>&nbsp;req-qos=20
guaranteed-delay<BR>&nbsp;session target =
ipv4:192.168.2.1<BR>!<BR>dial-peer=20
voice 2 pots<BR>&nbsp;destination-pattern +.<BR>&nbsp;port=20
1/0/0<BR>!<BR>dial-peer voice 3 pots<BR>&nbsp;destination-pattern=20
+.<BR>&nbsp;port 1/0/1<BR>!<BR>dial-peer voice 4=20
voip<BR>&nbsp;destination-pattern +205<BR>&nbsp;req-qos=20
guaranteed-delay<BR>&nbsp;session target=20
ipv4:192.168.2.1<BR>!<BR>!<BR>!<BR>interface FastEthernet0/0<BR>&nbsp;ip =
address=20
192.168.1.2 255.255.255.0<BR>&nbsp;duplex auto<BR>&nbsp;speed=20
auto<BR>!<BR>interface Serial0/0<BR>&nbsp;bandwidth 1544<BR>&nbsp;ip =
address=20
10.10.10.1 255.255.255.0<BR>&nbsp;encapsulation ppp<BR>&nbsp;ip tcp=20
header-compression iphc-format<BR>&nbsp;no ip =
mroute-cache<BR>&nbsp;fair-queue=20
128 256 36<BR>&nbsp;service-module t1 clock source internal<BR>&nbsp;ip =
rtp=20
header-compression iphc-format<BR>&nbsp;ip rtp compression-connections=20
25<BR>&nbsp;ip rsvp bandwidth 128 128<BR>!<BR>ip classless<BR>ip route =
0.0.0.0=20
0.0.0.0 192.168.1.1<BR>ip route 192.168.2.0 255.255.255.0 =
10.10.10.2<BR>no ip=20
http server<BR>!<BR>!<BR>line con 0<BR>line aux 0<BR>line vty 0=20
4<BR>&nbsp;password maw<BR>&nbsp;login<BR>!<BR>end<BR></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV><FONT face=3DArial size=3D2>Satellite office config:</FONT></DIV>
<DIV><FONT face=3DArial size=3D2></FONT>&nbsp;</DIV>
<DIV>Using 1103 out of 29688 bytes<BR>!<BR>version 12.1<BR>no service=20
single-slot-reload-enable<BR>service timestamps debug uptime<BR>service=20
timestamps log uptime<BR>no service password-encryption<BR>!<BR>hostname =

Scott<BR>!<BR>enable secret 5 $1$Sz.r$ejIBy.gEVliUuo4A4CkPX.<BR>enable =
password=20
scott<BR>!<BR>!<BR>!<BR>!<BR>!<BR>ip =
subnet-zero<BR>!<BR>!<BR>!<BR>voice-port=20
1/0/0<BR>!<BR>voice-port 1/0/1<BR>!<BR>!<BR>dial-peer voice 1=20
voip<BR>&nbsp;destination-pattern +...<BR>&nbsp;session target=20
ipv4:192.168.1.2<BR>!<BR>dial-peer voice 2 =
pots<BR>&nbsp;destination-pattern=20
+104<BR>&nbsp;port 1/0/0<BR>!<BR>dial-peer voice 3=20
pots<BR>&nbsp;destination-pattern +205<BR>&nbsp;port =
1/0/1<BR>!<BR>dial-peer=20
voice 4 voip<BR>&nbsp;destination-pattern +9<BR>&nbsp;session target=20
ipv4:192.168.1.2<BR>!<BR>!<BR>!<BR>interface FastEthernet0/0<BR>&nbsp;ip =
address=20
192.168.2.1 255.255.255.0<BR>&nbsp;duplex auto<BR>&nbsp;speed=20
auto<BR>!<BR>interface Serial0/0<BR>&nbsp;bandwidth 1544<BR>&nbsp;ip =
address=20
10.10.10.2 255.255.255.0<BR>&nbsp;encapsulation ppp<BR>&nbsp;ip tcp=20
header-compression iphc-format<BR>&nbsp;no ip =
mroute-cache<BR>&nbsp;fair-queue=20
128 256 4<BR>&nbsp;ip rtp header-compression iphc-format<BR>&nbsp;ip rtp =

compression-connections 25<BR>&nbsp;ip rsvp bandwidth 128 128<BR>!<BR>ip =

classless<BR>ip route 0.0.0.0 0.0.0.0 10.10.10.1<BR>no ip http=20
server<BR>!<BR>!<BR>line con 0<BR>line aux 0<BR>line vty 0 =
4<BR>&nbsp;password=20
scott<BR>&nbsp;login<BR>!<BR>end</DIV></BODY></HTML>

------=_NextPart_000_0038_01C264A3.900D6900--