[nsp] Interoperability between Juniper and Cisco on MPLS Martini

Sergey V. Artjushkin skiv at caravan.ru
Wed Dec 24 07:14:05 EST 2003


Hi

> I am trying to get a l2circuit working between a M40 and 7507.

I have tested AToM between M5 and 7509:

Juniper:
interfaces {
    fe-0/0/1 {
        vlan-tagging;
        unit 0 {
            vlan-id 616;
            family inet {
                address 10.100.100.2/24;
            }
            family mpls;
        }
    }
    fe-0/0/2 {
        vlan-tagging;
        mtu 1500;
        encapsulation vlan-ccc;
        }
        unit 1 {
            encapsulation vlan-ccc;
            vlan-id 625;
        }
routing-options {
    static {
        route 192.168.0.1/32 next-hop 10.100.100.1;
    }
    router-id 192.168.0.2;
}
protocols {
    mpls {
        interface fe-0/0/1.0;
    }
    ldp {
        transport-address loopback;
        interface fe-0/0/1.0;
        interface lo0.0;
    }
    l2circuit {
        traceoptions {
            file l2c.trace;
            flag all detail;
        }
        neighbor 192.168.0.1 {
            interface fe-0/0/2.1 {
                virtual-circuit-id 1;
            }
        }
    }
}

Cisco:
tag-switching tdp router-id Loopback0
!
interface Loopback0
 ip address 192.168.0.1 255.255.255.255
!
interface GigabitEthernet0/0/0.625
 encapsulation dot1Q 625
 no ip directed-broadcast
 no cdp enable
 mpls l2transport route 192.168.0.2 1 
!
interface GigabitEthernet0/0/0.846
 encapsulation dot1Q 846
 ip address 10.100.100.1 255.255.255.252
 no ip directed-broadcast
 mpls label protocol ldp
 tag-switching ip
!
ip route 192.168.0.2 255.255.255.255 10.100.100.2

Everything is working ok. As I remember, there was some troubles with
rewriting VLAN tag and MTU (must be the same on both ends).
Also I have tested HDLC over MPLS, and it is also working well.
 
> interface FastEthernet0/0/0.16
>  encapsulation dot1Q 16
>  mpls l2transport route 209.123.x.y 623
>
> and
>
>         unit 623 {
>             encapsulation vlan-ccc;
>             vlan-id 623;
> 
>     l2circuit {
>         neighbor 209.123.x.z {
>             interface ge-6/1/0.623 {
>                 virtual-circuit-id 623;
>                 control-word;

Try to use the same VLAN on 7507 and M40.

> 
> 
> results:
> 
> core2.xxx#sho mpls l2transport vc 623 detail
> Local interface: Fa0/0/0.16 up, line protocol up, Eth VLAN 16 up
>   Destination address: 209.123.x.y, VC ID: 623, VC status: down
>     Tunnel label: not ready, LFIB entry untagged
>     Output interface: unknown, imposed label stack {}
>   Create time: 01:23:09, last status change time: never
>   Signaling protocol: LDP, peer 209.123.x.y:0 up
>     MPLS VC labels: local 998, remote unassigned
>     Group ID: local 1, remote unknown
>     MTU: local 1500, remote unknown
>     Remote interface description:
>   Sequencing: receive disabled, send disabled
>   VC statistics:
>     packet totals: receive 0, send 0
>     byte totals:   receive 0, send 0
>     packet drops:  receive 0, send 0
> 
> 
> alex at gbr2.zzz> show l2circuit connections extensive
> Neighbor: 209.123.x.z
>     Interface                 Type  St     Time last up          # Up trans
>     ge-6/1/0.623 (vc 623)     rmt   VC-Dn  -----                          0
>       Local interface: ge-6/1/0.623, Status: Up, Encapsulation: VLAN
>       Remote PE: 209.123.x.z, Negotiated control-word: Yes (Null)
>       Incoming label: 108000, Outgoing label: 998
>         Time                  Event                   Interface/Lbl/PE
>         Dec 24 02:28:38 2003  PE route changed
>         Dec 24 02:28:38 2003  Out lbl Update                       998
>         Dec 24 02:28:38 2003  In lbl Update                     108000
>         Dec 24 02:28:38 2003  loc intf up                 ge-6/1/0.623
> 
> 
> 
> 12.3.5a on the cisco, 5.7R2.4 on the M40.
> 
> Any pointers, or any examples from people who have done this will be
> greatly appreciated.
> 
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
> 


-- 
With best regards.
------------------------------------------------------------------------------------------
Sergey Artjushkin


More information about the cisco-nsp mailing list