[nsp] rate-limiting

Christopher J. Wolff chris at bblabs.com
Wed Oct 8 18:31:24 EDT 2003


I read somewhere on CCO that basic 'CAR' was being deprecated in favor of
the class map policy method.  So, I thought I would do something new and
cool and try it out!  Thank you for the help!

-----Original Message-----
From: Andrew Fort [mailto:afort at choqolat.org] 
Sent: Wednesday, October 08, 2003 3:12 PM
To: Christopher J. Wolff
Cc: cisco-nsp at puck.nether.net
Subject: Re: [nsp] rate-limiting

Christopher J. Wolff said the following on 9/10/2003 7:35 AM:

> Hello,
> I'm rate-limiting a customers' internet connection and am seeing
throughput
> at about half (256k) the rate limit amount, which is 512K.  I do not see
> anything wrong with the rate limit statement is there something else I
could
> be missing?  I didn't wear my glasses today (haha) thank you all in
advance.
> 
> class-map match-any Customer_A_512K
>   match access-group 196
> 
> policy-map Customer_A_512K
>   class Customer_A_512K
>    police 512000 8000 8000 conform-action transmit  exceed-action drop

Hi Christopher,

I know that when using traditional CAR, your policer bucketsize values 
are incorrect.  I assume the policer is implemented similarly with the 
modular QoS on the same platforms.

Thus, I'd recommend,

police 512000 96000 192000 conform trans exceed drop

(First bucket size = rate in bps * 0.1875
Second bucket size = rate in bps * 0.375)

Note that the 'mls qos' 3550/6000 (aggregate) policers with a single 
bucket value seem to work correctly for any bps when the bucket size is 
~ 26000.

> 
> interface FastEthernet0/1.103
>  description Customer_A
>  encapsulation dot1Q 103
>  ip address 192.168.0.1 255.255.255.248
>  service-policy input Customer_A_512K
>  service-policy output Customer_A_512K
> 
> access-list 196 permit ip any any

-afort



More information about the cisco-nsp mailing list