[nsp] ethernet problems

Aaron Howell aaronh at amerion.net
Tue Feb 3 18:31:16 EST 2004

 Hi everybody, I'm back, this time with some ethernet wierdness. I
installed a 3640 last night to do some DSL aggregation, it's got a 4
port ATM T1 IMA card and a single fast ethernet port card in it, 128 MB
of RAM, and is running IOS 12.1(18). It worked fine for 12 hours or so,
and then dropped off the face of the planet. Here's where the wierdness
starts. I tried to access the router via console, and kept getting an
"Authentication Denied" message, even though there's no password set on
the conosle. It never actually prompted me for a password, just "Hit
Return to get started" <hit return key> "Authentication denied, Hit
Return to get started" over and over.

 I wound up putting it in rommon and getting in that way, and here's
some more wierdness: the fast ether interface was up/up, interface on
the switch it's plugged into also up/up, but I couldn't pass any
traffic. If I did a shut/no shut on the interface, it would come up for
a varying amount of time, a few seconds to a few minutes, and then stop
passing traffic again. I could see the traffic passing the switch, but
it never got to the fast ethernet on the router. I've changed cables,
twice, used the same cable it was using for another machine which worked
fine, so I'm ruling out the cable. One interesting thing was that when
the interface stopped passing traffic, the output queue would fill up,
and I'd start getting output drops. I tried increasing the output queue
size, but that had no effect. I moved everything back to the old router,
which is up and running fine, and assigned a new IP to the fast ether on
the 3640 to do some testing.

 With "debug fastethernet events" and "debug fastethernet packet" turned
on, I'm getting these:
02:05:56: FastEthernet0/0: PHY 0x0, read reg = 0x1, val = 0x784F
exactly 10 seconds apart. I have not been unable to ping the box since
giving it the new IP, although I do get some interesting results. I'm
running 1000 packets of 1024 bytes across the interface right now, and
every so often I get:
wrong data byte #533 should be 0x15 but was 0x95
wrong data byte #797 should be 0x1d but was 0x9d
wrong data byte #769 should be 0x1 but was 0x81
wrong data byte #525 should be 0xd but was 0x8d
wrong data byte #325 should be 0x45 but was 0xc5
wrong data byte #265 should be 0x9 but was 0x89

 Each of these "wrong data" messages is followed by what appear to be
several (32-33) lines of checksum errors or a hex dump, I'm not sure
which, as I've never seen anything like it before. They look like this:
#8      8 9 a b c d e f 10 11 12 13 14 15 16 17 18 19 1a 1b 1c 1d 1e 1f
20 21 22 23 24 25 26 27
#40     28 29 2a 2b 2c 2d 2e 2f 30 31 32 33 34 35 36 37 38 39 3a 3b 3c
3d 3e 3f 40 41 42 43 44 45 46 47
#72     48 49 4a 4b 4c 4d 4e 4f 50 51 52 53 54 55 56 57 58 59 5a 5b 5c
5d 5e 5f 60 61 62 63 64 65 66 67

 Some googling indicates that lots of people have seen this in
conjunction with linux boxen with a buggy ping, however I don't have
this problem with any other address I try to ping, so I think I can
safely rule out my system as the culprit. I apologize for the length of
this email but this one has me stumped (again). I can include config
samples if they will help, but didn't here, since this is already a

Aaron Howell
Network/System Administrator
Amerion, LLC

More information about the cisco-nsp mailing list