[c-nsp] Cisco 2511 Console server menu config

Per Ole Klemetsrud perole at kirurg.org
Mon Jul 26 18:00:44 EDT 2004


Since console ports seem to be all the rage these days (ref. nanog), here 
is a config I cooked up for our internal lab.  It's handy in a shared 
lab/teaching environment where you need easy access to console ports with 
a minimum of hassle.  I normally change the menu to describe what's 
connected to the port, and keep a couple of spares for initial 
configuration.

Regards,
Per Ole Klemetsrud


Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname console-server
!
enable secret ****
!
username cisco password 0 cisco
!
ip subnet-zero
no ip domain-lookup
ip host c1 2001 10.0.0.1
ip host c2 2002 10.0.0.1
ip host c3 2003 10.0.0.1
ip host c4 2004 10.0.0.1
ip host c5 2005 10.0.0.1
ip host c6 2006 10.0.0.1
ip host c7 2007 10.0.0.1
ip host c8 2008 10.0.0.1
ip host c9 2009 10.0.0.1
ip host c10 2010 10.0.0.1
ip host c11 2011 10.0.0.1
ip host c12 2012 10.0.0.1
ip host c13 2013 10.0.0.1
ip host c14 2014 10.0.0.1
ip host c15 2015 10.0.0.1
ip host c16 2016 10.0.0.1

!
process-max-time 200
!
interface Loopback66
  ip address 10.0.0.1 255.255.255.255
  no ip directed-broadcast
!
interface Ethernet0
  ip address 192.168.0.1 255.255.255.0
  no ip directed-broadcast
!
interface Serial0
  no ip address
  no ip directed-broadcast
  shutdown
!
!
ip classless
no ip http server
!
menu cserver title $If you have problems connecting to your device
   clear the connection via cl+# (ie:cl1) and try again.

   To exit back out to the menu press "CTRL+SHIFT+6"
   then "X".   You must then clear the connection and
   begin a new console session to re-connect to
   that device.
--------------------------------------------------------
   1    - Connect to console1
   2    - Connect to console2
   3    - Connect to console3
   4    - Connect to console4
   5    - Connect to console5
   6    - Connect to console6
   7    - Connect to console7
   8    - Connect to console8
--------------------------------------------------------
   p2   - console ports 9-16 | show - show lines in use
   Exit - logout             | menuexit - exit menu$
menu cserver prompt $Please enter command or selection:$
menu cserver command 1 tn c1
menu cserver command 2 tn c2
menu cserver command 3 tn c3
menu cserver command 4 tn c4
menu cserver command 5 tn c5
menu cserver command 6 tn c6
menu cserver command 7 tn c7
menu cserver command 8 tn c8
menu cserver command cl1 cl1
menu cserver command cl2 cl2
menu cserver command cl3 cl3
menu cserver command cl4 cl4
menu cserver command cl5 cl5
menu cserver command cl6 cl6
menu cserver command cl7 cl7
menu cserver command cl8 cl8
menu cserver command p2 menu cserver2
menu cserver command menuexit menu-exit
menu cserver command exit exit
menu cserver command show show line tty 1 16 | include \*
menu cserver options show pause
menu cserver clear-screen
menu cserver single-space
!
menu cserver2 title $If you have problems connecting to your device
   clear the connection via cl+# (ie:cl1) and try again.

   To exit back out to the menu press "CTRL+SHIFT+6"
   then "X".   You must then clear the connection and
   begin a new console session to re-connect to
   that device.
--------------------------------------------------------
   9     - Connect to console9
   10    - Conenct to console10
   11    - Connect to console11
   12    - Connect to console12
   13    - Connect to console13
   14    - Connect to console14
   15    - Connect to console15
   16    - Connect to console16
--------------------------------------------------------
   p1   - console ports 1-8  | show - show lines in use
   Exit - logout             |$
menu cserver2 command 9 tn c9
menu cserver2 command 10 tn c10
menu cserver2 command 11 tn c11
menu cserver2 command 12 tn c12
menu cserver2 command 13 tn c13
menu cserver2 command 14 tn c14
menu cserver2 command 15 tn c15
menu cserver2 command 16 tn c16
menu cserver2 command cl9 cl9
menu cserver2 command cl10 cl10
menu cserver2 command cl11 cl11
menu cserver2 command cl12 cl12
menu cserver2 command cl13 cl13
menu cserver2 command cl14 cl14
menu cserver2 command cl15 cl15
menu cserver2 command cl16 cl16
menu cserver2 command p1 menu-exit
menu cserver2 command exit exit
menu cserver2 command show show line tty 1 16 | include \*
menu cserver2 options show pause
menu cserver2 clear-screen
menu cserver2 single-space
alias exec cl1 clear line 1
alias exec cl2 clear line 2
alias exec cl3 clear line 3
alias exec cl4 clear line 4
alias exec cl5 clear line 5
alias exec cl6 clear line 6
alias exec cl7 clear line 7
alias exec cl8 clear line 8
alias exec cl9 clear line 9
alias exec cl10 clear line 10
alias exec cl11 clear line 11
alias exec cl12 clear line 12
alias exec cl13 clear line 13
alias exec cl14 clear line 14
alias exec cl15 clear line 15
alias exec cl16 clear line 16
alias exec tn telnet
privilege exec level 0 clear line
privilege exec level 1 clear
!
line con 0
  transport input none
line 1 16
  no exec
  exec-timeout 0 0
  transport input all
  telnet break-on-ip
  telnet sync-on-break
  telnet ip-on-break
  flowcontrol hardware
line aux 0

line vty 0 4
  exec-timeout 0 0
  no login
  autocommand menu cserver
!
end



More information about the cisco-nsp mailing list