[nsp] Mutual Redistribution Problem Multipoint EIGRP and OSPF
Dain Deutschman
daind at qwest.net
Sat Jun 5 11:06:55 EDT 2004
Hello group,
I'm having a redistribution problem between ospf and eigrp....description is below. Does anyone have any ideas? I'm stumped.
Thanks,
Dain
PROBLEM: Cannot ping 151.1.12.2 ( R2 ) from outside the multipoint network. Mutual route redistribution is occurring between EIGRP and OSPF at R3. The R2 network does not show up in the OSPF database or in the routing table.
r1#ping 151.1.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 151.1.12.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
**NETWORK DIAGRAM**
R4-------R3-------R2
|
R1
|
R6
Frame Relay Point-to-Multipoint network ( 151.1.12.0/28 )
R4 and R2 are spokes
R3 is the hub
R1 is on ethernet segment with R3 ( 150.2.12.0/24 )
R6 is on ethernet segment with R1 ( 150.3.12.0/24 )
OSPF Area 0 150.3.12.0/24 ( R6 and R1 )
OSPF Area 2 150.2.12.0/24 ( R1 and R3 )
OSPF Area 15 151.1.12.0/28 ( R3 and R4 )
Note: R2 does not take part in OSPF
EIGRP 200 ( R3, R4 and R2 )
**RUNNING CONFIGS and SHOW OUTPUT**
r1#r
Building configuration...
Current configuration : 1344 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r1
!
!
memory-size iomem 15
ip subnet-zero
!
!
ip tcp synwait-time 7
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 150.2.12.1 255.255.255.0
ip ospf network broadcast
duplex auto
speed auto
!
interface Serial0/0
no ip address
encapsulation frame-relay
shutdown
frame-relay lmi-type ansi
!
interface FastEthernet0/1
ip address 150.3.12.1 255.255.255.0
ip ospf network broadcast
duplex auto
speed auto
!
router ospf 100
router-id 1.1.1.1
log-adjacency-changes
area 2 virtual-link 3.3.3.3
network 150.2.12.0 0.0.0.255 area 2
network 150.3.12.0 0.0.0.255 area 0
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
alias exec r show run
alias exec c config t
alias exec s copy run start
alias exec i show ip route
alias exec si show ip int brief
alias exec on show ip ospf nei
alias exec sen show ip eigrp nei
alias exec b show ip bgp
alias exec bs show ip bgp summ
alias exec isa show crypto isakmp sa
alias exec ipsec show crypto ipsec sa
alias exec engine show crypto engine conn act
!
line con 0
logging synchronous
line aux 0
line vty 0 4
!
end
r1#
ts12>2
[Resuming connection 2 to r2 ... ]
00:
r2#r
Building configuration...
Current configuration : 1479 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r2
!
!
memory-size iomem 10
ip subnet-zero
!
!
ip tcp synwait-time 7
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Loopback1
ip address 12.12.12.12 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 151.1.12.2 255.255.255.240
encapsulation frame-relay
frame-relay map ip 151.1.12.3 123 broadcast
frame-relay map ip 151.1.12.4 124 broadcast
frame-relay lmi-type ansi
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
!
router eigrp 200
network 12.12.12.0 0.0.0.255
network 151.1.12.0 0.0.0.15
no auto-summary
eigrp router-id 2.2.2.2
!
ip classless
ip http server
!
!
!
voice-port 1/0/0
!
voice-port 1/0/1
!
dial-peer cor custom
!
!
!
!
alias exec r show run
alias exec c config t
alias exec s copy run start
alias exec i show ip route
alias exec si show ip int brief
alias exec on show ip ospf nei
alias exec sen show ip eigrp nei
alias exec b show ip bgp
alias exec bs show ip bgp summ
alias exec isa show crypto isakmp sa
alias exec ipsec show crypto ipsec sa
alias exec engine show crypto engine conn act
!
line con 0
logging synchronous
line aux 0
line vty 0 4
login
!
end
r2#
ts12>3
[Resuming connection 3 to r3 ... ]
r3#r
Building configuration...
Current configuration : 1773 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r3
!
!
ip subnet-zero
ip tcp synwait-time 7
no ip domain-lookup
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface Loopback1
ip address 13.13.13.13 255.255.255.0
!
interface Ethernet0
ip address 150.2.12.3 255.255.255.0
ip ospf network broadcast
media-type 10BaseT
!
interface Serial0
no ip address
encapsulation frame-relay
frame-relay lmi-type ansi
!
interface Serial0.1 multipoint
ip address 151.1.12.3 255.255.255.240
no ip split-horizon eigrp 200
ip ospf network point-to-multipoint
frame-relay map ip 151.1.12.2 132 broadcast
frame-relay map ip 151.1.12.4 134 broadcast
!
interface Serial1
no ip address
shutdown
!
interface Serial2
no ip address
shutdown
!
interface Serial3
no ip address
shutdown
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
router eigrp 200
redistribute ospf 100 metric 100000 30 254 20 1500
network 13.13.13.0 0.0.0.255
network 151.1.12.0 0.0.0.15
no auto-summary
eigrp router-id 3.3.3.3
!
router ospf 100
router-id 3.3.3.3
log-adjacency-changes
area 2 virtual-link 1.1.1.1
redistribute eigrp 200 subnets
network 150.2.12.0 0.0.0.255 area 2
network 151.1.12.0 0.0.0.15 area 15
!
ip classless
no ip http server
!
!
alias exec r show run
alias exec c config t
alias exec s copy run start
alias exec i show ip route
alias exec si show ip int brief
alias exec on show ip ospf nei
alias exec sen show ip eigrp nei
alias exec b show ip bgp
alias exec bs show ip bgp summ
alias exec isa show crypto isakmp sa
alias exec ipsec show crypto ipsec sa
alias exec engine show crypto engine conn act
!
line con 0
logging synchronous
line aux 0
line vty 0 4
!
end
r3#
ts12>4
[Resuming connection 4 to r4 ... ]
r4#r
Building configuration...
Current configuration : 1632 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r4
!
!
memory-size iomem 10
ip subnet-zero
!
!
ip tcp synwait-time 7
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface Loopback1
ip address 14.14.14.14 255.255.255.0
!
interface Ethernet0/0
no ip address
shutdown
half-duplex
!
interface BRI0/0
no ip address
encapsulation hdlc
shutdown
!
interface Serial1/0
ip address 151.1.12.4 255.255.255.240
encapsulation frame-relay
ip ospf network point-to-multipoint
frame-relay map ip 151.1.12.2 142 broadcast
frame-relay map ip 151.1.12.3 143 broadcast
frame-relay lmi-type ansi
!
interface Serial1/1
no ip address
shutdown
!
interface Serial1/2
no ip address
shutdown
!
interface Serial1/3
no ip address
shutdown
!
router eigrp 200
network 14.14.14.0 0.0.0.255
network 151.1.12.0 0.0.0.15
no auto-summary
eigrp router-id 4.4.4.4
!
router ospf 100
router-id 4.4.4.4
log-adjacency-changes
network 151.1.12.0 0.0.0.15 area 15
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
alias exec r show run
alias exec c config t
alias exec s copy run start
alias exec i show ip route
alias exec si show ip int brief
alias exec on show ip ospf nei
alias exec sen show ip eigrp nei
alias exec b show ip bgp
alias exec bs show ip bgp summ
alias exec isa show crypto isakmp sa
alias exec ipsec show crypto ipsec sa
alias exec engine show crypto engine conn act
!
line con 0
logging synchronous
line aux 0
line vty 0 4
!
end
r4#
ts12>6
[Resuming connection 6 to r6 ... ]
r6#r
Building configuration...
Current configuration : 1192 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname r6
!
!
memory-size iomem 10
ip subnet-zero
!
!
ip tcp synwait-time 7
no ip domain-lookup
!
ip audit notify log
ip audit po max-events 100
!
call rsvp-sync
!
!
!
!
!
!
!
!
interface Loopback0
ip address 6.6.6.6 255.255.255.0
!
interface Ethernet0/0
ip address 150.3.12.6 255.255.255.0
ip ospf network broadcast
half-duplex
!
interface Serial0/0
no ip address
encapsulation frame-relay
shutdown
frame-relay lmi-type ansi
!
interface Serial0/1
no ip address
shutdown
!
router ospf 100
router-id 6.6.6.6
log-adjacency-changes
network 150.3.12.0 0.0.0.255 area 0
!
ip classless
ip http server
!
!
!
dial-peer cor custom
!
!
!
!
alias exec r show run
alias exec c config t
alias exec s copy run start
alias exec i show ip route
alias exec si show ip int brief
alias exec on show ip ospf nei
alias exec sen show ip eigrp nei
alias exec b show ip bgp
alias exec bs show ip bgp summ
alias exec isa show crypto isakmp sa
alias exec ipsec show crypto ipsec sa
alias exec engine show crypto engine conn act
!
line con 0
logging synchronous
line aux 0
line vty 0 4
!
end
r6#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
6.0.0.0/24 is subnetted, 1 subnets
C 6.6.6.0 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
O E2 12.12.12.0 [110/20] via 150.3.12.1, 00:02:27, Ethernet0/0
13.0.0.0/24 is subnetted, 1 subnets
O E2 13.13.13.0 [110/20] via 150.3.12.1, 00:02:27, Ethernet0/0
151.1.0.0/32 is subnetted, 2 subnets
O IA 151.1.12.3 [110/11] via 150.3.12.1, 00:02:27, Ethernet0/0
O IA 151.1.12.4 [110/75] via 150.3.12.1, 00:02:27, Ethernet0/0
14.0.0.0/24 is subnetted, 1 subnets
O E2 14.14.14.0 [110/20] via 150.3.12.1, 00:02:29, Ethernet0/0
150.2.0.0/24 is subnetted, 1 subnets
O IA 150.2.12.0 [110/11] via 150.3.12.1, 00:02:29, Ethernet0/0
150.3.0.0/24 is subnetted, 1 subnets
C 150.3.12.0 is directly connected, Ethernet0/0
r6#ping 151.1.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 151.1.12.2, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)
r6#
ts12>1
[Resuming connection 1 to r1 ... ]
r1#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
1.0.0.0/24 is subnetted, 1 subnets
C 1.1.1.0 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
O E2 12.12.12.0 [110/20] via 150.2.12.3, 00:03:00, FastEthernet0/0
13.0.0.0/24 is subnetted, 1 subnets
O E2 13.13.13.0 [110/20] via 150.2.12.3, 00:03:00, FastEthernet0/0
151.1.0.0/32 is subnetted, 2 subnets
O IA 151.1.12.3 [110/1] via 150.2.12.3, 00:03:00, FastEthernet0/0
O IA 151.1.12.4 [110/65] via 150.2.12.3, 00:03:00, FastEthernet0/0
14.0.0.0/24 is subnetted, 1 subnets
O E2 14.14.14.0 [110/20] via 150.2.12.3, 00:03:01, FastEthernet0/0
150.2.0.0/24 is subnetted, 1 subnets
C 150.2.12.0 is directly connected, FastEthernet0/0
150.3.0.0/24 is subnetted, 1 subnets
C 150.3.12.0 is directly connected, FastEthernet0/1
r1#
ts12>3
[Resuming connection 3 to r3 ... ]
r3#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
3.0.0.0/24 is subnetted, 1 subnets
C 3.3.3.0 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
D 12.12.12.0 [90/2297856] via 151.1.12.2, 00:04:03, Serial0.1
13.0.0.0/24 is subnetted, 1 subnets
C 13.13.13.0 is directly connected, Loopback1
151.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 151.1.12.0/28 is directly connected, Serial0.1
O 151.1.12.4/32 [110/64] via 151.1.12.4, 00:03:17, Serial0.1
14.0.0.0/24 is subnetted, 1 subnets
D 14.14.14.0 [90/2297856] via 151.1.12.4, 00:05:00, Serial0.1
150.2.0.0/24 is subnetted, 1 subnets
C 150.2.12.0 is directly connected, Ethernet0
150.3.0.0/24 is subnetted, 1 subnets
O 150.3.12.0 [110/11] via 150.2.12.1, 00:03:18, Ethernet0
r3#
ts12>4
[Resuming connection 4 to r4 ... ]
r4#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
4.0.0.0/24 is subnetted, 1 subnets
C 4.4.4.0 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
D 12.12.12.0 [90/20640000] via 151.1.12.2, 00:03:37, Serial1/0
13.0.0.0/24 is subnetted, 1 subnets
D 13.13.13.0 [90/20640000] via 151.1.12.3, 00:04:59, Serial1/0
151.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
O 151.1.12.3/32 [110/781] via 151.1.12.3, 00:03:22, Serial1/0
C 151.1.12.0/28 is directly connected, Serial1/0
14.0.0.0/24 is subnetted, 1 subnets
C 14.14.14.0 is directly connected, Loopback1
150.2.0.0/24 is subnetted, 1 subnets
O IA 150.2.12.0 [110/791] via 151.1.12.3, 00:03:23, Serial1/0
150.3.0.0/24 is subnetted, 1 subnets
O IA 150.3.12.0 [110/792] via 151.1.12.3, 00:03:24, Serial1/0
r4#
ts12>2
[Resuming connection 2 to r2 ... ]
r2#i
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route
Gateway of last resort is not set
2.0.0.0/24 is subnetted, 1 subnets
C 2.2.2.0 is directly connected, Loopback0
12.0.0.0/24 is subnetted, 1 subnets
C 12.12.12.0 is directly connected, Loopback1
13.0.0.0/24 is subnetted, 1 subnets
D 13.13.13.0 [90/2297856] via 151.1.12.3, 00:04:13, Serial0/0
151.1.0.0/16 is variably subnetted, 2 subnets, 2 masks
C 151.1.12.0/28 is directly connected, Serial0/0
D EX 151.1.12.4/32 [170/2177536] via 151.1.12.3, 00:03:13, Serial0/0
14.0.0.0/24 is subnetted, 1 subnets
D 14.14.14.0 [90/2297856] via 151.1.12.4, 00:03:39, Serial0/0
150.2.0.0/24 is subnetted, 1 subnets
D EX 150.2.12.0 [170/2177536] via 151.1.12.3, 00:03:14, Serial0/0
150.3.0.0/24 is subnetted, 1 subnets
D EX 150.3.12.0 [170/2177536] via 151.1.12.3, 00:03:14, Serial0/0
r2#
ts12>3
[Resuming connection 3 to r3 ... ]
r3#ping 151.1.12.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 151.1.12.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/67/96 ms
r3#sh ip ospf data
OSPF Router with ID (3.3.3.3) (Process ID 100)
Router Link States (Area 0)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 5 (DNA) 0x80000004 0x00D040 2
3.3.3.3 3.3.3.3 234 0x80000004 0x00441A 1
6.6.6.6 6.6.6.6 295 (DNA) 0x80000002 0x002F72 1
Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
150.3.12.6 6.6.6.6 296 (DNA) 0x80000001 0x005FFA
Summary Net Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
150.2.12.0 1.1.1.1 11 (DNA) 0x80000003 0x002F62
150.2.12.0 3.3.3.3 600 0x80000001 0x005131
151.1.12.3 3.3.3.3 600 0x80000001 0x00CDBB
151.1.12.4 3.3.3.3 600 0x80000001 0x004602
Summary ASB Link States (Area 0)
Link ID ADV Router Age Seq# Checksum
3.3.3.3 1.1.1.1 1 (DNA) 0x80000001 0x00DC4E
Router Link States (Area 2)
Link ID ADV Router Age Seq# Checksum Link count
1.1.1.1 1.1.1.1 615 0x80000002 0x00805D 1
3.3.3.3 3.3.3.3 238 0x80000005 0x00A617 1
Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
150.2.12.1 1.1.1.1 615 0x80000001 0x00ED92
Summary Net Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
150.3.12.0 1.1.1.1 879 0x80000003 0x00236D
150.3.12.0 3.3.3.3 584 0x80000001 0x004F31
151.1.12.3 1.1.1.1 580 0x80000001 0x00147C
151.1.12.3 3.3.3.3 604 0x80000001 0x00CDBB
151.1.12.4 1.1.1.1 580 0x80000001 0x008CC2
151.1.12.4 3.3.3.3 606 0x80000001 0x004602
Summary ASB Link States (Area 2)
Link ID ADV Router Age Seq# Checksum
3.3.3.3 1.1.1.1 236 0x80000001 0x00DC4E
Router Link States (Area 15)
Link ID ADV Router Age Seq# Checksum Link count
3.3.3.3 3.3.3.3 240 0x80000005 0x004D19 2
4.4.4.4 4.4.4.4 796 0x80000003 0x0097FD 2
Summary Net Link States (Area 15)
Link ID ADV Router Age Seq# Checksum
150.2.12.0 3.3.3.3 606 0x80000001 0x005131
150.3.12.0 3.3.3.3 586 0x80000001 0x004F31
Type-5 AS External Link States
Link ID ADV Router Age Seq# Checksum Tag
12.12.12.0 3.3.3.3 239 0x80000001 0x00DB94 0
13.13.13.0 3.3.3.3 242 0x80000001 0x00B7B5 0
14.14.14.0 3.3.3.3 242 0x80000001 0x0093D6 0
r3#sh ip eigrp topo
IP-EIGRP Topology Table for AS(200)/ID(3.3.3.3)
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - reply Status, s - sia Status
P 12.12.12.0/24, 1 successors, FD is 2297856
via 151.1.12.2 (2297856/128256), Serial0.1
P 13.13.13.0/24, 1 successors, FD is 128256
via Connected, Loopback1
P 14.14.14.0/24, 1 successors, FD is 2297856
via 151.1.12.4 (2297856/128256), Serial0.1
P 150.2.12.0/24, 1 successors, FD is 33280
via Redistributed (33280/0)
P 150.3.12.0/24, 1 successors, FD is 33280
via Redistributed (33280/0)
P 151.1.12.0/28, 1 successors, FD is 2169856
via Connected, Serial0.1
P 151.1.12.4/32, 1 successors, FD is 33280
via Redistributed (33280/0)
r3#
More information about the cisco-nsp
mailing list