[nsp] Bonding multiple ADSL Lines

Paul Stewart pauls at nexicom.net
Wed May 19 13:58:46 EDT 2004


Unfortunately there might be a bit of trial and error.. Havne't done it
exactly the way you're looking for but here's some of the config from a 4
channel ISDN connection we have at a customer site.. This is a bonded
connection coming from a 2621 router that has two ISDN WIC modules in it...

interface FastEthernet0/0
 ip address 10.253.111.250 255.255.255.0
 no ip redirects
 no ip unreachables
 no ip proxy-arp
 ip accounting access-violations
 ip nat inside
 speed 10
 full-duplex
 no cdp enable
!
interface BRI0/0
 no ip address
 ip nat outside
 encapsulation ppp
 timeout absolute 30000 0
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 xxxxxxxxxxxx xxxxxxxx
 isdn spid2 xxxxxxxxxxxx xxxxxxxx
 ppp authentication pap callin
 ppp pap sent-username xxxxxxxx password 7 xxxxxxxxxxxxxx
 ppp multilink
!
interface BRI0/1
 no ip address
 ip nat outside
 encapsulation ppp
 timeout absolute 30000 0
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 xxxxxxxxxxxx xxxxxxxx
 isdn spid2 xxxxxxxxxxxx xxxxxxxx
 ppp authentication pap callin
 ppp pap sent-username xxxxxxxx password 7 xxxxxxxxxxxxxxxxxx
 ppp multilink
!
interface Dialer2
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer string 123123123
 dialer load-threshold 1 either
 dialer-group 1
 no cdp enable
 ppp authentication pap callin
 ppp multilink
!
ip nat inside source list 1 interface Dialer2 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer2

access-list 1 permit 10.253.111.0 0.0.0.255
dialer-list 1 protocol ip permit


Hope this helps..:)

Paul


-----Original Message-----
From: cisco-nsp-bounces at puck.nether.net
[mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of Maik Bachmann
Sent: Wednesday, May 19, 2004 1:32 PM
To: cisco-nsp at puck.nether.net
Subject: Re: [nsp] Bonding multiple ADSL Lines


On Wed, May 19, 2004 at 01:22:57PM -0400, Paul Stewart wrote:

Hi,

also would like to know about, but more from a config point of view:
  - using vpdn
  - virtual-template to bond ?
I would like to use PPPoE for 2 ADSL lines.

TIA
---Maik

> Are these ADSL lines using PPPOE?  If so, then you have to bind dialer 
> interfaces with mlppp as you mentioned.... Have done 4 ISDN channels 
> this way before and it worked but not sure about limitations...
> 
> We have been looking at bonding two ADSL lines for a while for a 
> remote POP site (dial-up shelves) but haven't actually implemented it.  
> The nice thing was that the ADSL was non-PPPOE (ethernet extensions 
> basically) so using CEF we proved it out that we could just load 
> balance in CEF that same as we do with T1's currently where needed...
> 
> I have a feeling that using dialer interfaces would get messy... Might 
> be doable though...  And I also heard the CEF can only balance 6 or 
> maybe it was actually 8 connections at once.. There is a limit, just 
> not sure 100% what it is...
> 
> Paul
> 
> -----Original Message-----
> From: cisco-nsp-bounces at puck.nether.net 
> [mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of Martin 
> Robinson
> Sent: Wednesday, May 19, 2004 1:04 PM
> Cc: cisco-nsp at puck.nether.net
> Subject: RE: [nsp] Bonding multiple ADSL Lines
> 
> 
> Hello All,
> 
> Trying to put together a couple of working solutions, is is possible 
> to bond 4, 6 and 8 adsl lines together using the 3640's or 26XX range 
> or 37XX routers.
> 
> Has any-one any experience with this, and if so do you have a 
> recomened vesion of IOS and memory.
> 
> I'm guessing that physically the 3640 will do this using a combo of 
> wic-1adsl's and nm-2w and using MLPP to bond them.
> 
> I would love to hear your experiences.
> 
> Martin.
> 
> Network Hardware Resale Europe
> Singaporestraat 66
> 1175 RA Lijnden (Amsterdam)
> The Netherlands
> T:   +31 (0) 20-4496927
> F:   +31 (0) 20-4496923
> E:  martin at networkhardware.com
> I:    www.networkhardware.com
> AOL:  martinNHR
> 
> 
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net 
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
> 
> 
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net 
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/

-- 
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
_/ Maik Bachmann ---------------- secnetix GmbH & Co KG
_/ Oettingenstr. 2 -------------- D-80538 Muenchen
_/ Tel(priv.): +49-8093-2962 ---- Mobil: +49-172-8305649
_/ Email: bachmann at secnetix.de -- IRC: IronMaik 
_/ PGP KeyID: F7A67E11 ---------- PGP Fingerprint:
_/ CA 3B AA EB 7F 6F 7D 7A  54 D4 AA 01 82 8E 32 9C
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
_______________________________________________
cisco-nsp mailing list  cisco-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/



More information about the cisco-nsp mailing list