[c-nsp] DSL termination on 7206VXR

Chris Stone cstone at axint.net
Mon Oct 4 16:47:58 EDT 2004


Here's a snippet of how we're doing it - ATM DS3, authentication via RADIUS,
IP from router pool unless defined by RADIUS, all PPPoA:

aaa new-model
<---snip--->
aaa authentication ppp default none
aaa authentication ppp DSLPPP group radius local
aaa authorization network DSLPPP group radius if-authenticated 
aaa accounting network DSLPPP wait-start group radius
<---snip--->
ip dhcp pool Megabit
   host xxx.xxx.136.1 255.255.255.0
   dns-server xxx.xxx.133.2 xxx.xxx.133.3 
   default-router xxx.xxx.136.1 
   lease 0 0 10
<---snip--->
interface Loopback0
 ip address xxx.xxx.136.1 255.255.255.0
<---snip--->
interface ATM2/0
 no ip address
 ip route-cache flow
 no ip mroute-cache
 atm scrambling cell-payload
 atm framing cbitplcp
 no atm ilmi-keepalive
!
interface ATM2/0.16 multipoint
 description Denver DSL
 bandwidth 3000
 ip broadcast-address xxx.xxx.136.255
 ip helper-address xxx.xxx.136.1
<---snip--->
 pvc 1/33 
  abr 256 256
  encapsulation aal5mux ppp Virtual-Template5
 !
 pvc 1/36 
  abr 256 256
  encapsulation aal5mux ppp Virtual-Template5
 !
 pvc 1/43 
  abr 1536 1024
  encapsulation aal5ciscoppp Virtual-Template5
 !
 pvc 1/44 
  abr 1536 1024
  encapsulation aal5mux ppp Virtual-Template5
 !
 pvc 1/45 
  abr 1536 1024
  encapsulation aal5mux ppp Virtual-Template5
 !
 pvc 1/46 
  abr 256 256
  encapsulation aal5mux ppp Virtual-Template5
 !
 pvc 1/47 
  abr 256 256
  encapsulation aal5mux ppp Virtual-Template5
<---snip--->
interface Virtual-Template5
 ip unnumbered Loopback0
 ip access-group privatenet in
 ip helper-address xxx.xxx.136.1
 autodetect encapsulation ppp
 peer default ip address pool Megabit
 ppp authentication pap ms-chap DSLPPP
 ppp authorization DSLPPP
 ppp accounting DSLPPP
!
<---snip--->
ip local pool Megabit xxx.xxx.136.2 xxx.xxx.136.200 cache-size 25
<---snip--->
ip access-list extended privatenet
 deny   ip 10.0.0.0 0.255.255.255 any
 deny   ip 172.16.0.0 0.15.255.255 any
 deny   ip 192.168.0.0 0.0.255.255 any
 permit ip any any
<---snip--->
ip radius source-interface FastEthernet0/0
<---snip--->
radius-server host xxx.xxx.xxx.xxx auth-port 1645 acct-port 1646 key 7
07373B5E17194950
radius-server timeout 30




-----Original Message-----
From: cisco-nsp-bounces at puck.nether.net
[mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of Roger Weeks
Sent: Monday, October 04, 2004 11:13 AM
To: cisco-nsp at puck.nether.net
Subject: [c-nsp] DSL termination on 7206VXR

Would anyone on the list who's currently using Cisco gear to terminate 
DSL connections be willing to share their config with me?  I'm looking 
for both RBE static IP setups and PPPoE/PPPoA setups.  Would like to 
know how other folks are doing this.

Thanks

--
Roger J. Weeks
Systems & Network Administrator
Mendocino Community Network

_______________________________________________
cisco-nsp mailing list  cisco-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/



More information about the cisco-nsp mailing list