[c-nsp] AS5300 config
Brian Feeny
signal at shreve.net
Sat Sep 25 15:32:01 EDT 2004
I am seeing some trouble out of an AS5300 and was wondering if someone
who configures them often, can see anything I have done that isn't
kosher in this config. This is for an ISP, and it just needs to be set
so customers can connect, get an IP, and move on. There is no special
situations on this AS5300.
They see a larger amount of user complaints in connecting to this box
then some of their other Remote Access Servers (non-Cisco), and I would
just like to find out from those on here, if perhaps I am running some
poor code (recommendations?), or have put something in the config that
I maybe should not have. I do not configure AS5300's much, as we don't
use them for dial where I work. The config looked good to me, but
their maybe something in there that someone more experienced in
AS5300's can see.
Alternately, if someone could email me their "cookie cutter" AS300 for
ISP config, I would check it against mine.
Thank you, and I appreciate any help you can give.
Brian
Building configuration...
Current configuration : 5580 bytes
!
version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
!
hostname sp-as5300
!
boot system flash:c5300-is-mz.122-24a.bin
aaa new-model
aaa authentication login console none
aaa authentication login vty line enable
aaa authentication login radius local
aaa authentication ppp default local group radius
aaa authorization exec default none
aaa authorization network default group radius
aaa accounting update newinfo
aaa accounting network default start-stop group radius
!
spe 1/0 2/9
firmware location flash:mica-modem-pw.2.9.5.0.bin
!
!
resource-pool disable
!
call rsvp-sync
ip subnet-zero
ip domain-name connectnc.net
ip name-server 65.162.17.2
ip name-server 65.162.17.12
!
async-bootp dns-server 65.162.17.2 65.162.17.12
isdn switch-type primary-5ess
!
!
!
!
!
fax interface-type modem
mta receive maximum-recipients 0
!
controller T1 0
framing esf
clock source line primary
linecode b8zs
pri-group timeslots 1-24
!
controller T1 1
framing esf
clock source line secondary 1
linecode b8zs
pri-group timeslots 1-24
!
controller T1 2
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 3
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 4
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 5
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 6
framing esf
linecode b8zs
pri-group timeslots 1-24
!
controller T1 7
framing esf
linecode b8zs
pri-group timeslots 1-24
!
!
!
interface Ethernet0
no ip address
shutdown
!
interface Virtual-Template1
ip unnumbered FastEthernet0
peer default ip address pool pool0
ppp authentication pap chap ms-chap callin
ppp multilink
no ppp multilink fragmentation
!
interface Serial0
no ip address
no fair-queue
clockrate 2015232
!
interface Serial1
no ip address
no fair-queue
clockrate 2015232
!
interface Serial2
no ip address
no fair-queue
clockrate 2015232
!
interface Serial3
no ip address
no fair-queue
clockrate 2015232
!
interface Serial0:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
autodetect encapsulation ppp v120
isdn switch-type primary-5ess
isdn incoming-voice modem
no cdp enable
!
interface Serial1:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
autodetect encapsulation ppp v120
isdn switch-type primary-5ess
isdn incoming-voice modem
no cdp enable
!
interface Serial2:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
autodetect encapsulation ppp v120
isdn switch-type primary-5ess
isdn incoming-voice modem
no cdp enable
!
interface Serial3:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
autodetect encapsulation ppp v120
isdn switch-type primary-5ess
isdn incoming-voice modem
no cdp enable
!
interface Serial4:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
autodetect encapsulation ppp v120
isdn switch-type primary-5ess
isdn incoming-voice modem
no cdp enable
!
interface Serial5:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
autodetect encapsulation ppp v120
isdn switch-type primary-5ess
isdn incoming-voice modem
no cdp enable
!
interface Serial6:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
autodetect encapsulation ppp v120
isdn switch-type primary-5ess
isdn incoming-voice modem
no cdp enable
!
interface Serial7:23
no ip address
encapsulation ppp
dialer rotary-group 1
dialer-group 1
autodetect encapsulation ppp v120
isdn switch-type primary-5ess
isdn incoming-voice modem
no cdp enable
!
interface FastEthernet0
ip address 65.162.17.69 255.255.255.224
no ip mroute-cache
duplex auto
speed auto
no cdp enable
!
interface Group-Async1
ip unnumbered FastEthernet0
encapsulation ppp
no ip mroute-cache
async dynamic address
async mode interactive
peer default ip address pool pool0 pool1
ppp authentication pap chap ms-chap callin
ppp multilink
group-range 1 96
!
interface Dialer1
ip unnumbered FastEthernet0
encapsulation ppp
dialer in-band
dialer idle-timeout 3600
dialer-group 1
peer default ip address pool pool0 pool1
no cdp enable
ppp authentication pap chap ms-chap callin
ppp multilink
!
router ospf 10
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
network 65.162.17.0 0.0.0.255 area 0
!
ip local pool pool0 204.213.204.129 204.213.204.254
ip local pool pool1 65.169.172.129 65.169.172.254
ip classless
ip route 0.0.0.0 0.0.0.0 65.162.17.65
no ip http server
!
logging facility syslog
logging 65.162.17.12
dialer-list 1 protocol ip permit
!
radius-server host 65.162.17.6 auth-port 1645 acct-port 1646
radius-server key xxxxxxxx
!
line con 0
password xxxxxxxxx
logging synchronous
line 1 96
no flush-at-activation
modem Dialin
autoselect during-login
autoselect ppp
line 97 240
no flush-at-activation
line aux 0
password xxxxxxxxxx
line vty 0 4
password xxxxxxxxx
!
scheduler interval 1000
end
---------------------------------------------
Brian Feeny, CCIE #8036, CISSP
Network Engineer
ShreveNet Inc.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PGP.sig
Type: application/pgp-signature
Size: 186 bytes
Desc: This is a digitally signed message part
Url : https://puck.nether.net/pipermail/cisco-nsp/attachments/20040925/17751d0e/PGP.bin
More information about the cisco-nsp
mailing list