[c-nsp] Rate-limit on 3550 port with routing mode

Marco Matarazzo marmata at libero.it
Mon Jul 4 04:36:41 EDT 2005


Hi Prit,

> Is there anyway to control ingresss/outgress xfic on 3550 port
> configured in routing mode.

This is what I use, it works!

class-map match-any all-out
  match ip dscp 0
class-map match-any all-in
  match access-group 100

policy-map 1mbit-in
  class all-in
    police 1024000 192000 exceed-action drop

policy-map 1mbit-out
  class all-out
    police 1024000 192000 exceed-action drop

access-list 100 permit ip any any

interface FastEthernet0/1
 no switchport
 ip address 1.2.3.4 255.255.255.240
 service-policy input 1mbit-in
 service-policy output 1mbit-out

The key factor here is to remember that you'll need separate policy maps for
inbound and outbound traffic (as you cannot apply a class map matching an ip
acl on egress, you'll have to match something else. dscp seems to work
fine). Also, testing it will be difficult, since snmp stats for the port
display prepolicing data, and the mib that should be used to have port based
qos stats is not working (yet!).

Cheers,
]\/[arco



More information about the cisco-nsp mailing list