[c-nsp] BGP multihoming with redundancy config problem

Ganbold ganbold at micom.mng.net
Mon Oct 24 05:59:32 EDT 2005


Hi all,

Basically I'm trying to make BGP multihoming work with 2 different
ISPs and plus redundancy.
Followiing is the scheme:

upstream1				upstream2
     \					    /
      \					   /
upstream1 border router	upstream2 border router
        \					/
         \				          /
      CORE ROUTER1 <-----------> CORE ROUTER2
	/				\
          /				 \
Part of OUR network	  	Part of OUR network


Following are the bgp config parts:

UPSTREAM1 border router config:
###################################
router ospf 117
  log-adjacency-changes
  passive-interface Hssi3/0
  passive-interface Loopback0
  network x.x.15.0 0.0.0.3 area 0
  network x.x.0.0 0.0.0.255 area 0
  network x.x.3.0 0.0.0.255 area 0
  network x.x.5.0 0.0.0.255 area 0
  network x.x.9.0 0.0.0.255 area 0
  network x.x.10.0 0.0.0.255 area 0
!
router bgp xxxx
  no synchronization
  bgp log-neighbor-changes
  network x.x.0.0 mask 255.255.224.0
  neighbor ibgp-peers peer-group
  neighbor ibgp-peers remote-as xxxx
  neighbor ibgp-peers description iBGP peering for internall
  neighbor ibgp-peers update-source Loopback0
  neighbor ibgp-peers send-community
  neighbor x.x.5.1 peer-group ibgp-peers
  neighbor x.x.5.2 peer-group ibgp-peers
  neighbor x.x.5.3 peer-group ibgp-peers
  neighbor x.x.5.25 peer-group ibgp-peers
  neighbor x.x.15.1 remote-as zzzzz
  neighbor x.x.15.1 description UPSTREAM1 INTERNET GW
  neighbor x.x.15.1 password 7 xxxxxxxxxxxxxxx
  neighbor x.x.15.1 version 4
  neighbor x.x.15.1 timers 120 360
  neighbor x.x.15.1 soft-reconfiguration inbound
  distance bgp 200 200 200
  no auto-summary
!
ip classless
ip route x.x.0.0 255.255.224.0 Null0
ip as-path access-list 100 permit ^$
ip as-path access-list 100 deny .*
!
!
ip prefix-list default seq 5 permit 0.0.0.0/0
!
ip prefix-list myblock seq 5 permit x.x.0.0/19
!
ip prefix-list subblocks seq 10 permit x.x.1.0/24
ip prefix-list subblocks seq 15 permit x.x.2.0/24
ip prefix-list subblocks seq 20 permit x.x.5.0/24
ip prefix-list subblocks seq 30 permit x.x.8.0/24
ip prefix-list subblocks seq 35 permit x.x.10.0/24
ip prefix-list subblocks seq 40 permit x.x.16.0/24
ip prefix-list subblocks seq 45 permit x.x.17.0/24
ip prefix-list subblocks seq 50 permit x.x.18.0/24
ip prefix-list subblocks seq 55 permit x.x.19.0/24
ip prefix-list subblocks seq 60 permit x.x.21.0/24
ip prefix-list subblocks seq 65 permit x.x.24.0/24
ip prefix-list subblocks seq 70 permit x.x.25.0/24
ip prefix-list subblocks seq 75 permit x.x.28.0/24
ip prefix-list subblocks seq 80 permit x.x.30.0/24

route-map infilter permit 10
  set local-preference 80
!
route-map outfilter permit 10
  match ip address prefix-list subblocks
  set as-path prepend xxxx xxxx xxxx
#########################################


UPSTREAM2 border router config:
###################################
router ospf 117
  log-adjacency-changes
  passive-interface Multilink1
  passive-interface Loopback0
  network x.x.0.0 0.0.0.255 area 0
  network x.x.3.0 0.0.0.255 area 0
  network x.x.5.0 0.0.0.255 area 0
  network x.x.9.0 0.0.0.255 area 0
  network x.x.10.0 0.0.0.255 area 0
  network x.y.39.132 0.0.0.3 area 0
!
router bgp xxxx
  no synchronization
  bgp log-neighbor-changes
  network x.x.1.0
  network x.x.2.0
  network x.x.5.0
  network x.x.8.0
  network x.x.10.0
  network x.x.16.0
  network x.x.17.0
  network x.x.18.0
  network x.x.19.0
  network x.x.21.0
  network x.x.24.0
  network x.x.25.0
  network x.x.28.0
  network x.x.30.0
  network x.x.0.0 mask 255.255.224.0
  neighbor ibgp-peers peer-group
  neighbor ibgp-peers remote-as xxxx
  neighbor ibgp-peers description iBGP peering for internall
  neighbor ibgp-peers update-source Loopback0
  neighbor ibgp-peers send-community
  neighbor x.x.5.1 peer-group ibgp-peers
  neighbor x.x.5.2 peer-group ibgp-peers
  neighbor x.x.5.3 peer-group ibgp-peers
  neighbor x.x.5.4 peer-group ibgp-peers
  neighbor x.y.39.133 remote-as 9800
  neighbor x.y.39.133 description UPSTREAM2 BGP Peering
  neighbor x.y.39.133 version 4
  neighbor x.y.39.133 soft-reconfiguration inbound
  neighbor x.y.39.133 prefix-list default in
  neighbor x.y.39.133 prefix-list subblocks out
  neighbor x.y.39.133 route-map outfilter out
  distance bgp 200 200 200
  no auto-summary
!
ip classless
ip route x.x.0.0 255.255.224.0 Null0
ip route x.x.1.0 255.255.255.0 Null0
ip route x.x.2.0 255.255.255.0 Null0
ip route x.x.5.0 255.255.255.0 Null0
ip route x.x.8.0 255.255.255.0 Null0
ip route x.x.10.0 255.255.255.0 Null0
ip route x.x.16.0 255.255.255.0 Null0
ip route x.x.17.0 255.255.255.0 Null0
ip route x.x.18.0 255.255.255.0 Null0
ip route x.x.19.0 255.255.255.0 Null0
ip route x.x.21.0 255.255.255.0 Null0
ip route x.x.24.0 255.255.255.0 Null0
ip route x.x.25.0 255.255.255.0 Null0
ip route x.x.28.0 255.255.255.0 Null0
ip route x.x.30.0 255.255.255.0 Null0
no ip http server
ip as-path access-list 100 permit ^$
ip as-path access-list 100 deny .*
!
!
ip prefix-list aggregate seq 5 permit x.x.0.0/19
!
ip prefix-list default seq 5 permit 0.0.0.0/0
!
ip prefix-list subblocks seq 1 permit x.x.0.0/19 le 24

route-map infilter permit 10
  match ip address prefix-list default
  set local-preference 80
!
route-map infilter permit 20
!
route-map outfilter permit 10
  match ip address prefix-list aggregate
  set as-path prepend xxxx xxxx xxxx
!
route-map outfilter permit 20
#########################################


CORE ROUTER1 which connects to UPSTREAM1 border router:
#########################################
router ospf 117
  log-adjacency-changes
  passive-interface Loopback0
  network x.x.0.64 0.0.0.31 area 0
  network x.x.0.96 0.0.0.31 area 0
  network x.x.0.128 0.0.0.31 area 0
  network x.x.0.160 0.0.0.31 area 0
  network x.x.0.192 0.0.0.31 area 0
  network x.x.3.0 0.0.0.255 area 0
  network x.x.5.0 0.0.0.255 area 0
  network x.x.9.0 0.0.0.255 area 0
  network x.x.10.0 0.0.0.255 area 0
!
router bgp xxxx
  no synchronization
  bgp log-neighbor-changes
  network x.x.0.0 mask 255.255.224.0
  neighbor ibgp-peers peer-group
  neighbor ibgp-peers remote-as xxxx
  neighbor ibgp-peers description iBGP peering for internal
  neighbor ibgp-peers update-source Loopback0
  neighbor ibgp-peers send-community
  neighbor x.x.5.2 peer-group ibgp-peers
  neighbor x.x.5.3 peer-group ibgp-peers
  neighbor x.x.5.4 peer-group ibgp-peers
  neighbor x.x.5.25 peer-group ibgp-peers
  distance bgp 200 200 200
  no auto-summary
!
ip classless
ip route x.x.0.0 255.255.224.0 Null0
!
!
#########################################

CORE ROUTER2 which connects to UPSTREAM2 border router:
#########################################
router ospf 117
  log-adjacency-changes
  passive-interface Loopback0
  network x.x.0.0 0.0.0.255 area 0
  network x.x.3.0 0.0.0.255 area 0
  network x.x.5.0 0.0.0.255 area 0
  network x.x.9.0 0.0.0.255 area 0
  network x.x.10.0 0.0.0.255 area 0
!
router bgp xxxx
  no synchronization
  bgp log-neighbor-changes
  network x.x.0.0 mask 255.255.224.0
  neighbor ibgp-peers peer-group
  neighbor ibgp-peers remote-as xxxx
  neighbor ibgp-peers description iBGP peering for internal
  neighbor ibgp-peers update-source Loopback0
  neighbor ibgp-peers send-community
  neighbor x.x.5.1 peer-group ibgp-peers
  neighbor x.x.5.2 peer-group ibgp-peers
  neighbor x.x.5.4 peer-group ibgp-peers
  neighbor x.x.5.25 peer-group ibgp-peers
  distance bgp 200 200 200
  no auto-summary
!
ip classless
!
#########################################
Do we need "ip route x.x.0.0 255.255.224.0 Null0" statement in above config?

I divided our network into different subnets in order to make load sharing 
work,
however I couldn't make redundancy work.
If one link goes down traffic will not switch to the other link. How can I 
make redundancy work?
Am I missing some configurations?
I appreciate if somebody can help me to configure routers in this regard.

thanks in advance,

Ganbold



More information about the cisco-nsp mailing list