[c-nsp] QoS on 837

Andris Zarins andris.zarins at microlink.lv
Thu Oct 27 14:57:51 EDT 2005


Check if there is any traffic matching your class maps - maybe marking
stuff isnt working and there are no packets marked with DSCP. For
example you can use 'show policy-map interface' command to see if any
trafifc matches your rules and how it is enqueued. Or you can apply some
ACL, like 


5   Ip access-list extended 100 permit ip any any dscp af31
10  Ip access-list extended 100 permit ip any any dscp ef
15  Ip access-list extended 100 permit ip any any 

to an interface and see if there are any matches for lines 5 and 10. If
there are matches and you can see correct statistics for 'show
policy-map interface' command - you can add for example shaping for all
traffic - to conform line rate, like:

class af31
match ip dscp af31
class ef
match ip dscp ef

policy-map dsl			- sets QOS actions for specific classes
class af31
bandwidth 16
class ef
priority 160

policy-map DSL			- sets QOS actions for all traffic
shape average 256
service-policy dsl

and then apply service-policy DSL to an interface you need. 


Hope that helps, 
Andris


-----Original Message-----
From: cisco-nsp-bounces at puck.nether.net
[mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of Voll, Scott
Sent: Thursday, October 27, 2005 9:12 PM
To: cisco-nsp at puck.nether.net
Subject: [c-nsp] QoS on 837

I would like to know if I did something on my QoS wrong.  Data is over
writing my Voice Traffic.

DSL is 256/256

IP Phone - 837 - DSL / ATM - 6509 - IP Phone

837 running 12.3(8)YG2
6509 running 12.2(18)SXE1

837 config:

class-map match-all VoIP-ctrl
 match ip dscp af31
 match ip precedence 3
class-map match-all VoIP
 match ip dscp ef
 match ip precedence 5
!
!
policy-map QoSWAN
 class VoIP
  priority 160
 class VoIP-ctrl
  bandwidth 16
 class class-default
  fair-queue
!
interface Ethernet0
 description DSL
 ip address 10.220.2.1 255.255.255.0
hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.32 point-to-point
 ip address 172.21.1.2 255.255.255.252
 atm route-bridged ip
 pvc 0/32
  vbr-nrt 256 256
  encapsulation aal5snap
  service-policy output QoSWAN

6509 config

class-map match-all VoIP-ctrl
  match access-group 151

class-map match-any VoIP
  match access-group 150
  match ip precedence 5

policy-map DSL_Voice
  class VoIP
    priority 160
  class VoIP-ctrl
    bandwidth 16
  class class-default
    fair-queue

interface ATM4/0/0.232 point-to-point
 description DSL to Scott Voll
 bandwidth 256
 ip address 172.21.1.1 255.255.255.252
 atm route-bridged ip
 service-policy output DSL_Voice
 pvc 2/32
  vbr-nrt 256 256
  tx-ring-limit 3
  encapsulation aal5snap

access-list 150 remark VoIP-Voice
access-list 150 permit ip any any precedence critical
access-list 150 permit ip any any dscp ef
access-list 151 remark VoIP-control
access-list 151 permit ip any any precedence flash
access-list 151 permit ip any any dscp af31
_______________________________________________
cisco-nsp mailing list  cisco-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/



More information about the cisco-nsp mailing list