[c-nsp] VoIP QoS on Cisco Routers

Jeremiah Millay jeremiah at rockriver.net
Wed Sep 28 18:53:38 EDT 2005


I've set up QoS on our office router for use with cisco 7960 phones. The 
phones connect to an external server. I guess I'd like to post my 
configs and get some feedback as to if I am doing QoS the right way. 
I've tried two variations of QoS. Not sure which is the most effective. 
Sometimes it seems as though it might not be working.
We are using the SIP protocol for call set up (UDP port 5060) and all of 
our voice RTP streams have been modified to use ports UDP 10000 through 
20000. I'm applying to the outbound interface on our router.
Here is my config:

ip access-list extended asterisktraffic
 remark RTP Streams
 permit udp any any range 10000 20000
 remark SIP Traffic
 permit udp any any eq 5060

!
class-map match-any VoIP
  match access-group name asterisktraffic
!

policy-map lowlatency
  class VoIP
   priority 1544
  class class-default
   fair-queue
!

interface Ethernet0
 description public
 ip address X.X.X.X X.X.X.X
 full-duplex
 service-policy output lowlatency
 no cdp enable
!




I've also tried working with this config:



access-list 105 permit udp any any range 10000 20000
access-list 105 permit udp any any eq 5060
access-list 106 permit tcp any any eq telnet
access-list 106 permit tcp any any eq 22
!
priority-list 1 protocol ip high list 105
priority-list 1 protocol ip medium list 106
!
!
interface Ethernet0
 description public
 ip address X.X.X.X X.X.X.X
 full-duplex
 priority-group 1
 no cdp enable
!

Any feed back is appreciated.
Jeremiah

-- 
Rock River Internet                            Jeremiah Millay
202 W. State St, 8th Floor              jeremiah at rockriver.net
Rockford, IL 61101                      815-968-9888 Ext. 2202
USA                                               fax 968-6888



More information about the cisco-nsp mailing list