[c-nsp] CBWFQ with bridging on 2821 ISR

Eric Helm helmwork at ruraltel.net
Wed Jan 4 10:40:20 EST 2006


My question is regarding CBWFQ on bridged 802.1q subinterfaces.
The setup is as follows:

               -- VLAN2 (INTERNET)
CPE FW-- 2821 --
               -- VLAN3 (PRIVATE LAN)

1 ethernet port carries 2 vlans, 1 for internet and 1 for a private lan
service to another location. The 2nd ethernet port is connected to the
customer Firewall. For reasons out of my control, the subnet for
Internet and the Private LAN must be the same, say a /24.
I have a Policy-Map for LLQ setup and it must be on the physical
interface, or I get the following error: "CBWFQ : Not supported on
subinterfaces"
Based on the config below with bridging enabled on one vlan and the
customer interface, will the LLQ policy apply to both subinterfaces and
work correctly?

class-map match-all EF-CLASS
 match ip dscp ef
!
!
policy-map LLQ-CHILD
 class EF-CLASS
  priority percent 75
 class class-default
  set ip dscp default
policy-map LLQ-POLICY
 class class-default
  shape average 3145728
  fair-queue
  service-policy LLQ-CHILD
!
!
!
bridge irb
!
!
!
interface GigabitEthernet0/0
 description EGRESS IF
 no ip address
 service-policy output LLQ-POLICY
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.3
 description Routed IF (Internet)
 bandwidth 3072
 encapsulation dot1Q 3
 ip address XXX
!
interface GigabitEthernet0/0.4
 description Bridged IF (Customer)
 encapsulation dot1Q 4
 bridge-group 1
!
interface GigabitEthernet0/1
 description Customer Access Port
 no ip address
 duplex auto
 speed auto
 bridge-group 1
!
interface BVI1
 ip address XXX
!
router ospf 1000
 log-adjacency-changes
 redistribute connected subnets
 redistribute static subnets
 network XXX area 0
!
ip classless
!
control-plane
!
bridge 1 protocol ieee

Thanks,
Eric


More information about the cisco-nsp mailing list