[c-nsp] cisco 3560 & Multicast

Sergey Velikanov [Intelsoft] sv at intelsoft.com
Mon Jan 23 22:00:24 EST 2006


Sergey Velikanov [Intelsoft] wrote:
> Hi
> 
> Currently we have multicast in our network, we use pim
> 
> interface Vlan139
>   ip address 192.168.20.113 255.255.255.248
>   ip access-group ipprotocols in
>   ip pim sparse-mode
> !
> interface Vlan140
>   ip address 192.168.25.153 255.255.255.248
>   ip access-group ipprotocols in
>   ip pim sparse-mode
> 
> ip pim rp-address 192.168.9.1
> 
> every thing works,
> 
> now we have connected to our partner(it provides digital tv) but partner do not use
> any multicast routing protocol, it requires that we sent igmp join message to each channel,
> how can I do  if any host in my network send igmp join message to specific group, it translate
> to partners port?


I was on right way, the problem was that my routers did not know path to source of multicast
(ip was out of my network) I've discovered that problem solved when I do smth. like

interface Vlan151
  description digitaltv
  ip address 10.0.0.5 255.255.255.252 secondary
  ip address 218.19.182.225 255.255.255.252
  ip pim sparse-mode
end

or

interface Vlan151
  description digitaltv
  ip address 218.19.182.225 255.255.255.252
  ip pim sparse-mode
end

ip route 10.0.0.5 255.255.255.255 218.19.182.226


What method is better?


More information about the cisco-nsp mailing list