[c-nsp] VPN

Shaun mailinglists at unix-scripts.com
Sat Sep 23 04:28:37 EDT 2006


I'm attempting to use a 7200 Series router as a VPN device to use with the 
default Windows XP client.  I'm not sure where I'm going wrong.  I did this 
once before but the Cisco device let me set the protocol to pptp and this 
device looks to not support that.  Below is what i have going so far... 
Where am i going wrong, right now the client just dumps a 800 error.  My 
goal incase it's not clear with the code below, is to allow remote users to 
connect to the VPN and access the network and world masked as 
FastEthernet2/0's interface ip.  Thanks in advance.


ip dhcp pool VPN
   network 192.168.0.0 255.255.255.0
   default-router 192.168.0.1
!
vpdn enable
!
vpdn-group L2TP
 accept-dialin
  protocol l2tp
  virtual-template 1
 no l2tp tunnel authentication
!
interface FastEthernet2/0
 ip address xxx.xxx.36.20 255.255.255.252
 ip nat outside
 no ip route-cache
 no ip mroute-cache
 full-duplex
 no cdp enable
!
interface FastEthernet2/1
 ip address 192.168.0.1 255.255.255.0
 ip nat inside
 no ip route-cache
 no ip mroute-cache
 half-duplex
!
interface Virtual-Template1
 ip unnumbered FastEthernet2/0
 ip mask-reply
 ip nat inside
 peer default ip address pool default
 ppp authentication ms-chap
!
ip local pool default 192.168.0.200 192.168.0.254
ip nat inside source list 1 interface FastEthernet2/0 overload
!
access-list 1 permit 192.168.0.0 0.0.0.255


-- 

~Shaun 





More information about the cisco-nsp mailing list