[c-nsp] DSL Bridging-to-PPPoE Configuration Help Please.

Jason Percle jasonp at teche.net
Fri Apr 20 14:08:30 EDT 2007


This is what I used when we migrated from bridged to PPPoE.  After this is
put into your router, of course after making your custom changes, this will
give you the benefit of having all customers still bridged and convert them
to PPP as you can. I have added notes in between some commands:


aaa new-model
aaa authentication ppp default group radius none
aaa authorization network default group radius none 
aaa accounting network default start-stop group radius

----------------------------------------------------------------------------
You can change radius instances to local to use the local user database if
you do not have access to a RADIUS or TACACS server.  Just make sure you
have usernames in the format of username at domain.  If you are moving to an
aggregated type of service such as Bellsouth's BBG, you must use the domain
that will be assigned to your BBG tunnel.  Also make sure you add an admin
username, because you will need to use it to login after enabling aaa
new-model.
----------------------------------------------------------------------------

!
username xxxxxxxx password xxxxxxxx
!
vpdn enable
!
vpdn-group 1
 accept-dialin
  protocol pppoe
  virtual-template 1
!
vpdn-group pppoe
!
vc-class atm 1
  protocol pppoe
  encapsulation aal5snap

----------------------------------------------------------------------------
Add a vc-class to be applied to the physical ATM interface, the settings
here will apply to all of your pvc's.
----------------------------------------------------------------------------

!
interface Loopback1
 ip address x.x.x.x x.x.x.x
!
interface ATM1/0
 description xxxxxxxxx 
 no ip address
 ip pim sparse-mode
 no ip route-cache
 no ip mroute-cache
 load-interval 30
 class-int 1	!Apply the vc-class from above
 atm vc-per-vp 256
 no atm ilmi-keepalive
 no scrambling-payload
!
interface Virtual-Template1
 ip unnumbered Loopback1
 no peer default ip address
 ppp authentication chap
 ppp ipcp dns x.x.x.x
!
ip local pool default x.x.x.x x.x.x.x
!
radius-server configure-nas
radius-server host x.x.x.x auth-port 1645 acct-port 1646 key xxxxxxxx
radius-server retransmit 3
radius-server attribute 8 include-in-access-req
radius-server attribute 25 nas-port format d
radius-server attribute nas-port format d
radius-server key xxxxxxxx
radius-server vsa send accounting
radius-server vsa send authentication


Jason

-----Original Message-----
From: cisco-nsp-bounces at puck.nether.net
[mailto:cisco-nsp-bounces at puck.nether.net] On Behalf Of spicer at bigskytel.com
Sent: Thursday, April 19, 2007 10:14 PM
To: cisco-nsp at puck.nether.net
Subject: [c-nsp] DSL Bridging-to-PPPoE Configuration Help Please.

Hello List,

Hopefully someone can help me. We run our DSL router in bridging mode as
shown below, we wish to migrate to PPPoE and do it an account at a time.

I have read through many hours of Cisco Docs along with looking at
configuration examples but for some reason no matter what I try I just can’t
get PPPoE to work much less along with our current bridging configuration
for migration. 
The DSL router is a 2620 with a 4port IMA card in it if that matters. 

Our network is pretty flat without any sub-netting, and we wish to stay with
public IP to our customers if possible.


Thanks,


Stephen Spicer




version 12.3
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname BSTDSLRTR
!
boot-start-marker
boot-end-marker
!
enable secret 5 XXXXXXXXXXXXXXXXXX
enable password XXXXXXXXX
!
no aaa new-model
ip subnet-zero
no ip rcmd domain-lookup
!
!
ip cef
!
!
bridge irb
!
!
interface ATM0/0
 dampening
 no ip address
 no ip route-cache cef
 no ip route-cache
 no ip mroute-cache
 no atm ilmi-keepalive
 bundle-enable
 ima-group 0
 no scrambling-payload
 hold-queue 224 in
!
interface ATM0/1
 dampening
 no ip address
 no ip mroute-cache
 no atm ilmi-keepalive
 bundle-enable
 ima-group 0
 no scrambling-payload
 hold-queue 224 in
!
interface ATM0/2
 no ip address
 shutdown
 no atm ilmi-keepalive
 clock source loop-timed
 no scrambling-payload
!
interface ATM0/3
 no ip address
 no ip mroute-cache
 shutdown
 no atm ilmi-keepalive
 no scrambling-payload
!
interface ATM0/IMA0
 no ip address
 no ip route-cache cef
 no ip route-cache
 no atm ilmi-keepalive
 !
! Most PVC entries below removed.
!
interface ATM0/IMA0.33 multipoint
 description customer33
 no ip route-cache
 bridge-group 1
 pvc 1/33
  encapsulation aal5snap
 !
!
interface ATM0/IMA0.34 multipoint
 description customer34
 no ip route-cache
 bridge-group 1
 pvc 1/34
  encapsulation aal5snap
 !
!
interface ATM0/IMA0.35 multipoint
 description customer35
 no ip route-cache
 bridge-group 1
 pvc 1/35
  encapsulation aal5snap
 !
!
interface ATM0/IMA0.36 multipoint
 description customer36
 no ip route-cache
 bridge-group 1
 pvc 1/36
  encapsulation aal5snap
 !
!
interface ATM0/IMA0.37 multipoint
 description customer37
 no ip route-cache
 bridge-group 1
 pvc 1/37
  encapsulation aal5snap
 !
!
interface ATM0/IMA0.38 multipoint
 description customer38
 no ip route-cache
 bridge-group 1
 pvc 1/38
  encapsulation aal5snap
 !
!
interface FastEthernet1/0
 ip address 67.135.51.20 255.255.255.0
 no ip mroute-cache
 speed 100
 full-duplex
 arp timeout 3600
 no cdp enable
 bridge-group 1
!
no ip http server
ip classless
!
!
access-list 1 permit 168.103.46.22
!
bridge 1 protocol ieee
!
!
dial-peer cor custom
!
!
!
gateway
!
!
line con 0
 exec-timeout 0 0
line aux 0
line vty 0 4
 access-class 1 in
 password XXXXXX
 login
!
!
end


-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.5.446 / Virus Database: 269.5.4/768 - Release Date: 4/19/2007
5:32 AM
 


_______________________________________________
cisco-nsp mailing list  cisco-nsp at puck.nether.net
https://puck.nether.net/mailman/listinfo/cisco-nsp
archive at http://puck.nether.net/pipermail/cisco-nsp/





More information about the cisco-nsp mailing list