[c-nsp] TE Config critique..

mb2 at os.datafx.com.au mb2 at os.datafx.com.au
Wed Feb 21 23:58:44 EST 2007


Hi,

Would like opinions on the following lab TE config's - pro's/con's of 
using explicit v dynamic path selection? (In production env. our links 
are 8Mb + 4Mb respectively), and whether ip load-sharing per-packet is 
needed?(And basically any other "best practices" that I have neglected 
to use!) - Goal is load-balance  traffic over the 8Mb + 4Mb links.

Thanks in advance.

### R1 ###

mpls label protocol ldp
no mpls ip propagate-ttl forwarded
mpls traffic-eng tunnels

interface Loopback1
ip address 192.168.1.1 255.255.255.255
!
interface Tunnel1
ip unnumbered Loopback1
tunnel destination 192.168.2.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng autoroute metric relative -1
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth  8000
tunnel mpls traffic-eng path-option 1 explicit name tun2

interface Tunnel2
ip unnumbered Loopback1
tunnel destination 192.168.2.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng autoroute metric relative -1
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth  4000
tunnel mpls traffic-eng path-option 1 explicit name tun1

interface FastEthernet0/0
ip address 192.168.10.1 255.255.255.0
ip load-sharing per-packet
duplex full
speed 100
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 4000 4000
!
interface FastEthernet0/1
ip address 192.168.11.1 255.255.255.0
ip load-sharing per-packet
duplex full
speed 100
mpls ip
mpls traffic-eng tunnels
ip rsvp bandwidth 8000 8000

router ospf 10
mpls traffic-eng router-id Loopback1
mpls traffic-eng area 0
router-id 192.168.1.1
log-adjacency-changes
redistribute connected subnets
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface FastEthernet0/1
network 192.168.10.0 0.0.0.255 area 0
network 192.168.11.0 0.0.0.255 area 0

!
ip explicit-path name tun1 enable
next-address 192.168.10.2 !
ip explicit-path name tun2 enable
next-address 192.168.11.2 !
!
!
mpls ldp router-id Loopback1


### R2 ###

mpls traffic-eng tunnels
no tag-switching ip propagate-ttl forwarded
tag-switching tdp router-id Loopback1

interface Loopback1
ip address 192.168.2.1 255.255.255.255

interface Tunnel1
ip unnumbered Loopback1
ip load-sharing per-packet
tunnel destination 192.168.1.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng autoroute metric relative -1
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth  8000
tunnel mpls traffic-eng path-option 1 explicit name tun2


interface Tunnel2
ip unnumbered Loopback1
ip load-sharing per-packet
tunnel destination 192.168.1.1
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng autoroute metric relative -1
tunnel mpls traffic-eng priority 7 7
tunnel mpls traffic-eng bandwidth  4000
  tunnel mpls traffic-eng path-option 1 explicit name tun1

interface FastEthernet0/0
ip address 192.168.10.2 255.255.255.0
ip load-sharing per-packet
duplex full
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 4000 4000

interface FastEthernet2/0
ip address 192.168.11.2 255.255.255.0
ip load-sharing per-packet
duplex full
mpls traffic-eng tunnels
tag-switching ip
ip rsvp bandwidth 8000 8000

router ospf 10
mpls traffic-eng router-id Loopback1
mpls traffic-eng area 0
router-id 192.168.2.1
log-adjacency-changes
redistribute connected subnets
passive-interface default
no passive-interface FastEthernet0/0
no passive-interface FastEthernet2/0
network 192.168.10.0 0.0.0.255 area 0
network 192.168.11.0 0.0.0.255 area 0

ip explicit-path name tun1 enable
next-address 192.168.10.1

ip explicit-path name tun2 enable
next-address 192.168.11.1



-------------------------------------------------------------------------
This e-mail was sent via Data FX Online WebMail http://www.datafx.com.au/




More information about the cisco-nsp mailing list