[c-nsp] Issues created by "ip address dhcp"

Tuc at T-B-O-H.NET ml at t-b-o-h.net
Fri Jul 13 14:15:29 EDT 2007


Hi,

	BTW: Thanks to everyone helping with my questions... I know I'm
going to get burnt bad since I'm doing a few weird things, as well as :

	1) Doing it on Friday the 13th.. I usually don't do anything on it.
	2) Its a Friday, and I usually NEVER do any network stuff on a Friday.
	3) I'm doing network changes at a remote site that if it goes down
		I have to RENT a jeep to get to it after a 9 hour drive

	SO.....

	I'm actually trying to implement :

		http://www.nil.si/ipcorner/SmallSiteMultiHoming/

	I have 1 connection to a local Wireless ISP on E0/0 . I have 1
connection to a satellite ISP on E1/0. I have E0/1 and E1/1 in a bridge
group with a 2924 hanging off each. SO, I did :

bridge irb

interface Ethernet0/0
 description SEABREEZE CONNECTIONS WIRELESS T-1
 ip address 192.168.75.49 255.255.255.0
 ip nat outside
 ip virtual-reassembly
 half-duplex
!         
interface Ethernet0/1
 description BRIDGE FOR 2924-1
 no ip address
 half-duplex
 bridge-group 1
!         
interface Ethernet1/0
 description HUGHES SATELLITE
 ip address dhcp
 ip nat outside
 ip virtual-reassembly
 shutdown 
 half-duplex
!         
interface Ethernet1/1
 description BRIDGE FOR 2924-2
 no ip address
 half-duplex
 bridge-group 1
!         
interface BVI1
 ip address 192.168.3.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly

ip route 0.0.0.0 0.0.0.0 192.168.75.1 10 name SEABREEZE
ip route 0.0.0.0 0.0.0.0 192.168.0.1 251 name HUGHES
!         
ip nat inside source route-map HUGHES interface Ethernet1/0 overload
ip nat inside source route-map SEABREEZE interface Ethernet0/0 overload
!         
logging 192.168.3.150
snmp-server community hackme RO
!         
route-map HUGHES permit 10
 match interface Ethernet1/0
!         
route-map SEABREEZE permit 10
 match interface Ethernet0/0
!         
bridge 1 protocol ieee
bridge 1 route ip

	I've run into 2 problems/issues (Hence why E1/0 is shutdown).


1) When I DHCP on E1/0, it doesn't care about my "ip route 0.0.0.0" statements,
it ends up with a static route out to E1/0.  I couldn't find a "ip address 
dhcp ignore-default-route" type command. Is there one? Or do I need to
do some sort of a route-map filter for default route? Can I do that with
dhcp? 

2) How do I properly code the "ip route 0.0.0.0" for the HUGHES connection.
I had to hardcode the next hop for the SEABREEZE since its not a point to
point connection. I need/want to do the same with the HUGHES, and I pretty
much KNOW the IP *SHOULD* be the 192.168.0.1 IP, but knowing my luck it
may/will change. I tried "ip route 0.0.0.0 0.0.0.0 e1/0 dhcp 251" but then it 
won't let me name the route (And I'm not sure if I ever end up DHCPing on
the SEABREEZE if it'll pick up the right one too).


		Thanks! Tuc


More information about the cisco-nsp mailing list