[c-nsp] BGPoPPPoEoA ?!

Gerald Krause gk at ax.tc
Thu Nov 15 14:30:46 EST 2007


On Thursday 15 November 2007 17:40:54 Adam Greene wrote:
> Lots of o's in that subject line ...
>
> I'm trying to set up a BGP session over a PPPoEoA DSL line. This is in the
> context of setting up redundant DSL lines to a single provider router. I
> control both ends (PE and CE). PE is 7200 NPE 200, IOS 12.3(15b). CE is
> 1841, IOS 12.4(17).
>
> I can't establish the BGP session. Both sides are in active state, but
> won't go further.
>
> The PE ATM interface is configured as IP unnumbered pointing to Loopback 0.
> The CE BGP neighbor thus points to the PE Loopback IP address. The PE BGP
> neighbor points to the IP address assigned to the CE Dialer (a /32 from the
> /23 block on the PE Loopback).
>
> I saw that the CE was reporting that the external BGP neighbor is not
> directly connected, so I issued "neighbor A.B.C.D disable-connected-check"
> to no avail.
>
> I tried specifying the update-source interface on both ends (loopback 0 on
> PE, Dialer1 on CE) again to no avail.
>
> I'm wondering if I have to do something at the neighbor A.B.C.D transport
> level, like disabling path-mtu-discovery (this is a wild shot in the dark).
>
> Has anyone else successfully established BGP over PPPoEoA before?

Yes, and it (still) works. As Aaron and Peter already mentioned you should 
use "ebgp-multihop" on both systems. Our config looks like this:

CE config:
==========
!
interface Dialer1
 ! local IP address is always 10.250.250.50/32 and
 ! remote-GW IP address 10.255.255.255 - from PPP/RADIUS
 ip address negotiated
 encapsulation ppp
 ...
!
!
router bgp 65534
 neighbor 10.255.255.255 remote-as 123
 neighbor 10.255.255.255 ebgp-multihop 2
 ...
!

PE config:
==========
!
interface Loopback101
 ip address 10.255.255.255 255.255.255.255
!
!
router bgp 123
 ...
  neighbor 10.250.250.50 remote-as 65534
  neighbor 10.250.250.50 ebgp-multihop 2
  neighbor 10.250.250.50 update-source Loopback101
 ...
!


-- 
Gerald   (ax/tc)


More information about the cisco-nsp mailing list