[c-nsp] 7600: etherchannel and aggregators
Dmitry Kiselev
dmitry at dmitry.net
Fri Sep 14 05:26:18 EDT 2007
Hello!
On Thu, Sep 13, 2007 at 10:21:38AM -0700, Michael K. Smith - Adhost wrote:
> Hello Dmitry:
>
> <snip>
>
> > Sep 13 18:38:00.091: idbman_get_agport: 14/4 Po2A(O)
> > Sep 13 18:37:59.762: %EC-SP-5-CANNOT_BUNDLE_LACP: Gi1/11 is not
> > compatible with aggregators in channel 2 and cannot attach to them
> > (trunk mode of Gi1/11 is trunk, Gi1/16 is dynamic)
>
>
> Are you sure Gi1/16 is really the same as the other's? The error
> message above would seem to indicate otherwise. Perhaps 'switchport
> nonegotiate' isn't in place?
I am really sure. Configs are *exactly* the same.
interface GigabitEthernet1/11
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active
!
interface GigabitEthernet1/12
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active
!
interface GigabitEthernet1/13
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active
!
interface GigabitEthernet1/14
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active
!
interface GigabitEthernet1/15
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active
!
interface GigabitEthernet1/16
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
channel-group 2 mode active
!
interface Port-channel2
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
Moreover g1/13-g1/16 was bundled about two month, but due
lack of bandwidth g1/11,g1/12 configured to be added.
Two other etherchannels used on this box (and same line card)
configured for no-DTP too.
interface Port-channel1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
interface Port-channel3
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
!
Router#sh etherc sum
Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator
M - not in use, minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
Number of channel-groups in use: 3
Number of aggregators: 4
Group Port-channel Protocol Ports
------+-------------+-----------+-----------------------------------------------
1 Po1(SU) LACP Gi1/43(P) Gi1/44(P) Gi1/45(P)
Gi1/46(P) Gi1/47(P) Gi1/48(P)
2 Po2(SU) LACP Gi1/13(P) Gi1/14(P) Gi1/15(P)
Gi1/16(P)
2 Po2A(SU) LACP Gi1/11(w) Gi1/12(w)
3 Po3(SU) LACP Gi1/1(P) Gi1/2(P) Gi1/3(P)
Gi1/4(D)
I activate more debug on SP and while reconfigure g1/11 got following
output:
Sep 14 12:21:23.300: FEC: pagp_switch_allocate_fecblock: Gi1/11
Sep 14 12:21:23.300: FEC: fec_user_enable: Gi1/11 allocating subblock with 2/6
Sep 14 12:21:23.300: Updated ptrunkgroup (2) of Gi1/11 for line cards.
Sep 14 12:21:23.300: FEC: pagp_switch_init_and_copy_fecblock: port Gi1/11
Sep 14 12:21:23.304: FEC: pagp_switch_config_new_member_added: Gi1/11 part of agport Po2
Sep 14 12:21:23.297: SP: pm_port_local_l3_agport_list: adding Gi1/11 Po2
Sep 14 12:21:53.040: FEC: pagp_switch_stay_shutdown: port Gi1/11 agport Po2
Sep 14 12:21:53.052: %LINK-3-UPDOWN: Interface GigabitEthernet1/11, changed state to down
Sep 14 12:21:53.240: FEC: pagp_switch_is_in_port_channel: Gi1/11 is not part of any agport
Sep 14 12:21:53.240: FEC: pagp_switch_is_in_port_channel: Gi1/11 is not part of any agport
Sep 14 12:21:53.240: FEC: pagp_switch_is_in_port_channel: Gi1/11 is not part of any agport
Sep 14 12:21:53.240: FEC: pagp_switch_is_in_port_channel: Gi1/11 is not part of any agport
Sep 14 12:21:59.976: SP: check_pagp_state: 1/11
Sep 14 12:21:59.976: SP: pm_sp_ec_port_unsuitable: 1/11(mode=2) tries to join in a channel.
Sep 14 12:21:59.976: SP: pm_ec_port_unsuitable: 1/11(mode=2) tries to join in a channel.
Sep 14 12:21:59.976: SP: pm_sp_idb_ec_attrib_diff: Gi1/11 Gi1/13;
Sep 14 12:21:59.976: SP: pm_ec_port_attrib_diff: Gi1/11 Gi1/13;
Sep 14 12:21:59.976: SP: FEC - Port mode is different from other ports (Gi1/13) in channel group
Sep 14 12:21:59.976: SP: pm_sp_idb_ec_attrib_diff: Gi1/11 Gi1/14;
Sep 14 12:21:59.976: SP: pm_ec_port_attrib_diff: Gi1/11 Gi1/14;
Sep 14 12:21:59.976: SP: FEC - Port mode is different from other ports (Gi1/14) in channel group
Sep 14 12:21:59.976: SP: pm_sp_idb_ec_attrib_diff: Gi1/11 Gi1/15;
Sep 14 12:21:59.976: SP: pm_ec_port_attrib_diff: Gi1/11 Gi1/15;
Sep 14 12:21:59.976: SP: FEC - Port mode is different from other ports (Gi1/15) in channel group
Sep 14 12:21:59.976: SP: pm_sp_idb_ec_attrib_diff: Gi1/11 Gi1/16;
Sep 14 12:21:59.976: SP: pm_ec_port_attrib_diff: Gi1/11 Gi1/16;
Sep 14 12:21:59.976: SP: FEC - Port mode is different from other ports (Gi1/16) in channel group
Sep 14 12:21:59.984: %LINK-3-UPDOWN: Interface GigabitEthernet1/11, changed state to up
Sep 14 12:22:00.256: idbman_get_agport: could not delete the swidb if_index
Sep 14 12:22:00.260: FEC: pagp_switch_is_in_port_channel: Po2A is not part of any agport
Sep 14 12:22:00.260: idbman_get_agport: 14/4 Po2A(O)
Sep 14 12:21:59.976: %EC-SP-5-CANNOT_BUNDLE_LACP: Gi1/11 is not compatible with aggregators in channel 2 and cannot attach to them (trunk mode of Gi1/11 is trunk, Gi1/16 is dynamic)
Sep 14 12:22:00.264: FEC: pagp_switch_is_in_port_channel: Po2A is not part of any agport
Sep 14 12:22:00.264: FEC: pagp_switch_is_in_port_channel: Po2A is not part of any agport
Sep 14 12:22:00.264: FEC: pagp_switch_is_in_port_channel: Po2A is not part of any agport
Sep 14 12:22:00.264: FEC: pagp_switch_is_in_port_channel: Po2A is not part of any agport
Sep 14 12:22:00.264: FEC: lacp_switch_notify_mp_of_subchannel: subchannel idb of Po2A
(whose primary idb is Po2) was added
Sep 14 12:22:00.260: SP: pm_bndl_new_agport: 14/4 Po2A
Sep 14 12:22:03.572: SP: pm_sp_idb_ec_attrib_diff: Gi1/11 Gi1/13;
Sep 14 12:22:03.572: SP: pm_ec_port_attrib_diff: Gi1/11 Gi1/13;
I also try to use another port (g1/21), but result is the same :(
Seems no fast answer is exists :( Going to open TAC case...
--
Dmitry Kiselev
More information about the cisco-nsp
mailing list