[c-nsp] QoS for VoIP to specific proxy

Ben Steele ben.steele at internode.on.net
Mon Jul 21 19:39:42 EDT 2008


Hi Nick,

You want something like this:

class-map match-all VoIP-Control
match protocol sip
match access-group 101

class-map match-all VoIP-Data
match dscp ef/match precedence 5/match protocol rtp **
match access-group 101

access-list 101 permit ip any host 202.x.VOIP.PROXY

policy-map QOS-OUT
class VoIP-Control
 bandwidth 60
class VoIP-Data
 priority percent 50
class class-default
 fair-queue 2048

then apply the policy-map to your interface like so "service-policy output 
QOS-OUT"

Make sure you have a bandwidth statement set on your interface "bandwidth x" 
where x is in kilobits.

The value in the classes under the policy-map: "bandwidth 60" is saying 
guarentee this much bandwidth in kilobits to this particular class.

The value in the classes under the policy-map: "priority percent 50" is 
saying give 50 percent of the bandwidth you specified in your bandwidth 
statement on your interface LLQ(low latency queuing) to this class, you want 
to use priority for your real time traffic (ie the rtp stream), bandwidth is 
fine for the normal control traffic and other traffic ie www etc. if you 
were wanting to prioritise that.

You would modify these bandwidth and priority values to your needs based on 
the number of simultaneous calls you plan to offer.

** pick one that best suits you, if your voip equipment is marking a tos bit 
then great, otherwise match protocol rtp should work unless you are on an 
old IOS.

You can't QoS inbound so to speak, best you can do is police traffic, I 
suggest you not worry about this for now as for VoIP to be effective the QoS 
has to be bi-directional so the other end should be matching you aswell.

Ben
----- Original Message ----- 
From: "Nick Voth" <nvoth at estreet.com>
To: <cisco-nsp at puck.nether.net>
Sent: Tuesday, July 22, 2008 5:39 AM
Subject: [c-nsp] QoS for VoIP to specific proxy


> Hello folks,
>
> Please pardon me asking what I'm sure has been answered before. I've 
> looked
> through the archives and the Cisco site, but I'm still confused about what 
> I
> need to do.
>
> I have a client who's Cisco 1841 CPE router needs to simply prioritize SIP
> traffic to and from a specific VoIP proxy.
>
> Let's say the VoIP proxy is 209.120.xxx.xxx
>
> The customer's current config on their 1841 is below. Can someone give me 
> an
> idea of how I can accomplish this? Remember, I just basically need 
> priority
> queuing of any traffic to and from that VoIP proxy listed above
>
> Thanks very much for any help!
>
> -Nick Voth
>
> ---------Customer's CPE config------------>>>>
> interface FastEthernet0/0
> ip address 67.101.xxx.xxx 255.255.255.248
> duplex auto
> speed auto
> no keepalive
> !
> !
> interface Serial0/0/0
> no ip address
> encapsulation frame-relay IETF
> no ip mroute-cache
> service-module t1 timeslots 1-24
> service-module t1 fdl both
> frame-relay lmi-type ansi
> !
> interface Serial0/0/0.1 point-to-point
> frame-relay interface-dlci 16 ppp Virtual-Template1
> !
> interface Virtual-Template1
> ip address negotiated
> ppp chap hostname xxxxx
> ppp chap password 7 01465656080E535773
> ppp ipcp dns request
> ppp ipcp route default
> ppp ipcp address accept
> ----------
>
>
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/
> 



More information about the cisco-nsp mailing list