[c-nsp] BGP Load Sharing

Jason Berenson jason at pins.net
Tue Jun 24 00:04:34 EDT 2008


Greetings,

I've got what should be a simple setup turned into something I can't 
quite wrap my head around.  I was hoping someone could point me in the 
right direction here.  I've attached a little sketch I did with paint 
since I'm really bad at ascii art.  Here's the layout:

1.  r1 and r2 peer with each other
2.  r1 and core1 peer (r1 is a 2621XM)
3.  r2 and core2 peer (r2 is a 1721)
4.  core 1 and core 2 peer (core routers are both 7206VXR running this 
customer network in a VRF

R1 is supposed to route the data network and R2 is supposed to route the 
voice network.  We've allocated 3 T1s for data and 2 for voice.  If 
either router or all T1s on either router go down then the one still 
standing should take on both the voice and data load.

The core is advertising out 192.168.100.0/24 and 10.10.10.0/24 as voice 
networks.  The data router is advertising 192.168.101.0/24 and the voice 
router is advertising 192.168.11.0/24.  I've tried to do this with 
route-maps and prefix lists but I'm kind of stuff.  We are also 
redistributing some OSPF routes into BGP until OSPF is phased out 
completely.   Here's the configurations I have so far (I've snipped 
irrelevant config):

R1:

interface Multilink1
description  DATA
ip address 10.3.3.146 255.255.255.252
ip helper-address 192.168.1.2
no cdp enable
ppp multilink
ppp multilink group 1
service-policy output voice
!
interface FastEthernet0/0
description connects to d1 p2
no ip address
speed 100
full-duplex
no cdp enable
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.101.253 255.255.255.0
no cdp enable
standby 1 ip 192.168.101.100
standby 1 timers 1 3
standby 1 preempt
standby 1 name ny-hq-data
!
interface FastEthernet0/0.11
encapsulation dot1Q 11
ip address 192.168.11.252 255.255.255.0
no cdp enable
standby 11 ip 192.168.11.254
standby 11 timers 1 3
standby 11 priority 95
standby 11 preempt
standby 11 name ny-hq-voice
!
router bgp 65501
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor 10.3.3.145 remote-as 7902
neighbor 10.3.3.145 route-map DataIn in
neighbor 10.3.3.145 route-map DataOut out
neighbor 192.168.101.251 remote-as 65501
neighbor 192.168.101.251 soft-reconfiguration inbound
no auto-summary
!
ip prefix-list cm-network seq 10 permit 192.168.100.0/24
!
ip prefix-list data-network seq 10 permit 192.168.101.0/24
!
ip prefix-list voice-network seq 10 permit 192.168.11.0/24
!
route-map DataIn permit 10
match ip address prefix-list cm-network
set local-preference 200
!
route-map DataIn permit 20
match ip address prefix-list voice-network
set local-preference 300
!
route-map DataOut permit 10
match ip address prefix-list data-network
set metric 200
!
route-map DataOut permit 20
match ip address prefix-list voice-network
set metric 300
!

R2:
interface Multilink1
ip address 10.3.3.202 255.255.255.252
no cdp enable
ppp multilink
ppp multilink group 1
service-policy output voice
!
interface FastEthernet0
description connects to d1 p1
no ip address
speed auto
no cdp enable
!
interface FastEthernet0.1
encapsulation dot1Q 1 native
ip address 192.168.101.251 255.255.255.0
no cdp enable
standby 1 ip 192.168.101.100
standby 1 timers 1 3
standby 1 priority 95
standby 1 preempt
standby 1 name ny-hq-data
!
interface FastEthernet0.11
encapsulation dot1Q 11
ip address 192.168.11.251 255.255.255.0
ip helper-address 192.168.100.14
no cdp enable
standby 11 ip 192.168.11.254
standby 11 timers 1 3
standby 11 preempt
standby 11 name ny-hq-voice
!
router bgp 65501
no synchronization
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor 10.3.3.201 remote-as 7902
neighbor 10.3.3.201 route-map VoiceIn in
neighbor 10.3.3.201 route-map VoiceOut out
neighbor 192.168.101.253 remote-as 65501
neighbor 192.168.101.253 soft-reconfiguration inbound
no auto-summary
!
ip prefix-list data-network seq 10 permit 192.168.101.0/24
!
ip prefix-list voice-network seq 10 permit 192.168.11.0/24
!
route-map VoiceOut permit 10
match ip address prefix-list voice-network
set metric 200
!
route-map VoiceOut permit 20
match ip address prefix-list data-network
set metric 300
!
route-map VoiceIn permit 10
match ip address prefix-list data-network
set local-preference 300
!
route-map VoiceIn permit 20
set local-preference 200
!

Core1:

interface Multilink10
description DATA
ip dhcp relay information trusted
ip vrf forwarding VRF
ip address 10.3.3.145 255.255.255.252
random-detect
no cdp enable
ppp multilink
ppp multilink group 10
!
interface GigabitEthernet0/1.118
description VLAN ID 118
encapsulation dot1Q 118
ip vrf forwarding VRF
ip address 192.168.100.11 255.255.255.0
no ip redirects
ip ospf priority 200
no cdp enable
!
router ospf 118 vrf VRF
router-id 192.168.100.11
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
redistribute bgp 7902 metric-type 1 subnets
network 10.3.0.0 0.0.255.255 area 0
network 192.168.254.0 0.0.0.255 area 254
network 192.168.0.0 0.0.255.255 area 0
default-information originate
!
router bgp ASN
no synchronization
bgp router-id IP
bgp log-neighbor-changes
bgp redistribute-internal
bgp suppress-inactive
timers bgp 5 30
address-family ipv4 vrf VRF
 redistribute connected
 redistribute static
 neighbor 10.3.3.146 remote-as 65501
 neighbor 10.3.3.146 activate
 neighbor 10.3.3.146 default-originate
 neighbor 10.3.3.146 soft-reconfiguration inbound
 neighbor 10.3.3.146 distribute-list Allow in
 neighbor 10.3.3.146 distribute-list AllowNone out
!
 neighbor 192.168.100.10 remote-as 7902
 neighbor 192.168.100.10 activate
 neighbor 192.168.100.10 soft-reconfiguration inbound
!
ip access-list standard Allow
deny   192.168.254.0 0.0.0.255
permit 192.168.0.0 0.0.255.255
!
ip access-list standard AllowNone
deny   any

Core 2:

interface Multilink13
description VOICE
ip vrf forwarding VRF
ip address 10.3.3.201 255.255.255.252
no cdp enable
ppp multilink
ppp multilink group 13
!
interface GigabitEthernet0/1.118
description VLAN ID 118
encapsulation dot1Q 118
ip vrf forwarding VRF
ip address 192.168.100.10 255.255.255.0
no ip redirects
ip ospf priority 200
no cdp enable
!
router ospf 118 vrf VRF
router-id 192.168.100.10
log-adjacency-changes
redistribute connected subnets
redistribute static subnets
redistribute bgp 7902 metric-type 1 subnets
network 10.3.0.0 0.0.255.255 area 0
network 192.168.254.0 0.0.0.255 area 254
network 192.168.0.0 0.0.255.255 area 0
default-information originate
!
router bgp ASN
no synchronization
bgp router-id IP
bgp log-neighbor-changes
bgp redistribute-internal
bgp suppress-inactive
timers bgp 5 30
address-family ipv4 vrf VRF
 redistribute connected
 redistribute static
 neighbor 10.3.3.202 remote-as 65501
 neighbor 10.3.3.202 activate
 neighbor 10.3.3.202 default-originate
 neighbor 10.3.3.202 soft-reconfiguration inbound
 neighbor 10.3.3.202 distribute-list Allow in
 neighbor 10.3.3.202 distribute-list AllowNone out
!
ip access-list standard Allow
deny   192.168.254.0 0.0.0.255
permit 192.168.0.0 0.0.255.255
!
ip access-list standard AllowNone
deny   any
!

If anymore information is needed please let me know.  Any help would be 
much appreciated.

Thanks,
Jason


More information about the cisco-nsp mailing list