[c-nsp] Frame to ATM

Joel Snyder Joel.Snyder at Opus1.COM
Tue May 27 23:40:41 EDT 2008


We do our FR->ATM a little differently than normal ATM->ATM.  I don't 
know if this is the most elegant way to do it, but here is a fragment on 
the ATM side the works.

interface ATM1/0.2037 point-to-point
  description PVC 34 to AirAuto 16/YBGA/001348 PVC 16
  bandwidth 1544
  ip address 207.182.63.117 255.255.255.252
  ip access-group FILTERFROMAIRAUTO in
  no snmp trap link-status
  pvc FR-Airauto 2/37
   vbr-rt 1544 1544
  !

Compare this to a typical ATM->ATM (we have two kinds: dynamic and static):


interface ATM1/0.151 point-to-point
  description Don Trumbo/dynamic
  ip policy route-map SET-PRECEDENCE
  no snmp trap link-status
  pvc Don-Trumbo 1/151
   class-vc radsl-dynamic

vc-class atm radsl-dynamic
   encapsulation aal5mux ppp Virtual-Template2
!
vc-class atm radsl-static
   encapsulation aal5mux ppp Virtual-Template1

interface Virtual-Template1
  description Used for static-addressed DSL
  mtu 2048
  ip unnumbered FastEthernet2/0
  logging event subif-link-status
  ppp authentication pap
!
interface Virtual-Template2
  description Used for dynamic-addressed DSL
  mtu 2048
  ip unnumbered FastEthernet2/0
  logging event subif-link-status
  peer default ip address pool dsldynamic
  ppp authentication pap callin


Jason Berenson wrote:
> Greetings,
> 
> We just got a new Covad DS3 and ordered an end T1 as frame relay.  The 
> backhaul is ATM.  Here's my network:
> 
> customer (dlci 16 and 17) --> covad cloud --> atm switch (0/xxx) --> atm 
> switch (0/xxx) --> cisco 7206 (atm pvc)
> 
> Here's what I did on the customer router:
> 
> interface Serial0
>  no ip address
>  encapsulation frame-relay IETF
>  no fair-queue
>  frame-relay lmi-type ansi
> !
> interface Serial0.1 point-to-point
>  frame-relay interface-dlci 17 ppp Virtual-Template17
> !
> interface Virtual-Template17
>  ip address 10.3.4.210 255.255.255.252
> !
> 
> Here's the core:
> 
> interface ATM3/0.26 point-to-point
>  pvc 0/70
>   ip addr inarp
>   protocol ppp Virtual-Template1000
>  !
> interface Virtual-Template1000
> ip address 10.3.4.209 255.255.255.252
> !
> 
> I'm not sure if this is going to work yet.  Has anyone done this 
> before?  If so, does this look right?
> 
> Thanks,
> Jason
> 
> _______________________________________________
> cisco-nsp mailing list  cisco-nsp at puck.nether.net
> https://puck.nether.net/mailman/listinfo/cisco-nsp
> archive at http://puck.nether.net/pipermail/cisco-nsp/

-- 
Joel M Snyder, 1404 East Lind Road, Tucson, AZ, 85719
Senior Partner, Opus One       Phone: +1 520 324 0494
jms at Opus1.COM                http://www.opus1.com/jms


More information about the cisco-nsp mailing list