[c-nsp] same-router tunnel loopback

Tim Durack tdurack at gmail.com
Fri Apr 3 16:14:40 EDT 2009


Using a same-router tunnel loopback to move traffic between global and
vrf on a SUP720:

rtr-1#sh run int tun254
Building configuration...

Current configuration : 251 bytes
!
interface Tunnel254
 vrf forwarding v101
 ip address 10.1.0.254 255.255.255.254
 ip mtu 1500
 ipv6 address FE80:0:1970::254 link-local
 ipv6 address xxxx:0:1970::254/127
 ipv6 enable
 tunnel source Loopback254
 tunnel destination 169.254.0.255
end

rtr-1#sh run int tun255
Building configuration...

Current configuration : 230 bytes
!
interface Tunnel255
 ip address 10.1.0.255 255.255.255.254
 ip mtu 1500
 ipv6 address FE80:0:1970::255 link-local
 ipv6 address xxxx:0:1970::255/127
 ipv6 enable
 tunnel source Loopback255
 tunnel destination 169.254.0.254
end


Works for ipv4:

rtr-1#ping 10.1.0.254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.0.254, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/8 ms


But not ipv6:

rtr-1#ping ipv6 xxxx:0:1970::254

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to xxxx:0:1970::254, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)


What am I doing wrong?


More information about the cisco-nsp mailing list